Bug 20527 - [G965 non-GEM] systray in KDE 4 completely broken
Summary: [G965 non-GEM] systray in KDE 4 completely broken
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL: http://cgit.freedesktop.org/xorg/driv...
Whiteboard:
Keywords: regression
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-03-07 12:25 UTC by walch.martin
Modified: 2009-03-10 12:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
broken icons in systray (1.47 KB, image/png)
2009-03-07 12:25 UTC, walch.martin
no flags Details
dmesg (28.83 KB, text/plain)
2009-03-07 12:34 UTC, walch.martin
no flags Details
/var/log/Xorg.0.log (109.14 KB, text/plain)
2009-03-07 12:35 UTC, walch.martin
no flags Details
/etc/X11/xorg.conf (2.04 KB, text/plain)
2009-03-07 12:36 UTC, walch.martin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description walch.martin 2009-03-07 12:25:55 UTC
Created attachment 23642 [details]
broken icons in systray

If you know KDE 4, you probably know about the broken systray icons: the background is garbled.

With current xf86-video-intel 2.6.3, the systray also does not show any icons. It switches between not showing anything and showing garbage (without distinguishing between fore- and background).

This was fine with 2.5.1. I bisected it to 6c0ca1676bf60529dd331cc739abdf68fa9e918d

System environment: 
 -- chipset: G965
 -- system architecture: 64-bit
 -- xf86-video-intel: 2.6.3
 -- xserver: 1.5.3
 -- mesa: 7.2
 -- libdrm: 2.4.5
 -- kernel: 2.6.27-gentoo-r8
 -- Linux distribution: Gentoo
 -- Machine or mobo model: Intel DG965SS
 -- Display connector: VGA/DE-15
 
more precisely:

The mainboard:
http://www.intel.com/Products/Desktop/Motherboards/DG965SS/DG965SS-overview.htm

uname -a:
Linux tacticalops 2.6.27-gentoo-r8 #10 SMP Sun Mar 1 17:18:33 CET 2009 x86_64 Intel(R) Core(TM)2 CPU 4300 @ 1.80GHz GenuineIntel GNU/Linux
Comment 1 walch.martin 2009-03-07 12:34:31 UTC
Created attachment 23643 [details]
dmesg
Comment 2 walch.martin 2009-03-07 12:35:34 UTC
Created attachment 23644 [details]
/var/log/Xorg.0.log
Comment 3 walch.martin 2009-03-07 12:36:12 UTC
Created attachment 23645 [details]
/etc/X11/xorg.conf
Comment 4 Gordon Jin 2009-03-07 17:34:07 UTC
Thanks for the bisect. So it's caused by:

author	Eric Anholt <eric@anholt.net>	2009-01-21 23:52:02 (GMT)
committer	Eric Anholt <eric@anholt.net>	2009-01-27 22:33:43 (GMT)
commit	6c0ca1676bf60529dd331cc739abdf68fa9e918d (patch)
Don't forget the new state bos in check_aperture.
They're tiny so it shouldn't have been a problem, but play it safe. This is another <5% loss on top of the previously reported value, bringing the whole series to about 8%. 
Comment 5 Eric Anholt 2009-03-09 22:05:13 UTC
Might check with:

commit fb6e00f40f713a87c760fc7603159ed11ea9b0d5
Author: Eric Anholt <eric@anholt.net>
Date:   Mon Mar 9 20:06:30 2009 -0700

    Fix XV with non-GEM kernels by allocating a larger fake bufmgr.
Comment 6 walch.martin 2009-03-10 02:57:07 UTC
After syncing to git master, it's working fine. :)

(I do not set the bug to resolved/fixed, because I do not know your policies for doing that)
Comment 7 Eric Anholt 2009-03-10 12:08:50 UTC
The policy is, if it's fixed upstream, go ahead and mark it fixed :)

Thanks for testing.  I'm pretty sure it was that commit.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.