Bug 20639 - [KMS] SDVO-TV not detected ( device connected to SDVOC)
[KMS] SDVO-TV not detected ( device connected to SDVOC)
Status: VERIFIED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
Other Linux (All)
: high enhancement
Assigned To: ykzhao
: patch
: 22653 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 20:46 UTC by liuhaien
Modified: 2009-09-18 00:22 UTC (History)
2 users (show)

See Also:


Attachments
dmesg (35.85 KB, text/plain)
2009-03-12 20:46 UTC, liuhaien
no flags Details
xorg.0.log (8.29 KB, text/plain)
2009-03-12 20:47 UTC, liuhaien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-03-12 20:46:28 UTC
Created attachment 23823 [details]
dmesg

system Environment:
--------------------------
Libdrm:		(master)82eac8060b98b425f29051bfd7830ba3622be7d8
Mesa:		(mesa_7_4_branch)45c4b4dfbd019260dd0df37ba6776c77149ec7ba	
Xserver:	(server-1.6-branch)f469726fec502ce29999eda6919c3c3d26c127d8
Xf86_video_intel:		(2.7)490cb578aef761e3fdd0a559bec36cdab96e6b2a
Connector:ADD2(S-video-->S-video)

Bug detailed description:
-------------------------
Current KMS couldn't detect SDVO-TV correctly. dmesg and xorg.0.log are attached.
Comment 1 liuhaien 2009-03-12 20:47:02 UTC
Created attachment 23824 [details]
xorg.0.log
Comment 2 Gordon Jin 2009-03-12 20:51:17 UTC
an unimplemented feature
Comment 3 Gordon Jin 2009-03-23 04:58:40 UTC
reopen to track this feature
Comment 4 Wang Zhenyu 2009-03-23 23:17:04 UTC
I sent patches to mail list too.
Comment 5 Wang Zhenyu 2009-03-24 20:28:01 UTC
As patches are out, mark this as fixed. Reopen if you have problem in testing.
Comment 6 liuhaien 2009-05-22 01:45:48 UTC
still cannot work.
Comment 7 ykzhao 2009-06-08 20:31:13 UTC
Hi, Haien
    Is the SDVO-TV detected in UMS mode?
    If so, please attach the output of xorg.log, vbios dump.
    Thanks.
Comment 8 MaLing 2009-06-14 22:21:20 UTC
Because our latest driver has latest tv detection patch, 
haien, could you please update and test it again

Thanks
Ma Ling 
Comment 9 liuhaien 2009-06-15 01:47:20 UTC
(In reply to comment #8)
> Because our latest driver has latest tv detection patch, 
> haien, could you please update and test it again
> 
> Thanks
> Ma Ling 
> 

I have tested it with the latest kernel. and it still fails.
but UMS works well.
Comment 10 liuhaien 2009-06-15 01:52:06 UTC
what I means is that TV isn't detected in KMS.I think anything about TV should show in dmesg. after start X, I cann't see any TV information in the Xorg.0.log and there is no display on TV-screen. but with the same card, X can start normally with UMS. 
Comment 11 Michael Fu 2009-06-23 21:30:21 UTC
ma ling said UMS has this problem as well. updated the summary line.
Comment 12 MaLing 2009-06-23 21:44:04 UTC
HaiEn
After updating  UMS code from our master tree, the issue also will occur, randomly the sdvo tv device is disconnect. The sdvo device care shows not reliable.
The symptom is the same with bug #20785 please try the patch 
http://bugs.freedesktop.org/attachment.cgi?id=26795


*** This bug has been marked as a duplicate of bug 20785 ***
Comment 13 MaLing 2009-06-25 05:17:07 UTC
(In reply to comment #12)
> HaiEn
> After updating  UMS code from our master tree, the issue also will occur,
> randomly the sdvo tv device is disconnect. The sdvo device care shows not
> reliable.
> The symptom is the same with bug #20785 please try the patch 
> http://bugs.freedesktop.org/attachment.cgi?id=26795
> *** This bug has been marked as a duplicate of bug 20785 ***

hi HaiEn

The patch from http://bugs.freedesktop.org/attachment.cgi?id=26795 works fine, so could you try it on the issue again?
thanks for your help
Ma Ling
Comment 14 Gordon Jin 2009-07-08 02:17:59 UTC
Let's track KMS issue (can't detect SDVO-TV) here, and track UMS issue (SDVO-TV connection unreliable) in bug#20785.
Comment 15 Gordon Jin 2009-07-08 02:20:47 UTC
*** Bug 22653 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fu 2009-07-30 18:23:27 UTC
isn't this fixed in 

commit 714605e4a05787c51a5ac36c926d2169cfdfbfba
Author: yakui_zhao <yakui.zhao@intel.com>
Date:   Sun May 31 17:18:07 2009 +0800

    drm/i915: Initialize the SDVO device based on the sdvo info parsed from VBT

    http://bugs.freedesktop.org/show_bug.cgi?id=20429

    Signed-off-by: Zhao Yakui <yakui.zhao@intel.com>
    [anholt: Massive cleanup of the slave addr function]
    Signed-off-by: Eric Anholt <eric@anholt.net>
Comment 17 Michael Fu 2009-07-30 18:25:53 UTC
sorry, ignore comment# 16. should be 

http://lists.freedesktop.org/archives/intel-gfx/2009-May/002508.html
Comment 18 ykzhao 2009-08-24 01:22:21 UTC
This is a regression caused by the following commit:
     commit 13520b051e8888dd3af9bda639d83e7df76613d1
Author: Kristian Høgsberg <krh at redhat.com>
Date:   Fri Mar 13 15:42:14 2009 -0400

    drm/i915: Read the right SDVO register when detecting SVDO/HDMI

The corresponding patch is already sent to intel-gfx mailing list.
   >http://lists.freedesktop.org/archives/intel-gfx/2009-August/003946.html

Thanks.
Comment 19 ykzhao 2009-08-24 19:06:21 UTC
The patch is already shipped in the Eric's drm-intel-next tree. 
  commit 27185ae1b795a4ba5e25b95fb5584e950545d774
Author: Ma Ling <ling.ma@intel.com>
Date:   Mon Aug 24 13:50:23 2009 +0800

    drm/i915: Always use SDVO_B detect bit for SDVO output detection

The bug can be resolved by this patch. So this bug will be marked as resolved.
Thanks.
Comment 20 fangxun 2009-09-18 00:22:03 UTC
Verified with following commits:
Libdrm:  (master)cdd325b59a17a614b90fc2f8b388175e6d79e3cf
Mesa:    mesa_7_6_branch)fac38e8c8f1814ae54703b872db8c6dd21c34a3b
Xserver:   (server-1.6-branch)3044711412d0a08ba65a491bd2441c0c8980f5e2
Xf86_video_intel: (master)b8c5c996e888485c3a16d645c8490592534a7882
Kernel: (master)74fca6a42863ffacaf7ba6f1936a9f228950f657