Bug 20670 - [945GM TV] 2.6.99.902 sets a too high CONTRAST-value
Summary: [945GM TV] 2.6.99.902 sets a too high CONTRAST-value
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-03-15 05:18 UTC by Peter Hjalmarsson
Modified: 2009-03-16 01:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Fix contrast and sat for 945G (1.08 KB, patch)
2009-03-15 19:29 UTC, Wang Zhenyu
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Hjalmarsson 2009-03-15 05:18:21 UTC
It seems that the defaults for TVout changed from 2.6 to 2.7.
Starting up X I get a picture that is WAY to light, and first after ssh'ing into the box and reducing the CONTRAST to about 50 (it is 96 from the start) with the help of xrandr I can start see more then the dark parts.

Maybe a error in the new logic calculating starting-values since these values became changeable?
Comment 1 Wang Zhenyu 2009-03-15 19:29:47 UTC
Created attachment 23893 [details] [review]
Fix contrast and sat for 945G

Could you try with this patch?
Comment 2 Peter Hjalmarsson 2009-03-16 00:29:11 UTC
That seems to give the result I was hoping for, thank you.
Comment 3 Wang Zhenyu 2009-03-16 00:34:04 UTC
Thanks, could you help to test changing contrast afterwards? I haven't 945G with TV by hand now to test more on this. 
Comment 4 Peter Hjalmarsson 2009-03-16 00:41:04 UTC
xrandr --output TV --set CONTRAST works as it should, 0 makes the screen nearly black and 255 makes it somewhat like it was without the patch.
Comment 5 Wang Zhenyu 2009-03-16 00:53:03 UTC
Thanks a lot. Pushed. Close.(I should really test this on real hw...)

commit 1a6e70cd98abc63f24f710819961c24601afb59b
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Mon Mar 16 10:19:39 2009 +0800

    TV: fix contrast and saturation for 945G

    Bug #20670.
Comment 6 Peter Hjalmarsson 2009-03-16 01:03:40 UTC
Maybe fix this on 2.7-branch also since this is a regression since 2.6?
Comment 7 Wang Zhenyu 2009-03-16 01:07:39 UTC
yeah, I'll ping cworth for this.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.