Bug 20863 - vt switching fails and crashes X
Summary: vt switching fails and crashes X
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL: https://qa.mandriva.com/show_bug.cgi?...
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-03-25 09:47 UTC by Klaas Vantournhout
Modified: 2009-04-08 09:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log after stopping the display manager (25.04 KB, text/plain)
2009-03-25 09:47 UTC, Klaas Vantournhout
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Klaas Vantournhout 2009-03-25 09:47:35 UTC
Created attachment 24238 [details]
Xorg.0.log after stopping the display manager

When in X and pressing ctrl-alt-f1, the display manager crashes furiously and
restarts returning back to the graphical login screen. It is impossible to turn
to vt1->6 since you in the end always end up with vt7.

When asking in the login screen (vt7) to restart X, the system crashes.

The card I am using is :

Card:Intel 810 and later: Intel Corporation|82Q35 Express Integrated Graphics
Controller [DISPLAY_VGA] (vendor:8086 device:29b2 subv:1028 subd:0211)

The xorg.conf entry reads

Section "Device"
    Identifier "device1"
    VendorName "Intel Corporation"
    BoardName "Intel 810 and later"
    Driver "intel"
    Option "DPMS"
EndSection

Operating system : mandriva cooker x86_64

The driver I am using is
x11-driver-video-intel-2.6.99.902-1.20090324.1mdv2009.1

This is what is written in /var/log/messages after ctrl-alt-f1

Mar 25 16:44:46 talvin10 klogd: X:3159 freeing invalid memtype
d0000000-e0000000
Mar 25 16:44:46 talvin10 klogd: [drm:i915_get_vblank_counter] *ERROR* trying to
get vblank count for disabled pipe 1
Mar 25 16:44:46 talvin10 kdm[3157]: X server for display :0 terminated
unexpectedly

The included attachment is the Xorg.0.log which was obtained by stopping the display manager (service dm stop) This is the only Xorg.0.log I could obtain.

After stopping dm, the only thing I obtained was a frozen screen. A little
white bar in the upright corner.

switching to vt1 to 6 fails.

restarting dm over ssh works
Comment 1 Gordon Jin 2009-03-25 19:14:17 UTC
Assuming this is regression, what's the previous version working for you?
Comment 2 Klaas Vantournhout 2009-03-26 04:22:53 UTC
The previous version I had was 2.6.3, that one "worked", 3D of kde hanged my system, but vt switching was normal.
Comment 3 Jesse Barnes 2009-03-26 12:48:34 UTC
Ah at first this wasn't making sense, but when I checked out the Mandriva report it started to... Sounds like with your display manager you may be running multiple servers?  I.e. when you login it starts a new server for you (fast user switching also does this).  So there could be a problem with starting two X servers and VT switching one of them.  Or the display manager could be using server generations (not exiting the server, just bringing it almost to a close then starting it up).  Can you check either of those theories?
Comment 4 Klaas Vantournhout 2009-03-30 15:44:12 UTC
Hi,

As far as I know, the display manager does not create multiple X sessions. The people of mandriva confirmed this.

However I can say that a revert to the 2.6.99.902 tarball removed the problems with vt switching. So maybe this could help with sorting things out.
Comment 5 Jesse Barnes 2009-03-30 15:59:07 UTC
Well, the backtrace looks awfully similar to a crash I fixed recently in unbind_memory, but it looks like you filed this bug after that was fixed.  But maybe you were running old git bits?  Can you try with git master from today (will require libdrm from git to build).
Comment 6 Jesse Barnes 2009-04-06 12:26:42 UTC
Any update here, Klaas?  Have you had a chance to try more recent git bits?
Comment 7 Klaas Vantournhout 2009-04-07 05:15:04 UTC
No sorry, I had some other priorities

I will have a look this evening or tomorrow.
Comment 8 Klaas Vantournhout 2009-04-08 05:02:36 UTC
The following intel driver was tested and did not show any problems regarding vt switching.

x11-driver-video-intel-2.6.99.903-0.20090406.1mdv2009.1.src.rpm
Comment 9 Jesse Barnes 2009-04-08 09:27:20 UTC
Great, thanks for confirming Klaas.  Closing this out.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.