Bug 20899 - Monitor disconnected while computer suspended, not disabled
Summary: Monitor disconnected while computer suspended, not disabled
Status: RESOLVED DUPLICATE of bug 21554
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xrandr (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other All
: medium normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-27 01:33 UTC by Frederik Himpe
Modified: 2009-07-20 15:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (105.72 KB, text/plain)
2009-03-27 01:36 UTC, Frederik Himpe
no flags Details
/etc/X11/xorg.conf (2.73 KB, text/plain)
2009-03-27 01:37 UTC, Frederik Himpe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2009-03-27 01:33:29 UTC
When I disconnect my external monitor while my system is suspended and then resume my system, the external monitor is not swiched off. xrandr notices the monitor is disconnected, but still continues to use the 1280x1024 resolution for it. Because of this my window manager (Metacity) still thinks the external monitor is there, leaving applications on the second, unavailable monitor.

Here is the xrandr output when the VGA monitor was removed while suspended:
# xrandr
Screen 0: minimum 320 x 200, current 2720 x 1024, maximum 2720 x 1024
VGA disconnected 1280x1024+1440+0 (normal left inverted right x axis y axis) 338mm x 270mm
LVDS connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+   40.0  
   1152x864       75.0  
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
TV disconnected (normal left inverted right x axis y axis)
  1280x1024 (0x41)  135.0MHz
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz

This is the xrandr output when the VGA monitor is connected:
Screen 0: minimum 320 x 200, current 2720 x 1024, maximum 2720 x 1024
VGA connected 1280x1024+1440+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0 +   75.0* 
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
   720x400        70.1  
LVDS connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+   40.0  
   1152x864       75.0  
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
TV disconnected (normal left inverted right x axis y axis)

System is a Dell Latitude E6400 laptop with this graphical chipset:
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
Comment 1 Frederik Himpe 2009-03-27 01:36:40 UTC
Created attachment 24305 [details]
Xorg.0.log

Xorg.0.log from affected system. The last-but-one suspend/resume cycle is the one when the external monitor was removed. During the last suspend/resume cycle, the VGA monitor was connected again.
Comment 2 Frederik Himpe 2009-03-27 01:37:47 UTC
Created attachment 24306 [details]
/etc/X11/xorg.conf
Comment 3 Federico Mena-Quintero 2009-07-20 15:00:45 UTC
This is fixed now that the X server re-probes the outputs when it comes back from suspend (actually, from any VT switch).  Marking as duplicate.

*** This bug has been marked as a duplicate of bug 21554 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.