Bug 2141 - The X server warning message when /dev/apm_bios can't be opened is misleading
Summary: The X server warning message when /dev/apm_bios can't be opened is misleading
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 3801 (view as bug list)
Depends on:
Blocks: 3116
  Show dependency treegraph
 
Reported: 2004-12-23 11:50 UTC by Mike A. Harris
Modified: 2005-07-16 00:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
kinder-gentler-apm-message-1.patch (780 bytes, patch)
2005-04-14 16:50 UTC, Adam Jackson
no flags Details | Splinter Review
kinder-gentler-apm-message-2.patch (797 bytes, patch)
2005-04-14 17:14 UTC, Adam Jackson
no flags Details | Splinter Review
kinder-gentler-apm-message-3.patch (1.05 KB, patch)
2005-04-24 17:06 UTC, Adam Jackson
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mike A. Harris 2004-12-23 11:50:52 UTC
When the X server starts, it attempts to open /dev/apm_bios normally,
in order to try to access APM services in the kernel.  If the kernel
has APM support built in or loaded, and configured, etc. then APM
support in the X server will generally work.

However, if the user does not have any need for APM support on their
machine and does not have it configured, or does not have a kernel
with APM support loaded, then the X server will not be able to
open /dev/apm_bios.  That is normal behaviour, and not a bug or
a problem of any kind.  In this case, the X server realizes that
it is unable to access the kernel's APM functions, and it just
disables APM support.

Users who do not want/need APM support don't need to know or care
about this.  However, the X server logs a line to the X server
log file when it is unable to open the APM device, which scares
a lot of users, who often think this is some kind of error, and
may be responsible for some random problem they are having with
the X server.

(WW) Open APM failed (/dev/apm_bios) (No such device)

Since the error message given above by the X server is not very
detailed or informative to the average user, it is not surprising
that many users consider this to be the cause of random problems,
when it is just a harmless message.  Most users probably don't even
know what APM is, and are thus even more likely to think this (WW)
warning is the cause of their problems.


Solution:

The above error message should be modified to be more informative
to users in the log file, and be downgraded from (WW) warning to
(II) info level.  Something like:

(II) Operating system APM services via /dev/apm_bios are unavailable,
     so APM power management features in the X server will not be
     used.  If you require APM power management features, please
     ensure your BIOS and operating system kernel are configured to
     provide APM services.  This message is just an informative
     message which can be safely ignored, and is not an error.
Comment 1 Mike A. Harris 2004-12-23 11:52:48 UTC
I'd like to have some opinions about this, and then unless there is
disagreement, I will make a patch unless someone beats me to it.

Also, feel free to suggest alternate wordings for the log message if
desired.
Comment 2 Adam Jackson 2004-12-28 09:13:43 UTC
users can and do think this.

between ACPI and DPMS, APM's userbase is shrinking every day.  downgrading this
to X_INFO isn't going to hurt anyone.
Comment 3 Adam Jackson 2005-04-14 16:50:58 UTC
Created attachment 2430 [details] [review]
kinder-gentler-apm-message-1.patch

more pleasant message
Comment 4 Adam Jackson 2005-04-14 17:14:59 UTC
Created attachment 2431 [details] [review]
kinder-gentler-apm-message-2.patch

post-bikeshed version of the same message
Comment 5 Adam Jackson 2005-04-14 17:19:18 UTC
applied to HEAD, closing.
Comment 6 Adam Jackson 2005-04-24 17:04:02 UTC
reopening, didn't change the right xf86MsgVerb call...
Comment 7 Adam Jackson 2005-04-24 17:06:55 UTC
Created attachment 2532 [details] [review]
kinder-gentler-apm-message-3.patch

back out the previous patch, fix the right xf86MsgVerb call.
Comment 8 Adam Jackson 2005-04-24 17:18:21 UTC
fixed for real this time, closing, sorry for the noise.
Comment 9 Adam Jackson 2005-07-17 10:16:35 UTC
*** Bug 3801 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.