Bug 22189 - [G41] Jaunty: HDMI connected but no valid modes
Summary: [G41] Jaunty: HDMI connected but no valid modes
Status: RESOLVED DUPLICATE of bug 21322
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: MaLing
QA Contact: Xorg Project Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-09 18:34 UTC by Robin Zhang
Modified: 2009-06-15 02:37 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (20.85 KB, text/plain)
2009-06-09 18:34 UTC, Robin Zhang
no flags Details
xorg.conf (950 bytes, text/plain)
2009-06-09 18:36 UTC, Robin Zhang
no flags Details
lspci.txt (19.52 KB, text/plain)
2009-06-09 18:37 UTC, Robin Zhang
no flags Details
lshal.txt (126.01 KB, text/plain)
2009-06-09 18:39 UTC, Robin Zhang
no flags Details
please try the patch against latest driver, thanks (1.44 KB, patch)
2009-06-10 22:53 UTC, MaLing
no flags Details | Splinter Review
please try the patch against latest driver, thanks (1.53 KB, patch)
2009-06-11 01:49 UTC, MaLing
no flags Details | Splinter Review
correct detect tv throught HDMI (17.95 KB, text/plain)
2009-06-13 07:35 UTC, Robin Zhang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Zhang 2009-06-09 18:34:17 UTC
Created attachment 26607 [details]
Xorg.0.log

PC connected with Sharp A33 LCD-TV (support 1360x768), but when starting X, it claimed: No valid modes.

Graphic Driver Versions:
 xserver-xorg-video-intel_2.7.1-0ubuntu1~xup~1_i386.deb
 or
 xserver-xorg-video-intel_2.6.3-0ubuntu9_i386.deb

Base System:
 Linux 2.6.28-11-generic
 xorg-server 2:1.6.0-0ubuntu14

Hardware:
 Intel G41 + ICH-7 (by MicroStar Co,ltd, Model: G41TM-E43 (MS-7592))
 Sharp 37A33 LCD-TV
 HDMI connected

Steps to replicate:
1. Set X's graphics driver using intel not vesa
2. restart X

[lspci]
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
 Subsystem: Micro-Star International Co., Ltd. Device 7592
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
 Subsystem: Micro-Star International Co., Ltd. Device 7592
Comment 1 Robin Zhang 2009-06-09 18:36:43 UTC
Created attachment 26608 [details]
xorg.conf
Comment 2 Robin Zhang 2009-06-09 18:37:23 UTC
Created attachment 26609 [details]
lspci.txt
Comment 3 Robin Zhang 2009-06-09 18:39:18 UTC
Created attachment 26610 [details]
lshal.txt
Comment 4 Michael Fu 2009-06-10 19:26:36 UTC
Robin, how about the DVI-D interface on this motherboard? does it work well on your Sharp TV or other DVI monitor? 
Comment 5 Robin Zhang 2009-06-10 21:05:05 UTC
(In reply to comment #4)
> Robin, how about the DVI-D interface on this motherboard? does it work well on
> your Sharp TV or other DVI monitor? 
> 

I have not any monitor using DVI interface, so cannot check it. 
Maybe I can check VGA interface to connect Sharp TV ?
Does this can help you ?
Thanks. 
Comment 6 Michael Fu 2009-06-10 22:50:04 UTC
have you tried Ubuntu 8.10 ?(In reply to comment #5)
> (In reply to comment #4)
> > Robin, how about the DVI-D interface on this motherboard? does it work well on
> > your Sharp TV or other DVI monitor? 
> > 
> 
> I have not any monitor using DVI interface, so cannot check it. 
> Maybe I can check VGA interface to connect Sharp TV ?
> Does this can help you ?
> Thanks. 
> 

no... how about Ubuntu 8.10?
Comment 7 MaLing 2009-06-10 22:53:13 UTC
Created attachment 26656 [details] [review]
please try the patch against latest driver, thanks
Comment 8 MaLing 2009-06-11 01:49:32 UTC
Created attachment 26664 [details] [review]
please try the patch against latest driver, thanks

Based on HDMI spec each HDMI source should provide HDMI identity, which is
stored in CEA extension, otherwise we may think it is not HDMI device. So we
also can detect HDMI device by trying to fetch EDID.

Thanks for your hellp.
Ma Ling
Comment 9 Robin Zhang 2009-06-13 07:32:38 UTC
(In reply to comment #8)
> Created an attachment (id=26664) [details]
> please try the patch against latest driver, thanks
> 
> Based on HDMI spec each HDMI source should provide HDMI identity, which is
> stored in CEA extension, otherwise we may think it is not HDMI device. So we
> also can detect HDMI device by trying to fetch EDID.
> 
> Thanks for your hellp.
> Ma Ling
> 

Yes, the patched versions (in my case, they are built from version 2.7.1 and 2.7.99.901+git20090610.9d3c3b05) can detect my TV and can set resolution to 1360x768 @ 60Hz.

 xrandr report:

Screen 0: minimum 320 x 200, current 1360 x 768, maximum 1360 x 1360
VGA disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1360x768+0+0 (normal left inverted right x axis y axis) 820mm x 460mm
   1360x768 60.0*+
   1024x768 60.5 60.0
   800x600 60.3
   640x480 59.9
   720x400 70.1
Comment 10 Robin Zhang 2009-06-13 07:35:22 UTC
Created attachment 26760 [details]
correct detect tv throught HDMI
Comment 11 MaLing 2009-06-15 02:37:24 UTC

*** This bug has been marked as a duplicate of bug 21322 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.