Bug 21322 - [G43 DVI] Can't open DVI display
[G43 DVI] Can't open DVI display
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) Linux (All)
: high major
Assigned To: MaLing
Xorg Project Team
: patch
: 22189 22497 22871 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 07:44 UTC by Eric Zhang
Modified: 2009-07-29 19:03 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
including xorg.conf, Xorg.log.0(ModeDebug enabled), uname, dmesg, package infos (14.12 KB, application/octet-stream)
2009-04-21 07:44 UTC, Eric Zhang
no flags Details
One single file includes xorg log, xorg conf, uname, dmesg... (55.13 KB, text/plain)
2009-04-21 19:10 UTC, Eric Zhang
no flags Details
please try the patch on your machine, thanks. (554 bytes, application/octet-stream)
2009-04-21 23:01 UTC, MaLing
no flags Details
New error log (21.83 KB, application/octet-stream)
2009-04-22 07:28 UTC, Eric Zhang
no flags Details
please try the patch on your machine, thanks. (487 bytes, application/octet-stream)
2009-04-26 23:07 UTC, MaLing
no flags Details
New error log, xorg.conf is attached on the bottom of file (24.36 KB, application/octet-stream)
2009-04-27 08:00 UTC, Eric Zhang
no flags Details
please try this debug patch on your machine, then upload log with modedebug option on, thanks. (411 bytes, application/octet-stream)
2009-04-27 19:17 UTC, MaLing
no flags Details
Xorg.0.log (62.80 KB, application/octet-stream)
2009-04-28 07:22 UTC, Eric Zhang
no flags Details
rom.bin file (64.00 KB, application/octet-stream)
2009-04-28 07:24 UTC, Eric Zhang
no flags Details
Eric, please try the debug patch on your machine ,thanks (626 bytes, application/octet-stream)
2009-05-10 01:05 UTC, MaLing
no flags Details
Eric, pleaes try the debug patch on your machine, thanks. (958 bytes, application/octet-stream)
2009-05-10 18:32 UTC, MaLing
no flags Details
New xorg.0.log (21.88 KB, text/x-log)
2009-05-11 06:54 UTC, Eric Zhang
no flags Details
hi Eric, could you please try the debug patch on your machine, thanks. (752 bytes, application/octet-stream)
2009-05-20 20:27 UTC, MaLing
no flags Details
Xorg.0.log (21.88 KB, application/octet-stream)
2009-05-21 07:12 UTC, Eric Zhang
no flags Details
Eric, please try the debug patch against latest driver (1.47 KB, text/plain)
2009-06-11 01:45 UTC, MaLing
no flags Details
Xorg.log with patch applied (8.23 KB, text/x-log)
2009-06-29 11:50 UTC, Achim Frase
no flags Details
error i830_hdmi.c.rej (863 bytes, application/octet-stream)
2009-06-29 11:51 UTC, Achim Frase
no flags Details
pleaset try the patch on your machine, thanks. (330 bytes, text/plain)
2009-06-30 05:52 UTC, MaLing
no flags Details
Xorg.log with debug.patch (8.13 KB, text/plain)
2009-06-30 06:29 UTC, Achim Frase
no flags Details
pleaset try the patch on your machine, thanks. (467 bytes, text/plain)
2009-07-02 02:57 UTC, MaLing
no flags Details
Xorg.0.UMS.2.6.30.log (22.32 KB, text/plain)
2009-07-02 08:48 UTC, Achim Frase
no flags Details
Xorg.0.log using UMS and debug option enbaled (69.81 KB, text/plain)
2009-07-02 14:50 UTC, Mahmut Izci
no flags Details
Xorg.0.UMS.2.6.31 (76.02 KB, text/x-log)
2009-07-03 01:00 UTC, Achim Frase
no flags Details
UMS with hdmi_detect_edid_debug.patch applied (76.24 KB, text/x-log)
2009-07-03 01:34 UTC, Achim Frase
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Zhang 2009-04-21 07:44:01 UTC
Created attachment 24999 [details]
including xorg.conf, Xorg.log.0(ModeDebug enabled), uname, dmesg, package infos

I have a G43 chipset with x4500 display card embedded. Using xf86-video-intel 2.6.x, DVI(DVI-D) display can't be opened so the X server can't start.

Check the attachment for details. It includes xorg.conf(ModeDebug enabled), Xorg.log.0, uname outputs, dmesg, xrandr --verbose outputs and package infos.

I have installed the xf86-video-intel 2.7 version today but it still doesn't work.

I'm looking forward to your patches, otherwise I can't start my work under Linux. :)
Comment 1 Gordon Jin 2009-04-21 18:37:40 UTC
I wished you really go through http://intellinuxgraphics.org/how_to_report_bug.html and not use zipped attachment.

What's your G43 motherboard model? Does it have VGA port?
Comment 2 Eric Zhang 2009-04-21 19:01:18 UTC
(In reply to comment #1)
> I wished you really go through
> http://intellinuxgraphics.org/how_to_report_bug.html and not use zipped
> attachment.
> 
> What's your G43 motherboard model? Does it have VGA port?
> 

The motherboard is ASUS P5QL-EM. Yes, it has a VGA port. Actually, there are 3 ports available on this board: VGA, DVI-D, HDMI.

Comment 3 Eric Zhang 2009-04-21 19:10:59 UTC
Created attachment 25019 [details]
One single file includes xorg log, xorg conf, uname, dmesg...
Comment 4 MaLing 2009-04-21 23:01:37 UTC
Created attachment 25024 [details]
please try the patch on your machine, thanks.

I guess the issue is duplicate with bug #20429, so please try the debug patch.

thanks
maling
Comment 5 Eric Zhang 2009-04-22 07:28:02 UTC
Created attachment 25034 [details]
New error log

With no lucky, seems the patch doesn't work. Here's the new Xorg.0.log file.
Comment 6 MaLing 2009-04-26 23:07:29 UTC
Created attachment 25174 [details]
please try the patch on your machine, thanks.

the reason is from incorrect hdmi detection, please try the patch on your machine.
thanks
maling
Comment 7 Eric Zhang 2009-04-27 08:00:09 UTC
Created attachment 25188 [details]
New error log, xorg.conf is attached on the bottom of file

Still unlucky, the X can't start again. My step is:

1. download xf86-video-intel 2.7.0 source from git
2. cd source dir, patch the source: patch -p1 < 21322_debug.patch
3. ./autogen --prefix=/usr
4. make
5. make install -- check the file under /usr/lib/xorg/drivers/intel are updated
6. Xorg -configure -- generate a xorg.conf.new in /root
7. Edit /root/xorg.conf.new, turn on ModeDebug, add DefaultDepth 24, Modes "1440x900"
8. X -config /root/xorg.conf.new -- X started failed

BTW: I tried to patch these 2 patches, the result is also failed. The error log attached is the version I only patched 21322_debug.patch on the source.
Comment 8 MaLing 2009-04-27 19:17:56 UTC
Created attachment 25210 [details]
please try this debug patch on your machine, then upload log with modedebug option on, thanks.

Meanwhile please provide the vbios dump via:

# cd /sys/devices/pci0000\:00/0000\:00\:02.0/
# echo 1 > rom
# cat rom > /tmp/rom.bin
# echo 0 > rom

then submit the rom.bin here.
thanks for your help.
maling
Comment 9 zhao jian 2009-04-28 00:34:32 UTC
Maybe you could have a try of plug your display port again, make sure it has connected tight enough. I have the same issue and just reconnect the HDMI and it works well now.
Comment 10 Eric Zhang 2009-04-28 07:22:48 UTC
Created attachment 25228 [details]
Xorg.0.log

Hi, guys. Here comes the good news. The X started successfully after this new patch has applied. And now my KDE works well too.

Ma Ling, as you mentioned, I uploaded this new Xorg.0.log, check it. Thanks for your hard work.

Also thanks to Zhao Jian, but obviously this is not because the DVI cable isn't plugged well. I installed windows in my machine and the DVI outputs work well under windows all the time.

I think maybe this is a temporary patch so, if any tests or other stuffs are needed to perform, just feel free to let me know.
Comment 11 Eric Zhang 2009-04-28 07:24:07 UTC
Created attachment 25229 [details]
rom.bin file
Comment 12 MaLing 2009-05-10 01:05:28 UTC
Created attachment 25685 [details]
Eric, please try the debug patch on your machine ,thanks
Comment 13 MaLing 2009-05-10 18:32:33 UTC
Created attachment 25709 [details]
Eric, pleaes try the debug patch on your machine, thanks.
Comment 14 Eric Zhang 2009-05-11 06:54:07 UTC
Created attachment 25728 [details]
New xorg.0.log

Hi, Ma Ling. This patch doesn't work. I attached the Xorg.0.log here, check it pls.
Comment 15 MaLing 2009-05-20 20:27:54 UTC
Created attachment 26045 [details]
hi Eric, could you please try the debug patch on your machine, thanks.
Comment 16 Eric Zhang 2009-05-21 07:12:02 UTC
Created attachment 26069 [details]
Xorg.0.log

Seems patch doesn't work. Check the new Xorg.0.log, pls.
Comment 17 MaLing 2009-05-25 05:50:09 UTC
hi Eric
I have similar motherboard with you --Asus P5Q-EM, ATX. Today I encountered the same issue, but after I turned off system, pluged HDMI cable out of machine, and re-pluged it, then reboot system, the issue disappeared. Could you help us to try the above process?

Thanks for your help
Ma Ling
Comment 18 Eric Zhang 2009-05-28 19:02:18 UTC
Hi, Ma Ling:

    I tried the method you mentioned, the result is: failed. Here are my steps:

1. Compile and install the xf86-video-intel 2.7.0 with the latest patch you provided.
2. Re-plug the DVI cable and reboot the system. The X started failed.
3. On the command line, re-plug the DVI cable, and test with "X -config /etc/xorg/xorg.conf", the X started failed.

    Any other ideas? Thanks a lot.

Eric
Comment 19 MaLing 2009-06-08 23:13:37 UTC
Hi Eric

The issue is very strange to me, now I can not reproduce it in Asus P5Q-EM platform, so would you please like to download our latest driver from master tree, then try it?

Thanks for your help.
Ma Ling
  
Comment 20 Gordon Jin 2009-06-09 15:37:09 UTC
I'm confused. Since there's a patch working as comment#10 said, why does ling need Eric to try master?
Comment 21 MaLing 2009-06-09 18:18:00 UTC
(In reply to comment #20)
> I'm confused. Since there's a patch working as comment#10 said, why does ling
> need Eric to try master?

The patch in comments #8 is only debug patch to confirm the issue, it is not really resolved. And several days ago I could reproduce it in Asus P5Q-EM platform , but now it always work, so I suggest Eric to update his driver from our master tree.

Thanks
Ma Ling
Comment 22 Gordon Jin 2009-06-09 18:24:49 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > I'm confused. Since there's a patch working as comment#10 said, why does ling
> > need Eric to try master?
> The patch in comments #8 is only debug patch to confirm the issue, it is not
> really resolved. 

But that patch does make it work, so I thought it should give you good clue.
Comment 23 MaLing 2009-06-09 18:29:25 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > I'm confused. Since there's a patch working as comment#10 said, why does ling
> > > need Eric to try master?
> > The patch in comments #8 is only debug patch to confirm the issue, it is not
> > really resolved. 
> But that patch does make it work, so I thought it should give you good clue.

The patch is hard code , in fact it can not dynamically detect hdmi connection, we can not accept it.
Comment 24 MaLing 2009-06-11 01:45:24 UTC
Created attachment 26663 [details]
Eric, please try the debug patch against latest driver

Based on HDMI spec each HDMI source should provide HDMI identity, which is stored in CEA extension, otherwise we may think it is not HDMI device. So we also can detect HDMI device by trying to fetch EDID.

Thanks for your hellp.
Ma Ling
Comment 25 Eric Zhang 2009-06-14 06:20:04 UTC
Hi, Ma Ling. Sorry for the late reply. It's a good news. Test passed. Here is the details:

1. I downloaded the latest master branch source codes, compile and install. But when starting X server, it failed.

2. Then I patched the patch you provided and tried again, this time it works. Great.

Thanks for your hard work. You did a great job.

By the way, should I close this bug?

Eric Zhang
Comment 26 MaLing 2009-06-15 02:37:24 UTC
*** Bug 22189 has been marked as a duplicate of this bug. ***
Comment 27 MaLing 2009-06-22 06:47:42 UTC
(In reply to comment #25)
> Hi, Ma Ling. Sorry for the late reply. It's a good news. Test passed. Here is
> the details:
> 1. I downloaded the latest master branch source codes, compile and install. But
> when starting X server, it failed.
> 2. Then I patched the patch you provided and tried again, this time it works.
> Great.
> Thanks for your hard work. You did a great job.
> By the way, should I close this bug?
> Eric Zhang

Thanks for your help, we will close it until patch is committed into our tree :)
Comment 28 MaLing 2009-06-28 20:37:24 UTC
*** Bug 22497 has been marked as a duplicate of this bug. ***
Comment 29 Achim Frase 2009-06-29 11:49:50 UTC
(In reply to comment #28)
> *** Bug 22497 has been marked as a duplicate of this bug. ***

Hello Ma Ling,

I have tried you patch but without success.

This is what I have done

1. git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-intel

2. patch -p1 -i ../hdmi_detect_edid_debug.patch

patching file src/i830_hdmi.c
Hunk #2 FAILED at 172.
Hunk #3 succeeded at 212 (offset 8 lines).
1 out of 3 hunks FAILED -- saving rejects to file src/i830_hdmi.c.rej

The patch did not apply cleanly but I looked through i830_hdmi.c and compared it with the changes that the patch should apply and everything looked okay.

3. ./autogen.sh --prefix=/usr
make
make install

4. I also checked that the files in /usr/lib/xorg/modules/drivers/ are new.
-rwxr-xr-x 1 root root  985 2009-06-29 20:07 intel_drv.la
-rwxr-xr-x 1 root root 3,4M 2009-06-29 20:07 intel_drv.so

After restarting the system with my DVI cable pluged in the error still persists (VGA cable was not unpluged).

I hope I did everything right. I will attach Xorg.0 patched.log and i830_hdmi.c.rej

regards
Achim
Comment 30 Achim Frase 2009-06-29 11:50:53 UTC
Created attachment 27227 [details]
Xorg.log with patch applied
Comment 31 Achim Frase 2009-06-29 11:51:52 UTC
Created attachment 27228 [details]
error i830_hdmi.c.rej
Comment 32 MaLing 2009-06-30 05:52:54 UTC
Created attachment 27263 [details]
pleaset try the patch on your machine, thanks.

this is a only dummy patch, please try it and upload your xorg log file with modedebug optoin on in UMS.

Thanks
Ma Ling
Comment 33 Achim Frase 2009-06-30 06:29:57 UTC
Created attachment 27265 [details]
Xorg.log with debug.patch

I hope the log has the necessary information. I was not sure what UMS is. I couldn't find any information at the freedesktop.org/wiki.
Comment 34 Geir Ove Myhr 2009-07-01 19:39:43 UTC
I'm guessing UMS means Userland ModeSetting (as opposed to Kernel ModeSetting). From the device names in Xorg.0.log it looks like you are using KMS (DVI1 instead of DVI-1). Using UMS can be done like this (taken from ubuntu: https://lists.ubuntu.com/archives/ubuntu-x/2009-June/000578.html)

How do we revert back to non-KMS?  Boot the kernel with the
option i915.modeset=0 on your kernel command line.

The ModeDebug part is supposed to go in xorg.conf. Add the following line to the "Device" section in xorg.conf:
  Option "ModeDebug" "true"
Comment 35 MaLing 2009-07-02 02:57:34 UTC
Created attachment 27330 [details]
pleaset try the patch on your machine, thanks.

Thanks for  Geir Ove Myhr's exact reply !
The patch is dummy code, which will return connect status for HDMI output.
please try it in UMS and upload log file with modedebug option on.

Thanks
Ma Ling
Comment 36 Achim Frase 2009-07-02 08:48:57 UTC
Created attachment 27339 [details]
Xorg.0.UMS.2.6.30.log

Thanks Geir Ove Myhr and Ma ling for your advice.

I hope that I have done everything right this time.

Regards
Achim
Comment 37 Mahmut Izci 2009-07-02 14:46:41 UTC
(In reply to Bug 22497)
(DVI port not detected on MSI G45M Digital motherboard)

I switched off KMS (as Geir Ove Myhr mentioned) and applied this patch 
"http://bugs.freedesktop.org/attachment.cgi?id=26663" to 2.7.1 and now it works!!
DVI port is detected. Xorg.0.log with debug option enabled is attached.
But this patch still not works with KMS.

Another possible solution to the problem is using an additional DVI port 
on an ADD2 card. This works without patch and even with KMS.

Thanks and Regards
Mahmut

Comment 38 Mahmut Izci 2009-07-02 14:50:24 UTC
Created attachment 27346 [details]
Xorg.0.log using UMS and debug option enbaled
Comment 39 MaLing 2009-07-02 20:00:32 UTC
(In reply to comment #36)
> Created an attachment (id=27339) [details]
> Xorg.0.UMS.2.6.30.log
> Thanks Geir Ove Myhr and Ma ling for your advice.
> I hope that I have done everything right this time.
> Regards
> Achim

hi  Achim Frase, I doubt you doesn't use the patch in comments 35 correctly, because it is dummy code and force hdmi connect ?
Thanks
Ma Ling
Comment 40 Achim Frase 2009-07-03 01:00:25 UTC
Created attachment 27361 [details]
Xorg.0.UMS.2.6.31

Hi Ma Ling,

now DVI works with UMS with your patch from comment 35. You were right it was my fault, I have forgotten to use --prefix=/usr at configure time.

regards
Achim
Comment 41 MaLing 2009-07-03 01:07:11 UTC
o(In reply to comment #40)
> Created an attachment (id=27361) [details]
> Xorg.0.UMS.2.6.31
> Hi Ma Ling,
> now DVI works with UMS with your patch from comment 35. You were right it was
> my fault, I have forgotten to use --prefix=/usr at configure time.
> regards
> Achim

great! please try the below patch again after removing that patch in comments #35.

http://bugs.freedesktop.org/attachment.cgi?id=26663

Thanks a lot
Ma Ling
Comment 42 Achim Frase 2009-07-03 01:34:18 UTC
Created attachment 27362 [details]
UMS with hdmi_detect_edid_debug.patch applied

>great! please try the below patch again after removing that patch in comments
>#35.
>http://bugs.freedesktop.org/attachment.cgi?id=26663
>Thanks a lot
>Ma Ling

DVI is still working with your patch :-)
One side note, it seems that the time until I see GDM took a bit longer but I think that will change with KMS.

Do I understand it correct, that KMS needs extra patches to get DVI working?

Thanks for your help.
Achim
Comment 43 MaLing 2009-07-15 19:33:39 UTC
*** Bug 22717 has been marked as a duplicate of this bug. ***
Comment 44 MaLing 2009-07-23 21:22:30 UTC
*** Bug 22871 has been marked as a duplicate of this bug. ***
Comment 45 MaLing 2009-07-29 19:03:56 UTC
commit 2ded9e2747d0a390d281bb5b16ff7f640ec85f78
Author: ling.ma@intel.com <ling.ma@intel.com>
Date:   Thu Jul 16 17:23:09 2009 +0800

fixed, please update your kernel version from drm-intel-next tree.
close issue please open it if you need.

Thanks
Ma Ling