Bug 22497 - [fatal server error] g45 doesn't detect valid mode for DVI-D
Summary: [fatal server error] g45 doesn't detect valid mode for DVI-D
Status: RESOLVED DUPLICATE of bug 21322
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: high major
Assignee: MaLing
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-26 07:21 UTC by Achim Frase
Modified: 2009-06-28 20:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log and xrandr --verbose (27.18 KB, text/plain)
2009-06-26 07:23 UTC, Achim Frase
no flags Details
Xorg.0.log (9.63 KB, text/plain)
2009-06-27 14:38 UTC, Mahmut Izci
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Frase 2009-06-26 07:21:40 UTC
The driver doesn't find a valid mode for my Monitor if I try to use DVI-D.
It works with the VGA ouput.

chipset: [g45] X4500HD
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

system architecture: x86_64

kernel version: 2.6.30-020630-generic

Linux distribution: ubuntu 9.04

Machine or mobo model: MICRO-STAR INTERNATIONAL CO.,LTD, G45M Digital (MS-7521)

Display connector: DVI-D

Xorg log and xrandr --verbose see attachment

I have used the xorg-edgers ppa for testing purpose.

If there is a temporary workaround, I would be very pleased if someone could give me a hint.
Comment 1 Achim Frase 2009-06-26 07:23:00 UTC
Created attachment 27171 [details]
Xorg.log and xrandr --verbose
Comment 2 Mahmut Izci 2009-06-27 14:37:26 UTC
I can report the same behaviour, have the same mobo MSI G45M Digital.
VGA works well, but for the DVI port driver reports "Output DVI1 disconnected". 
I even tried out the latest driver from git repository without any luck.
Monitor supports DDC. Windows driver works with DVI.
Any help will be very appreciated. Xorg.0.log is attached.

Thanks.
Comment 3 Mahmut Izci 2009-06-27 14:38:42 UTC
Created attachment 27197 [details]
Xorg.0.log
Comment 4 Gordon Jin 2009-06-28 19:02:54 UTC
Note Achim is using UMS and the DVI is detected as HDMI-1 (disconnected), and Izci is using KMS and the DVI is detected as DVI1 (disconnected).
Comment 5 MaLing 2009-06-28 20:37:24 UTC
The root cause is that HDMI is not detected correctly.

please try the patch 
http://bugs.freedesktop.org/attachment.cgi?id=26663

*** This bug has been marked as a duplicate of bug 21322 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.