Bug 22505 - support easier drag behavior on "buttonless" touchpads
Summary: support easier drag behavior on "buttonless" touchpads
Status: RESOLVED DUPLICATE of bug 38303
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/synaptics (show other bugs)
Version: unspecified
Hardware: Other All
: medium enhancement
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-26 16:58 UTC by Brian Tarricone
Modified: 2012-03-13 21:45 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Tarricone 2009-06-26 16:58:03 UTC
Newer Apple hardware has touchpads where the entire touchpad is the button.  With the synaptics driver, drag and drop is very awkward and sometimes impossible if the drag distance is large, as I must drag with the same finger that is pressing the button.  If I hit the edge of the touchpad and need to go farther, I cannot lift my dragging finger to move it to the other side of the touchpad, as that will also release the button and end the drag.

MacOS X handles this very well -- you can click and hold with one finger, and then drag using another finger while keeping the click finger in one place.  Unless I'm missing something, I'm unable to enable similar functionality using the synaptics driver.  This type of behavior would be great as I'm not a fan of the 'tap lock' method (which I believe synaptics does support).

On a side note, this behavior is also useful for pop up menus.  You can click and hold with one finger, and swipe vertically with another finger to select the menu item, then release the first finger to activate.  I just can't make myself get used to the click-release-navigate-click-release-activate method of menu navigation.
Comment 1 Peter Hutterer 2009-07-02 17:00:13 UTC
synaptics has little two-finger support right now. Henrik is working on some multi-touch stuff but I am not sure how much of that overlaps with the feature requested here.

Feel free to start hacking on it though to add this feature. I think it would be welcomed.
Comment 2 Peter Hutterer 2012-03-13 21:45:18 UTC
Clickpad support has been merged, marking this as duplicate of the clickpad request to have everything in one place.

*** This bug has been marked as a duplicate of bug 38303 ***


bug/show.html.tmpl processed on Jul 29, 2016 at 12:02:12.
(provided by the Example extension).