Bug 38303 - Support for new Clickpad series of hardware
Support for new Clickpad series of hardware
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Input/synaptics
git
All Linux (All)
: medium major
Assigned To: Peter Hutterer
2011BRB_Reviewed
: patch
: 22505 40118 43394 (view as bug list)
Depends on:
Blocks: 39055 45396
  Show dependency treegraph
 
Reported: 2011-06-14 07:44 UTC by Jesse Jaara
Modified: 2012-03-13 21:45 UTC (History)
9 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch to add initial support for clickpad series of trackpads. (4.35 KB, patch)
2011-06-14 07:44 UTC, Jesse Jaara
no flags Details | Splinter Review
Initial clickpad support with led and power swich support. (19.78 KB, patch)
2011-06-14 07:47 UTC, Jesse Jaara
no flags Details | Splinter Review
Kernel patch to add clickpad led support to psmouse. 2.6.38&2.6.39 tested (5.98 KB, patch)
2011-06-14 07:50 UTC, Jesse Jaara
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Jaara 2011-06-14 07:44:50 UTC
Created attachment 47959 [details] [review]
Patch to add initial support for clickpad series of trackpads.

The Synaptics newer Clickpad series of trackpads are currently unusable with the driver. These trackpads don't have 'external' buttons like classical trackpads, but instead the buttons are under the trackingplate and act as part of it.

Here is a refrence imgage: http://bit.ly/clickpad

Biggest problem is that the second mouse button is not detected and acts as mouse button one. Resulting in bad usability. There is a patch to fix this clickpad.patch .

Another problem is that after aplying the patch abowe to add support for clickpads is that click and drag wont work. To drag something a double click is required, but pressing the button and dragging results in 2 finger scrolling.
So the tracking-area over the buttons should be disabled when physicality mouse-click is detected.

The trackpads also provide a led to show the state of the trackpad. This led is also supposed to act as on/off switch triggered by a double-click. Currently for this led to function a kernel patch to psmouse kernel driver is required. But the double tap switch works without the led. Patch clickpad_with_led_and_onoff_swich.patch

I also attached the kernel patch for testing.
Comment 1 Jesse Jaara 2011-06-14 07:47:28 UTC
Created attachment 47960 [details] [review]
Initial clickpad support with led and power swich support.
Comment 2 Jesse Jaara 2011-06-14 07:50:05 UTC
Created attachment 47961 [details] [review]
Kernel patch to add clickpad led support to psmouse. 2.6.38&2.6.39 tested
Comment 3 Rogutės Sparnuotos 2011-08-21 14:59:19 UTC
Jesse Jaara: looks like the first 2 patches were written by Takashi Iwai, but you posted them without any attribution (and thus they appear to be written by you, which is not right).

The first 2 patches and much more were reviewed by Peter Hutterer and others [1], but Takashi Iwai didn't follow up.

[1] http://lists.x.org/archives/xorg-devel/2010-October/thread.html#13821

I have an HP ProBook 4530s. Its touchpad has normal hardware buttons, and has a LED-button in the top left. Everything except the LED works without any patches. The LED needs patches to the kernel and to xf86-input-synaptics. Takashi Iwai submitted the kernel patch [2] (3rd patch posted by Jesse Jaara), got it reviewed and sent fixes, but it was not merged (forgotten?). I tried [2] + LED patches from [3] and the LED-button worked nicely...

[2] http://lkml.org/lkml/2010/4/22/35
[3] https://build.opensuse.org/package/files?package=xorg-x11-driver-input&project=openSUSE%3AFactory
Comment 4 Nasenbaer 2011-09-06 11:39:36 UTC
I haven't checked the patches shown here, however OpenSuSe had its own patches for Clickpad, that worked fine with kernel 2.6.37.6, but did not with newer 3.0.x kernels.

I initially posted this bug to the kernel bugtracker at https://bugzilla.kernel.org/show_bug.cgi?id=41252

Most important comment is:

Comment #4 From Dmitry Torokhov  2011-08-25 18:02:41 
OK, it looks like clickpad support still hasn't made it into official
xf86-input-synaptics driver and adding multifinger support to kernel driver
broke SUSE's detection of clickpads (they detect clickpads by having BTN_LEFT
capability only, and we started reporting BTN_TOOL_DOUBLETAP). They should
switch to checking INPUT_PROP_BUTTONPAD.


Could someone *please* take care about the implementation!
Comment 5 Nasenbaer 2011-09-06 11:49:27 UTC
I added the link to the equivalent SuSe bug.
Comment 6 Thomas Vogt 2011-11-13 09:21:45 UTC
Still no updates concerning this bug? No fix? I don't understand, how this can be such a big deal, even though it has been fixed in OpenSuse almost a year ago. There not only the clickpad itself works brilliantly but also the on/off switch with the white LED...
Comment 7 Peter Hutterer 2011-11-27 18:22:41 UTC
Please feel free to submit patches to the list. http://wiki.x.org/wiki/Development/Documentation/SubmittingPatches
Comment 8 Nicola Soranzo 2012-01-13 05:26:27 UTC
*** Bug 43394 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Vogt 2012-02-07 15:10:58 UTC
Is there any hope for a better clickpad performance in coming versions due to the enormous advances in Xorg multitouch support pushed greatly by Peter Hutterer during the last few months?

I saw all those articles on his blog (who-t..) and wondered if this will affect clickpad support in the near future. What do you think?
Comment 10 Nicola Soranzo 2012-02-10 09:38:40 UTC
(In reply to comment #9)
> Is there any hope for a better clickpad performance in coming versions due to the enormous advances in Xorg multitouch support pushed greatly by Peter Hutterer
> during the last few months?
> 
> I saw all those articles on his blog (who-t..) and wondered if this will affect clickpad support in the near future. What do you think?

http://lists.x.org/archives/xorg-devel/2012-February/029132.html
Comment 11 Peter Hutterer 2012-03-13 18:38:31 UTC
commit 6c457c0c61a0834361f45a073148db7b4c9be40b
Merge: defc1d0 fee18d8
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Wed Mar 14 08:48:00 2012 +1000

    Merge branch 'clickpad-v3'
Comment 12 Peter Hutterer 2012-03-13 21:26:04 UTC
*** Bug 40118 has been marked as a duplicate of this bug. ***
Comment 13 Peter Hutterer 2012-03-13 21:45:18 UTC
*** Bug 22505 has been marked as a duplicate of this bug. ***