Bug 226 - lib/Xrender
Summary: lib/Xrender
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: unspecified
Hardware: All All
: highest blocker
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
: 228 (view as bug list)
Depends on:
Blocks: 213
  Show dependency treegraph
 
Reported: 2004-02-25 10:23 UTC by Jim Gettys
Modified: 2011-10-15 15:48 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Gettys 2004-02-25 10:23:41 UTC
The version is in CVS is stale.

Right now, Mike updates during the build; maybe like Xft we need to
do likewise as a stopgap.

Needs release noting.
Comment 1 Jim Gettys 2004-02-25 11:10:31 UTC
*** Bug 228 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2004-02-27 16:45:33 UTC
There are some problems with trying to incorporate the new Xcursor/Xft/Xrender
into the tree due to the fact that imake does not support 3 digit .so versions,
and these new libraries use 3 digit library versions.

We had a discussion on #xwin today about this, and I believe we've come to
a concensus of what we should do.  I will be posting an email to the mailing
list tomorrow about this to elicit feedback, just to ensure that everyone
is in agreement with how we should proceed, and any problems can be discussed
and ironed out first.

Feel free to reassign this to me if you like.
Comment 3 Egbert Eich 2004-03-09 11:00:16 UTC
Updated to 0.8.3 (with large parts of 0.8.4).
Comment 4 Mike A. Harris 2004-03-09 15:10:56 UTC
Just curious about what parts of 0.8.4 were unacceptable, because I've updated
Red Hat Xrender to 0.8.4, and if there are known bugs, I'd like to fix them
or back out changes.
Comment 5 Mike A. Harris 2004-03-09 15:11:26 UTC
Just to clarify, I mean "back out changes" meaning in Red Hat xft packaging, not
in CVS.
Comment 6 Egbert Eich 2004-03-10 07:38:36 UTC
All of the code has been taken. I don't remember what the diffs were other than
it was irrelevant.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.