Bug 22717 - [G45] DQ45CB: DVI not working, monitor connected but report as disconnected
Summary: [G45] DQ45CB: DVI not working, monitor connected but report as disconnected
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: ykzhao
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2009-07-10 18:10 UTC by Bryce Harrington
Modified: 2009-09-27 02:24 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (52.65 KB, text/x-log)
2009-07-10 18:10 UTC, Bryce Harrington
no flags Details
Xrandr.txt (4.69 KB, text/plain)
2009-07-10 18:14 UTC, Bryce Harrington
no flags Details
xorg.log (89.65 KB, text/plain)
2009-09-10 09:32 UTC, Christian Berger
no flags Details
check whether the HDMI is connected or not by reading the EDID (1.72 KB, patch)
2009-09-15 02:05 UTC, ykzhao
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-07-10 18:10:45 UTC
Created attachment 27582 [details]
Xorg.0.log

Forwarding this bug from Ubuntu reporter Casandro:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/386700

[Problem]
DVI outputs are not being reported properly and do not work correctly.

[Original Report]
As you can seen on the automatically generated bug report, xrandr lists 3 outputs, one VGA which works perfectly, plus 2 HDMI outputs. This board however only has 2 DVI outputs. One is DVI-I which I use with a VGA adaptor. The other one is a DVI-D which was connected to another monitor with DVI-D input.

Only the analog output of the first DVI-output works, the rest doesn't seem to work. To be fair it might be a problem with my monitor as it neither works on the BIOS setup screens. The monitor is fairly old, but once worked with an old ATI card.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu9
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-11-generic x86_64

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 4 Series Chipset DRAM Controller [8086:2e10] (rev 03)
	Subsystem: Intel Corporation Device [8086:1003]
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e12] (rev 03)
	Subsystem: Intel Corporation Device [8086:1003]
Comment 1 Bryce Harrington 2009-07-10 18:14:23 UTC
Created attachment 27583 [details]
Xrandr.txt

VGA connected 1280x1024+0+0 (0x3e) normal (normal left inverted right x axis y axis) 337mm x 270mm
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

Motherboard:
http://www.intel.com/products/desktop/motherboards/dq45cb/dq45CB-overview.htm

"Intel® Graphics Media Accelerator 4500 onboard graphics subsystem with integrated DVI-I and DVI-D graphics output"
Comment 2 MaLing 2009-07-12 18:20:44 UTC
(In reply to comment #1)
> Created an attachment (id=27583) [details]
> Xrandr.txt
> VGA connected 1280x1024+0+0 (0x3e) normal (normal left inverted right x axis y
> axis) 337mm x 270mm
> HDMI-1 disconnected (normal left inverted right x axis y axis)
> HDMI-2 disconnected (normal left inverted right x axis y axis)
> Motherboard:
> http://www.intel.com/products/desktop/motherboards/dq45cb/dq45CB-overview.htm
> "Intel® Graphics Media Accelerator 4500 onboard graphics subsystem with
> integrated DVI-I and DVI-D graphics output"

xrandr correctly reports output, VGA(connected), 2 HDMI outputs(disconnect),
it is not bug because our driver will enumerate all output from motherboard,
even if you only use DVI-I to connect VGA output, but 2 HDMI outputs are not connected, so they are showed as disconnect correctly.

Thanks for your help, I will close it, please open it if you need.

Regards
Ma Ling
Comment 3 Michael Fu 2009-07-12 18:22:47 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=27583) [details] [details]
> > Xrandr.txt
> > VGA connected 1280x1024+0+0 (0x3e) normal (normal left inverted right x axis y
> > axis) 337mm x 270mm
> > HDMI-1 disconnected (normal left inverted right x axis y axis)
> > HDMI-2 disconnected (normal left inverted right x axis y axis)
> > Motherboard:
> > http://www.intel.com/products/desktop/motherboards/dq45cb/dq45CB-overview.htm
> > "Intel® Graphics Media Accelerator 4500 onboard graphics subsystem with
> > integrated DVI-I and DVI-D graphics output"
> 
> xrandr correctly reports output, VGA(connected), 2 HDMI outputs(disconnect),
> it is not bug because our driver will enumerate all output from motherboard,
> even if you only use DVI-I to connect VGA output, but 2 HDMI outputs are not
> connected, so they are showed as disconnect correctly.
> 
> Thanks for your help, I will close it, please open it if you need.
> 
> Regards
> Ma Ling
> 
bug reporter actually connect _two_ monitors to his computer:

"One is DVI-I which I use with a VGA adaptor. The other
one is a DVI-D which was connected to another monitor with DVI-D input.
"
Comment 4 MaLing 2009-07-12 18:32:45 UTC
sorry, I think it is duplicate with bug #21322
Comment 5 Michael Fu 2009-07-14 05:56:14 UTC
(In reply to comment #4)
> sorry, I think it is duplicate with bug #21322
> 

yes, it is.
Comment 6 MaLing 2009-07-15 19:33:39 UTC

*** This bug has been marked as a duplicate of bug 21322 ***
Comment 7 Christian Berger 2009-09-10 09:32:50 UTC
Created attachment 29388 [details]
xorg.log

This bug isn't solved yet, but it has changed. I'm currently using Kernel version 2.6.31-10 from Ubuntu on the same system as before and now xrandr reports:

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 337mm x 270mm
   1280x1024      60.0*+   75.0
   1024x768       75.1     70.1     60.0
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        72.8     75.0     66.7     60.0
   720x400        70.1
DVI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DVI2 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
Comment 8 Michael Fu 2009-09-11 02:05:50 UTC
reopen
Comment 9 Christian Berger 2009-09-11 07:32:09 UTC
I have found a crude workaround. Entering the following commands will enable the output. It seems as if it's a bug in detecting the monitor.

xrandr --addmode DVI1 1024x768
xrandr --output DVI1 --mode 1024x768
xrandr --output DVI1 --right-of VGA1
Comment 10 ykzhao 2009-09-13 20:07:09 UTC
(In reply to comment #9)
> I have found a crude workaround. Entering the following commands will enable
> the output. It seems as if it's a bug in detecting the monitor.
> 
> xrandr --addmode DVI1 1024x768
> xrandr --output DVI1 --mode 1024x768
> xrandr --output DVI1 --right-of VGA1

Will you please try to add the boot option of "drm.debug=the latest Dave's drm-next tree and attach the output of dmesg?
    You can use the following command to get the Dave's drm-next tree.
    1. git clone git://git.kernel.org/pub/scm/linux/kernel/git/airlied/drm-2.6.git
   2. git branch -r
   3. git checkout -b origin/drm-next

Please also attach the output of vbios.dump . The vbios.dump can be obtained by using the following command:
    1. echo 1 > /sys/devices/pci0000:00/0000:00:02.0/rom
    2. cat /sys/devices/pci0000:00/0000:00:02.0/rom > vbios.dump
    3. echo 0 > /sys/devices/pci0000:00/0000:00:02.0/rom


It will be great if you can do the following test with KMS disabled by adding the boot option of "i915.modeset=0".
   a. add the modedebug option in xorg.conf ( option "modedebug" "true")
   b. attach the xorg.0.log.

Thanks. 
> 

Comment 11 ykzhao 2009-09-13 22:53:15 UTC
> 
> Will you please try to add the boot option of "drm.debug=the latest Dave's
> drm-next tree and attach the output of dmesg?
Sorry for typo.

Will you please try to add the boot option of "dr.debug=15" on the latest Dav'es drm-next tree and attach the output of dmesg?
How to get the Dave's drm-next tree can be referred in comment #10.
>     You can use the following command to get the Dave's drm-next tree.
>     1. git clone
> git://git.kernel.org/pub/scm/linux/kernel/git/airlied/drm-2.6.git
>    2. git branch -r
>    3. git checkout -b origin/drm-next
> 
Comment 12 ykzhao 2009-09-15 02:05:58 UTC
Created attachment 29552 [details] [review]
check whether the HDMI is connected or not by reading the EDID

Will you please try the debug patch and attach the output of Xorg.0.log?
Please do the test under UMS mode.

Thanks.
Comment 13 Christian Berger 2009-09-25 11:01:25 UTC
Unfortunately I haven't been able to run that kernel, however I think I might have found the problem. It thinks the EDID checksum is invalid. I assume it's a problem with the monitor.

[   17.084445] i915 0000:00:02.0: VGA-1: no EDID data                                           
[   17.287218] [drm:edid_is_valid] *ERROR* EDID checksum is invalid, remainder is 108           
[   17.287279] [drm:edid_is_valid] *ERROR* Raw EDID:                                            
[   17.287319] <3>00 ff ff ff ff ff ff 00 04 72 05 ad 01 00 00 00  .........r......             
[   17.287321] <3>25 0d 01 03 80 1e 17 75 2a f3 e0 9d 58 4a 97 25  %......u*...XJ.%             
[   17.287323] <3>19 50 54 af 4e 00 61 40 61 4f 45 40 45 4f 31 40  .PT.N.a@aOE@EO1@             
[   17.287325] <3>31 4f 01 01 01 01 64 19 00 40 41 00 26 30 18 88  1O....d..@A.&0..             
[   17.287326] <3>36 00 30 e4 10 00 00 18 00 00 00 ff 00 33 33 37  6.0..........337             
[   17.287328] <3>30 30 31 39 42 50 4b 30 30 0a 00 00 00 fd 00 37  0019BPK00......7             
[   17.287330] <3>4b 1e 3f 08 00 0a 20 20 20 20 20 20 00 00 00 fc  K.?...      ....             
[   17.287332] <3>00 41 63 65 72 20 41 4c 31 35 32 31 0a 20 6c 94  .Acer AL1521. l.             
[   17.287333]                                                                                  
[   17.287336] i915 0000:00:02.0: DVI-D-1: EDID invalid.  
Comment 14 ykzhao 2009-09-26 18:13:17 UTC
(In reply to comment #13)
> Unfortunately I haven't been able to run that kernel, however I think I might
> have found the problem. It thinks the EDID checksum is invalid. I assume it's a
> problem with the monitor.
> 
> [   17.287332] <3>00 41 63 65 72 20 41 4c 31 35 32 31 0a 20 6c 94  .Acer
> AL1521. l.             
> [   17.287333]                                                                  
> [   17.287336] i915 0000:00:02.0: DVI-D-1: EDID invalid.  
> 
thanks for the test.
What you said is right. It seems that the EDID checksum in invalid. As the EDID is required for the HDMI/DVI-D port, it will be regarded as disconnected.

Will you please try another monitor and see whether it can work?

Thanks.

Comment 15 Christian Berger 2009-09-26 22:00:30 UTC
Unfortunately I do not (yet) have another monitor with DVI connector. I'll try my best.
Comment 16 Michael Fu 2009-09-26 22:12:38 UTC
(In reply to comment #15)
> Unfortunately I do not (yet) have another monitor with DVI connector. I'll try
> my best.
> 

have you ever make this monitor work on this DQ45CB board before? i.e. is this a regression? thanks.
Comment 17 Christian Berger 2009-09-26 22:15:42 UTC
Nope, this monitor never worked with that board. But it did work on an old ATI card. However the monitor doesn't even work on the BIOS menues of that board. So the bad monitor hyphothesis is currently the most plausible.
Comment 18 Christian Berger 2009-09-27 01:39:26 UTC
I have just tried it out with an LCD television set and it worked nicely over the DVI output. So I guess we can blame it on the monitor and mark it as fixed.
Comment 19 Michael Fu 2009-09-27 02:24:17 UTC
mark as NOTOURBUG for correct tracking..


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.