Bug 22871 - xf86-intel 2.8.0 uses wrong mode on LVDS1, due to DVI1 (Thinkpad x200, intel GM45)
Summary: xf86-intel 2.8.0 uses wrong mode on LVDS1, due to DVI1 (Thinkpad x200, intel ...
Status: RESOLVED DUPLICATE of bug 21322
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: MaLing
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2009-07-21 04:28 UTC by Michael Stapelberg
Modified: 2009-07-23 21:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg logfile (71.62 KB, text/plain)
2009-07-21 04:28 UTC, Michael Stapelberg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stapelberg 2009-07-21 04:28:59 UTC
Created attachment 27875 [details]
Xorg logfile

Since a few versions, I have an additional output called DVI1 (and DVI2). They seem to be related to LVDS1 and VGA1. My notebook only has its flat panel and a VGA output.

The output of xrandr looks like this:
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800       60.0*+   50.0  
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
DVI1 connected (normal left inverted right x axis y axis)
   1360x768       59.8  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
DVI2 disconnected (normal left inverted right x axis y axis)


In 2.8.0, it seems that the driver is using the highest common resolution of all screens when starting. Thus, my LVDS1 is initialized with 1024x768 instead of 1280x800. When using xrandr --output LVDS1 --mode 1280x800 and xrandr --output DVI1 --off, it works.

Furthermore, when using the VGA1, I have to disable DVI2 explicitly with xrandr --output DVI2 --off to get a resolution of 1024x768. Otherwise, only 800x600 works.

Xorg.0.log output is attached
Comment 1 MaLing 2009-07-22 06:02:01 UTC
The root cause is  HDMI detected incorrectly. please try the below patch.
http://lists.freedesktop.org/archives/intel-gfx/2009-July/003450.html

Thanks
Ma Ling
 
Comment 2 Michael Stapelberg 2009-07-22 07:54:31 UTC
Your patch fixes the problem, the LVDS1 is now running on 1280x800, its native resolution. VGA also works fine, as far as I could test it here.

xrandr output now looks like this:
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800       60.0*+   50.0  
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
DVI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DVI2 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

Let me know if you need any more information. Iā€™d be happy to see your work in 2.6.31.

Best regards,
Michael
Comment 3 MaLing 2009-07-23 21:22:30 UTC

*** This bug has been marked as a duplicate of bug 21322 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.