Bug 23053 - [i915 OGLC] pointsprite.c failed
[i915 OGLC] pointsprite.c failed
Status: CLOSED WONTFIX
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
: 41786 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-30 20:48 UTC by Shuang He
Modified: 2015-06-16 02:00 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg log (23.80 KB, text/plain)
2009-07-30 20:48 UTC, Shuang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2009-07-30 20:48:00 UTC
System Environment:
--------------------------
Arch 	i386
Platform 	945GM
Libdrm 	(master)5a73f066ba149816cc0fc2de4b97ec4714cf8ebc
Mesa 	(master)6c70285e330bd19db78b7d45e43a01b0255ca15f
Xserver 	(master)0565f4ed4519962bed40a0bbcf0b409471f4de40
Xf86_video_intel 	(master)50e2a6734de43a135aa91cd6e6fb5147e15ce315
Kernel 	(drm-intel-next)666069ac404a209edce9c5609a8a87386d93b4fe 

Bug detailed description:
-------------------------
oglconform case pointsprite.c failed, which used to be not support.


Reproduce steps:
----------------
1.xinit&
2. run olgc/pointsprite.c
Comment 1 Shuang He 2009-07-30 20:48:24 UTC
Created attachment 28213 [details]
xorg log
Comment 2 Shuang He 2009-07-30 22:30:44 UTC
This change is due to:
commit 92b9aa1646daa7d9e6470e9d1dbb3460eeae8941
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Jul 29 13:37:41 2009 -0700

    i915: Add ARB_point_sprite since we already expose NV_point_sprite.
    
    It's all fallbacks anyway due to the DD_POINT_ATTEN fallback.
Comment 3 ajax at nwnk dot net 2009-08-24 12:33:03 UTC
Mass version move, cvs -> git
Comment 4 Ouping Zhang 2011-04-28 02:44:34 UTC
System Environment:
--------------------------
Libdrm:    (master)2.4.25
Mesa:      (7.10)73f4273b8647abe0020ad3c2d593e009092d2be5
Xserver:   (server-1.10-branch)xorg-server-1.10.1
Xf86_video_intel:   (master)2.15.0-6-g67e5a74e997f199327f9115c7ba867df3c49da8d

pointsprite still fails on PineView.
Comment 5 Ian Romanick 2011-10-14 10:58:05 UTC
*** Bug 41786 has been marked as a duplicate of this bug. ***
Comment 6 Gordon Jin 2015-06-16 02:00:13 UTC
closing as won't fix.