Bug 23532 - Qt apps using opengl graphicssystem break with KMS
Qt apps using opengl graphicssystem break with KMS
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
: 25838 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-26 10:36 UTC by Marc Dietrich
Modified: 2010-03-12 00:39 UTC (History)
1 user (show)

See Also:


Attachments
backtrace of kcalc --graphicssystem opengl (4.61 KB, text/plain)
2009-08-26 10:36 UTC, Marc Dietrich
Details
new backtrace (9.35 KB, text/x-log)
2009-08-27 04:10 UTC, Marc Dietrich
Details
output with RADEON_DEBUG=all (943.50 KB, text/plain)
2009-09-16 07:22 UTC, Marc Dietrich
Details
output of with drm.debug=1 (4.90 KB, application/x-bzip)
2009-10-15 07:41 UTC, Marc Dietrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Dietrich 2009-08-26 10:36:17 UTC
Created attachment 28925 [details]
backtrace of kcalc --graphicssystem opengl

starting a Qt app (e.g. kcalc) with parameter "--graphicssystem opengl" causes a assert. I'm using latest mesa/drm+kms on rs690. attached is the backtrace of kcalc.
Comment 1 Marc Dietrich 2009-08-27 04:10:01 UTC
ok - with mesa 74b55970dc25d6b2a65f385fd298f141176cd4d3 the error changed a bit. a window opens showing only garbage. Moving the mouse a litte over it crashes kcalc. attaching new backtrace. also dmesg throughs out:
[drm:r300_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
Comment 2 Marc Dietrich 2009-08-27 04:10:41 UTC
Created attachment 28948 [details]
new backtrace
Comment 3 Marc Dietrich 2009-09-16 07:22:48 UTC
Created attachment 29594 [details]
output with RADEON_DEBUG=all

output with RADEON_DEBUG=all
Comment 4 Marc Dietrich 2009-10-15 07:41:57 UTC
Created attachment 30450 [details]
output of with drm.debug=1

retestet with latest drm/mesa/radeon/drm-next. This is definitely a KMS problem as it does not happen with mdoeset=0 (changed subject). Attached is the output with drm.debug=1.
Comment 5 Marc Dietrich 2009-12-31 05:48:51 UTC
*** Bug 25838 has been marked as a duplicate of this bug. ***
Comment 6 Maciej Cencora 2010-03-10 13:36:25 UTC
Fixed on master mesa branch since addedd091e81907837b3aa0680b242b8fdbde7ef.
Comment 7 Mike Lothian 2010-03-11 14:37:25 UTC
I can't seem to find that git commit

Do you know if kwin's compositing should work with this? It doesn't appear to atm
Comment 8 Marc Dietrich 2010-03-12 00:39:58 UTC
try "git show addedd09" with current mesa/master. Unfortunately, I cannot test this anymore as my system was upgraded.