Bug 23938 - keys occasionally get stuck with xorg-server 1.6.99.901
Summary: keys occasionally get stuck with xorg-server 1.6.99.901
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard: 2012BRB_Reviewed
Keywords:
: 25669 (view as bug list)
Depends on:
Blocks: xserver-1.12 xserver-1.13
  Show dependency treegraph
 
Reported: 2009-09-14 12:08 UTC by Bernhard Rosenkraenzer
Modified: 2016-11-28 04:39 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2009-09-14 12:08:53 UTC
This has happened twice so far (in about a day of working with xorg 1.6.99.901), both times on the same machine (while 2 other machines running the same software are ok), and both times under fairly heavy load (compiling stuff and playing a video at the same time):

While typing, a key appears to get stuck, just repeating the character over and over, even long after the key has been released; at the same time, new key presses (such as Ctrl+Alt+Backspace) are ignored.

ssh-ing in and restarting the X server fixes it; I doubt it's a hardware problem because this never happens while in text mode.

Xorg-server 1.6.99.901
libXi 1.2.99.4
xf86-input-keyboard 1.3.99.1
linux 2.6.31

The keyboard is a USB Logitech Classic New Touch Keyboard (46d:c315).
Comment 1 Peter Hutterer 2009-09-14 18:52:50 UTC
Pressing the same key that is stuck doesn't help?
Comment 2 Bernhard Rosenkraenzer 2009-09-14 23:32:56 UTC
No, any input from the keyboard (including the same key) is ignored at the point. The mouse keeps working.

Neither Xorg.0.log nor dmesg show anything unusual.
Comment 3 Bernhard Rosenkraenzer 2009-09-15 00:18:04 UTC
The problem appears to be specific to the kbd driver -- I've switched the box showing the problem to the evdev driver this morning and at least so far it hasn't caused any problems.

(My other machines that don't have the problem use the kbd driver as well, so it's probably not a general kbd bug)
Comment 4 Peter Hutterer 2009-09-16 16:06:23 UTC
(In reply to comment #3)
> The problem appears to be specific to the kbd driver -- I've switched the box
> showing the problem to the evdev driver this morning and at least so far it
> hasn't caused any problems.

have you seen the bug in the last 3 days?
Comment 5 Bernhard Rosenkraenzer 2009-09-17 00:05:47 UTC
No, it went away after I switched xorg.conf over to using evdev.

I'll switch back to kbd now to see if it keeps happening there
Comment 6 Peter Hutterer 2009-09-27 21:08:13 UTC
I can sort-of reproduce the issue, the key (very occasionally only) gets stuck, but hitting the stuck key stops it again. I suspect this is a race in the xkb autorepeat code triggered only by the kbd driver.

Either way, since it's not reproducible with evdev and it's hard enough to reproduce with kbd I'm punting it to 1.7.1 instead. This won't hold up the release.
Comment 7 Chí-Thanh Christopher Nguyễn 2009-10-18 17:24:46 UTC
From user report, it seems that this happens especially when the system is under load. (The permanent issue from comment 2 not the one from comment 6)
Comment 8 Rolf Leggewie 2010-01-19 05:00:17 UTC
I think this is the same issue that has been lengthily discussed in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/124406.  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/124406/comments/269 credibly suggested that http://ajaxxx.livejournal.com/62378.html may have some information as to the root cause of this issue.  Please have a look.
Comment 9 Jeremy Huddleston Sequoia 2011-05-28 17:36:33 UTC
Is this bug still relevant?  Is there a way to reproduce it, or do yo know where the race is, so it can be more easily reproduced by introducing a stall?
Comment 10 Jeremy Huddleston Sequoia 2011-10-03 20:02:46 UTC
*** Bug 25669 has been marked as a duplicate of this bug. ***
Comment 11 Bastien Nocera 2011-10-07 08:59:45 UTC
Not certain whether this is a problem with the X server, but I experience similar probbbbbbblems when the machine is under load. Thisssssssssssssssssssssssssssssssss    reeeeeeeeeeeeeeeeeeeeeeeeeeeeeegularly happens with this Bluetooth Lenovo                                          keyboard in HID                                             mode.

Noooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooot           sure hoooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooow to   diagnoseeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee it , but yyyyou                                                                                    can see the effecccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccts of normal typppppppppppppppppppppppppppppppppppppppppppppppppping right above....
Comment 12 Jeremy Huddleston Sequoia 2011-10-07 09:51:58 UTC
The fact that it's a BT keyboard makes me wonder if you're experiencing an issue at the BT layer rather than in X11 itself.  Do you have issues if you use the tty directly as well, or is it restricted to X11?
Comment 13 Peter Hutterer 2016-11-28 04:39:56 UTC
This is a mass change of bugs. Bugs assigned to me that haven't been updated in the last 3 years are closed as WONTFIX, because, well, let's at least be honest about it.

Please do not re-open unless you have a really good reason to do so (e.g. you're fixing it yourself). If it hasn't been fixed in the last 3 years, it probably won't be fixed anytime soon either. Sorry.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.