Bug 25669 - Mode_switch alternate mode often stays activated after key-release
Mode_switch alternate mode often stays activated after key-release
Status: RESOLVED DUPLICATE of bug 23938
Product: xorg
Classification: Unclassified
Component: * Other
x86 (IA32) Linux (All)
: high major
Assigned To: Peter Hutterer
Xorg Project Team
Depends on:
  Show dependency treegraph
Reported: 2009-12-16 02:26 UTC by Peter Wayne
Modified: 2011-10-04 20:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wayne 2009-12-16 02:26:18 UTC
X.Org X Server (1.7.4 RC 1)

No special keyboard settings in xorg.conf (autodetection).

Dummy .xmodmap:
keycode 30 = u U aring Aring
keycode 94 = Mode_switch

Keycode 94 is the key right to L_Shift on my Lenovo Thinkpad X41 with German Layout ( http://www.schwoll.de/thinkpad/tastatur.jpg ). This doesn't really matter, since it also applies to other keys.

Usually I could hold 94 and then press "u" and the special character would show up. After releasing 94 normal behavior was restored. Now the alternate mode often stays activated, even though I've already released 94.

When holding 94 and watching the output of xev, the state is initially always "0x00". However after Mode_switch has been used for the first time together with "u", the state in xev shows the following pattern "0x00 0x00 0x2000 0x2000 0x00 0x00 0x2000 0x2000 0x00 0x00 ...". When I hit "u" while it is 0x00, a normal "u" appears. Else the special character.

If the alternate mode is locked in, I can restore correct behavior by holding Mode_switch for a while. If I'm lucky and release it at the correct moment, everything is fine again.

What more information do you need?
Comment 1 Sebastian Biallas 2010-12-06 11:39:53 UTC
Same as 27807
Comment 2 Jeremy Huddleston 2011-10-03 20:02:46 UTC

*** This bug has been marked as a duplicate of bug 23938 ***
Comment 3 Peter Hutterer 2011-10-04 20:37:46 UTC
pretty sure this is not the same issue. mode_switch had other issues until
1.10, see https://bugzilla.redhat.com/show_bug.cgi?id=537708