Bug 24423 - radeonhd driver detects LVDS instead of DVI
Summary: radeonhd driver detects LVDS instead of DVI
Status: RESOLVED DUPLICATE of bug 11801
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other All
: medium normal
Assignee: Luc Verhaegen
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-09 08:53 UTC by RomaHagen
Modified: 2009-10-19 07:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (36.46 KB, text/plain)
2009-10-14 03:16 UTC, RomaHagen
no flags Details
xorg.conf (4.94 KB, text/plain)
2009-10-14 03:17 UTC, RomaHagen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description RomaHagen 2009-10-09 08:53:32 UTC
Hi,

after intallation of openSuSE 11.1 I've got the error on the monitor "Input signal out of range". I have spent one and a half day resolving this issue, trying different versions of proprietary drivers. (only precompiled) However it didn't help.

Then all of a sudden I found my problem described in one of the Debian bug reports. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=518782

The problem is that the driver wrongly recognized video output. It claimed that this is LVDS though it is DVI. Workaround Option "LVDSProbePLL" "off" in Device section helped me too. But I'm not still sure that driver works correctly, however X server and GUI started as it should be...

As I understood Debian supports it's own version of the open sourse ati driver and they have already fixed it.

But as you see the problem still remains in radeonhd driver.

How can I help to fix this bug?

Best regards and thanks,

Roman
Comment 1 Matthias Hopf 2009-10-09 08:56:33 UTC
The driver in openSUSE 11.1 is pretty out of date - so the first thing would be to use the driver from the X11:Drivers:Video build project.

I'm about to make a release, and that build project should have a new version very soon. Currently it's set at some git commit at the end of 1.2.5's lifetime.
Comment 2 RomaHagen 2009-10-14 03:16:34 UTC
Created attachment 30380 [details]
Xorg.0.log
Comment 3 RomaHagen 2009-10-14 03:17:08 UTC
Created attachment 30381 [details]
xorg.conf
Comment 4 RomaHagen 2009-10-14 03:17:49 UTC
Hi,

I've just intalled new driver from the repository you've gave me. (version 1.3.0). Where can I check that the correct version of driver is already in use. I suppose junst installation was enough, but I'm not that sure.

The bad news are, that with new driver exactly the same thing happens. Please see xorg.conf and Xorg.0.log in the attachmets.

As always please feel free to ask any additional information.

Best regards,

Roman
Comment 5 Matthias Hopf 2009-10-19 05:48:47 UTC
New log file from the 1.3.0 driver, please.

Installation and restarting X is enough. The version of the used driver is stated in the log file.
Comment 6 RomaHagen 2009-10-19 06:49:42 UTC
The log of the X server with new driver is in comment #2.

I've submitted comment#2,#3 and #4 simultaneously. I thought attachments would be in the same comment, but they were added separately.

Regards,

Roman
Comment 7 Rafał Miłecki 2009-10-19 06:52:00 UTC
(In reply to comment #6)
> The log of the X server with new driver is in comment #2.
> 
> I've submitted comment#2,#3 and #4 simultaneously. I thought attachments would
> be in the same comment, but they were added separately.

It shows you use radeon, not radeonhd. Edit xorg.conf to change that.
Comment 8 Alex Deucher 2009-10-19 07:10:18 UTC
Your chip, an RS4xx, is only supported by radeon.  You are using an ancient version of the driver.  The LVDS/DVI issue was fixed long ago.  Please upgrade to 6.12.4 or git master.  However, using DVI on older IGP chips is problematic as they use external tmds chips that are not well supported yet.

*** This bug has been marked as a duplicate of bug 11801 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.