Bug 25647 - Add ortho file for locale sd_IN@devanagari
Summary: Add ortho file for locale sd_IN@devanagari
Status: RESOLVED MOVED
Alias: None
Product: fontconfig
Classification: Unclassified
Component: orth (show other bugs)
Version: 2.8
Hardware: Other All
: highest enhancement
Assignee: fontconfig-bugs
QA Contact: Behdad Esfahbod
URL:
Whiteboard:
Keywords:
: 27850 (view as bug list)
Depends on: 42900
Blocks: 35485
  Show dependency treegraph
 
Reported: 2009-12-14 22:16 UTC by Parag
Modified: 2018-08-20 21:52 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Ortho file (2.56 KB, patch)
2010-03-03 03:05 UTC, Parag
Details | Splinter Review
Sindhi using devanagari script ortho file (2.64 KB, patch)
2012-02-23 20:03 UTC, Parag
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Parag 2009-12-14 22:16:07 UTC
please add ortho file for locale sd_IN@devanagari which is devanagari script based language.
Comment 1 Parag 2010-03-03 03:05:07 UTC
Created attachment 33709 [details] [review]
Ortho file
Comment 2 Parag 2010-03-17 20:21:50 UTC
Ping for feedback on attached patch.
Comment 3 Parag 2010-04-05 03:40:41 UTC
Can we have fontconfig update before Final freeze of Fedora 13 development cycle?
Comment 4 Parag 2010-05-02 21:48:18 UTC
Behdad,
Fedora 13 Final freeze is due on tomorrow. Can we have new fontconfig built in Fedora 13 before that?
Comment 5 Parag 2010-12-08 01:31:30 UTC
Fedora 14 is already out since a month and still we are waiting for this fix to be included in fontconfig.

Please, can someone look into this and commit attached patch and release new fontconfig?

Thanks.
Comment 6 Behdad Esfahbod 2010-12-08 11:26:38 UTC
Why not just sd_IN.orth?
Comment 7 Parag 2010-12-08 20:09:24 UTC
(In reply to comment #6)
> Why not just sd_IN.orth?

I assumed ortho file name should be same as locale file name. If this assumption is wrong then please use sd_IN.orth name.
Comment 8 Behdad Esfahbod 2010-12-09 10:33:23 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Why not just sd_IN.orth?
> 
> I assumed ortho file name should be same as locale file name. If this
> assumption is wrong then please use sd_IN.orth name.

You didn't provide any comment or link suggesting what the locale name is either.  You provided zero references in fact.  Please link to the locale entry so I can confirm.  Same about the other orth bugs of yours.  Thanks.
Comment 9 Parag 2010-12-10 01:34:00 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Why not just sd_IN.orth?
> > 
> > I assumed ortho file name should be same as locale file name. If this
> > assumption is wrong then please use sd_IN.orth name.
> 
> You didn't provide any comment or link suggesting what the locale name is
> either.  You provided zero references in fact.  Please link to the locale entry
> so I can confirm.  Same about the other orth bugs of yours.  Thanks.

Sorry I forgot the locale reference. This file can be found in Fedora 14 at location /usr/share/i18n/locales/sd_IN\@devanagari

Also tried to give glibc git url but its down with error "
503 - The load average on the server is too high"

Once server is back, i will provide online link also.
Comment 10 Behdad Esfahbod 2010-12-13 15:24:32 UTC
Thanks.  Please double check with hi.orth.  For those that are quite similar to hi.orth, please just include it.  If the difference is small, you can exclude characters from hi.orth.  See ne.orth for example.

Also, please comment out abbreviation sign, etc, the same way that hi.orth has done.

When you're done with all of these, please push a git repo out somewhere so I can pull.

Thanks
Comment 11 Parag 2011-02-16 02:01:39 UTC
I have updated Indic ortho files in local git checkout and copied that directory to http://paragn.fedorapeople.org/fontconfig/

If needed only git patch then http://paragn.fedorapeople.org/0001-Update-for-Indic-languages-ortho-files.patch
Comment 12 Parag 2011-03-14 22:58:32 UTC
ping behdad
Comment 13 Pravin 2012-02-10 00:50:53 UTC
*** Bug 27850 has been marked as a duplicate of this bug. ***
Comment 14 Parag 2012-02-23 20:03:33 UTC
Created attachment 57568 [details] [review]
Sindhi using devanagari script ortho file

updated patch
Comment 15 Akira TAGOH 2012-02-24 00:32:20 UTC
The language model in fontconfig isn't the same to the locale. so adding the script modifier following @ doesn't look correct to me. if we really need to have some variants like this, it has to be addressed first.

I'll think about it once next release is out.
Comment 16 GitLab Migration User 2018-08-20 21:52:40 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/101.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.