Bug 27850 - RFE: No orth file for sd@devanagari
Summary: RFE: No orth file for sd@devanagari
Status: RESOLVED DUPLICATE of bug 25647
Alias: None
Product: fontconfig
Classification: Unclassified
Component: orth (show other bugs)
Version: 2.8
Hardware: Other All
: medium normal
Assignee: Roozbeh Pournader
QA Contact: Behdad Esfahbod
URL:
Whiteboard:
Keywords:
Depends on: 42900
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 01:34 UTC by Akira TAGOH
Modified: 2012-02-10 00:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Akira TAGOH 2010-04-27 01:34:52 UTC
Summary says that all, fontconfig can't pick up the appropriate fonts for Sindhi for Devanagari script due to the lacking of the orth file in it.

How to reproduce:
1. install Samyak Devanagari font.
2. fc-match serif:lang=sd-in@devanagari or :lang=sd@devanagari

Actual result:
DejaVuSans.ttf: "DejaVu Sans" "Book"

Expect result:
Samyak-Devanagari.ttf: "Samyak Devanagari" "Regular"

Additional Info:
Aside from no orth file provided in fc-lang/, FcGetDefaultLang() seems ignoring @scriptname in current locale. so if lang= isn't given and run with LANG=sd_IN.UTF-8@devanagari say, fontconfig will set the default lang as sd-in.
Comment 1 Pravin 2012-02-10 00:50:53 UTC

*** This bug has been marked as a duplicate of bug 25647 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.