Bug 25723 - Bloom option in OpenArena causes 1FPS (blit sth?)
Bloom option in OpenArena causes 1FPS (blit sth?)
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600
unspecified
Other All
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-19 07:32 UTC by Rafał Miłecki
Modified: 2010-01-16 12:18 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Miłecki 2009-12-19 07:32:11 UTC
This is very similar to bug #19366

Using Mesa git I get very slow OpenArena rendering after enabling Bloom option. My hardware is RV620.
Comment 1 Rafał Miłecki 2010-01-12 07:44:43 UTC
I've tried this git repo:
http://cgit.freedesktop.org/~andrem/mesa/log/?h=r600-blit

Tested performance:

1) Bloom: off && mesa's master:
840 frames 18.5 seconds 45.5 fps 5.0/22.0/225.0/9.7 ms

2) Bloom: on && mesa's master:
untestable

3) Bloom: off && ~andrem's r600-blit
840 frames 18.9 seconds 44.3 fps 6.0/22.6/293.0/10.0 ms

4) Bloom: on && ~andrem's r600-blit
840 frames 31.4 seconds 26.8 fps 24.0/37.4/59.0/6.3 ms

So that patches don't cause performance regression and significantly improve "Bloom: On"! :)

I saw some corruptions (maybe related to:
format for copy MESA_FORMAT_XRGB8888
format for copy MESA_FORMAT_RGBA8888_REV
format for copy MESA_FORMAT_XRGB8888
format for copy MESA_FORMAT_RGBA8888_REV
?) will investigate.
Comment 2 Rafał Miłecki 2010-01-12 08:54:26 UTC
Ignore my corruption suspicion. It's not blit related (see bug #26011).
Comment 3 Rafał Miłecki 2010-01-13 07:40:04 UTC
With "r600: blit - add formats, cleanup, formatting" I don't see that format messages anymore :)

Before "r600: blit - add formats, cleanup, formatting"
840 frames 32.3 seconds 26.0 fps 24.0/38.4/243.0/11.5 ms
840 frames 31.7 seconds 26.5 fps 23.0/37.8/63.0/6.3 ms
840 frames 32.0 seconds 26.3 fps 24.0/38.0/241.0/10.4 ms

After "r600: blit - add formats, cleanup, formatting"
840 frames 27.2 seconds 30.8 fps 19.0/32.4/86.0/6.0 ms
840 frames 28.0 seconds 29.9 fps 20.0/33.4/231.0/13.1 ms
840 frames 27.5 seconds 30.5 fps 20.0/32.8/254.0/10.2 ms

But this may be improvement due to less printing only, I do not know.
Comment 4 Alex Deucher 2010-01-16 08:59:39 UTC
should be fixed in mesa master with r600 blit support.
Comment 5 Rafał Miłecki 2010-01-16 12:18:11 UTC
Thanks Andre, thanks Alex.