Bug 27169 - [gm45] the console output is not full screen due to spurious S-Video TV detection
[gm45] the console output is not full screen due to spurious S-Video TV detec...
Status: RESOLVED DUPLICATE of bug 25913
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
Other All
: medium normal
Assigned To: Rodrigo Vivi
:
: 29314 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 08:47 UTC by darkbasic
Modified: 2012-03-27 07:04 UTC (History)
6 users (show)

See Also:


Attachments
A photo of the screen showing the problem (992.97 KB, image/jpeg)
2010-03-18 08:53 UTC, darkbasic
no flags Details
Xorg.0.log (15.42 KB, text/plain)
2010-03-18 08:54 UTC, darkbasic
no flags Details
dmesg (drm.debug=0x04) (87.46 KB, text/plain)
2010-03-18 08:54 UTC, darkbasic
no flags Details
intel_reg_dumper (10.44 KB, text/plain)
2010-03-18 08:55 UTC, darkbasic
no flags Details
vbios.dump (64.00 KB, application/octet-stream)
2010-03-18 08:55 UTC, darkbasic
no flags Details
xrandr (verbose) (5.02 KB, text/plain)
2010-03-18 08:55 UTC, darkbasic
no flags Details
drm.debug for kernel 2.6.35-rc6 (101.13 KB, text/plain)
2010-07-24 05:28 UTC, darkbasic
no flags Details
intel_tv-2.6.38.c (894 bytes, text/plain)
2011-02-01 09:21 UTC, darkbasic
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description darkbasic 2010-03-18 08:47:37 UTC
Distro: gentoo amd64
xorg-server: 1.7.6
xf86-video-intel: 2.10.902 (2.11 RC2)
libdrm: 2.4.19
kernel: linux-2.6.33.1
mesa: 7.8_rc1

With kernel 2.6.32 I had no problems. I started having such a problem since earlier .33 rcs. Nothing is attached to the laptop.
xrandr shows TV output is on when I have such a issue (otherwise it is usually off).
This laptop (Samsung X360) doesn't even have a TV output!

Attachments:
- a photo of my laptop screen showing the problem
- Xorg.0.log
- dmesg (drm.debug=0x04)
- xrandr -q --verbose
- intel_reg_dumper
- echo 1 > /sys/devices/pci0000:00/0000:00:02.0/rom && cat
/sys/devices/pci0000:00/0000:00:02.0/rom > vbios.dump
Comment 1 darkbasic 2010-03-18 08:53:05 UTC
Created attachment 34203 [details]
A photo of the screen showing the problem
Comment 2 darkbasic 2010-03-18 08:54:13 UTC
Created attachment 34204 [details]
Xorg.0.log
Comment 3 darkbasic 2010-03-18 08:54:44 UTC
Created attachment 34205 [details]
dmesg (drm.debug=0x04)
Comment 4 darkbasic 2010-03-18 08:55:06 UTC
Created attachment 34206 [details]
intel_reg_dumper
Comment 5 darkbasic 2010-03-18 08:55:29 UTC
Created attachment 34207 [details]
vbios.dump
Comment 6 darkbasic 2010-03-18 08:55:45 UTC
Created attachment 34208 [details]
xrandr (verbose)
Comment 7 Chris Wilson 2010-07-19 10:49:30 UTC
The error is all due to the spurious TV detection; sometimes it is declared connected and sometimes disconnected. There has been some work in this area, but I can't find a patch that precisely matches.

This I think is promising for the misdetection:

commit 14571b4c1ac9c109f5d6d6e95cfdb92339151fe0
Author: Zhenyu Wang <zhenyuw@linux.intel.com>
Date:   Tue Mar 30 14:06:33 2010 +0800

    drm/i915: implement multifunction SDVO device support
    
    With new intel_encoder/intel_connector structure change, each supported
    connector type on SDVO device will be created as a new 'intel_connector',
    and all attached to one 'intel_encoder' for its SDVO port.
    
    The SDVO encoder will handle SDVO protocol stuff, and each connector does
    its own part of work now, like detection is only to check if current active
    output is itself, etc.
    
    Update since last submit:
    - Fixed SDVO TV property creation failure by incorrect set target output call
    
    Signed-off-by: Zhenyu Wang <zhenyuw@linux.intel.com>

darkbasic, can you check against the current bits to save me a wild goose chase?
Comment 8 darkbasic 2010-07-19 16:28:26 UTC
Thank you for answering.
My adsl stopped working and I use my mobile phone to connect to the internet, so I can't download an entire kernel with git. Instead I downloaded a 2.6.35-rc5 tarball which is a lot smaller (I think this patch is in 2.6.35-rc5, am I right?)
I think it's the same commit I read of on phoronix in the 2.6.35-rc1 (or rc2?) changelog.

Unfortunately it did not solve the problem :(
This damn problem forces me to reboot and reboot and reboot again until it does not turn on the tv output, because if the tv output is on kde freezes when I start it.
I also cannot close the lid because otherwise the x server will freeze when I will open it.
I also cannot use latest stable xorg server because it gives me random freezes and xrandr does not work with it.
I also cannot change the display brightness without some ugly workarounds (but maybe there is a patch which will solve it) and I cannot watch movies on my tv because the intel driver does not work at 1360x768, even if I create the modeset.


The intel driver does not simply allow me to use my laptop.
It's funny to know that my laptop does not even have a tv out connector!
Is there a patch to DELETE tv out support from the intel driver?
I'm too much tired of this problem.
Comment 9 Jesse Barnes 2010-07-23 13:28:31 UTC
Yeah, should be easy enough to delete your TV output.  Just comment out the line that calls tv_init in drivers/gpu/drm/i915/intel_display.c (intel_modeset_init I think).
Comment 10 Chris Wilson 2010-07-24 04:44:29 UTC
Ah, I've seen other bug reports were .33 was reporting spurious TV connections fortunately since resolved. Can you please attach a drm.debug dmesg with current bits and lets have a look at the current status. Thanks.
Comment 11 darkbasic 2010-07-24 05:28:22 UTC
Created attachment 37350 [details]
drm.debug for kernel 2.6.35-rc6

Distro: gentoo amd64
xorg-server: 1.8.2
xf86-video-intel: 2.12
libdrm: git master
kernel: linux-2.6.35-rc6
mesa: 7.8.2

I attached drm.debug-2.6.35-rc6
Comment 12 Chris Wilson 2010-07-24 06:26:53 UTC
Eek, still occasionally detecting the S-Video out.
Comment 13 darkbasic 2010-07-27 05:45:52 UTC
Yes, it does :-(
Is there someone working on it?
If you need to test patches or if you want more logs let me know, I definitely want it fixed.
Comment 14 Chris Wilson 2010-08-08 15:37:36 UTC
*** Bug 29314 has been marked as a duplicate of this bug. ***
Comment 15 darkbasic 2010-09-09 09:59:31 UTC
2.6.36 (today's git snapshot) is stil bugged...
Comment 16 Chris Wilson 2011-02-01 04:42:23 UTC
This [applied to -fixes] should fix the transient SDVO detections:

commit d121a5d2a098ba6dd033dd195f5ccbf7558c37b6
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Jan 25 15:00:01 2011 +0000

    drm/i915/sdvo: If at first we don't succeed in reading the response, wait
    
    We were not pausing after detecting the response was pending and so did
    not allow the hardware sufficient time to complete before aborting. This
    lead to transient failures whilst probing SDVO devices.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=30235
    Reported-by: Knut Petersen <Knut_Petersen@t-online.de>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 17 darkbasic 2011-02-01 08:13:39 UTC
Unfortunately drm-intel-fixes doesn't solve anything: still occasionally detecting the S-Video out :(
Comment 18 Chris Wilson 2011-02-01 08:31:06 UTC
Oh well. Partly because it's not even an SDVO device...
Comment 19 darkbasic 2011-02-01 09:20:59 UTC
!!!!!!!!*SOLVED* *SOLVED* *SOLVED* *SOLVED*!!!!!!!!

In my desperate search for a workaround I found a patch which does work: https://patchwork.kernel.org/patch/90982/

Unfortunately it has been reverted (http://www.mail-archive.com/intel-gfx@lists.freedesktop.org/msg00262.html) because Eric Anholt told it was bad (see the previous link).

I slightly modified it to apply against 2.6.38/drm-intel-fixes and it just works, 100% reliable!

If someone else is interested I uploaded the updated patch.
Comment 20 darkbasic 2011-02-01 09:21:43 UTC
Created attachment 42814 [details]
intel_tv-2.6.38.c
Comment 21 Chris Wilson 2011-04-21 22:30:41 UTC
Ok, the reason the patch was dropped is that we don't know whether it just turns off TV detection completely. Are you able to test hooking up your machine to a TV?
Comment 22 darkbasic 2011-04-22 02:08:26 UTC
I can't because my laptop doesn't have a TV out connector.
Comment 23 Jan de Groot 2011-11-07 06:06:54 UTC
What's the state of this bugreport? So far Archlinux and some other distributions have been carrying around this patch for ages without anyone complaining that the TV-Out doesn't work on his GM45. I don't think you'll find someone with GM45 and TV-Out anyways.
Comment 24 darkbasic 2011-11-07 09:41:04 UTC
> So far Archlinux and some other
> distributions have been carrying around this patch for ages without anyone
> complaining that the TV-Out doesn't work on his GM45.

In this case it should go upstream I think.
Comment 25 darkbasic 2011-12-18 05:57:30 UTC
up
Comment 26 Rodrigo Vivi 2012-03-27 06:15:45 UTC
Up! Daniel schedule this patch for -next and it should land on 3.5.
Comment 27 darkbasic 2012-03-27 06:51:31 UTC
Awesome, thanks for pushing for mainline inclusion.
Comment 28 Daniel Vetter 2012-03-27 07:04:11 UTC
Queued for 3.5, I'll close this one as a duplicate of the bug I have in the commit message.

*** This bug has been marked as a duplicate of bug 25913 ***