Bug 28306 - [Arrandale] VGA output buggy (wavering/out-of-phase-ness)
[Arrandale] VGA output buggy (wavering/out-of-phase-ness)
Status: RESOLVED WONTFIX
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Chris Wilson
https://bugzilla.kernel.org/show_bug....
:
: 28858 28899 33416 36599 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 17:20 UTC by Maxime C
Modified: 2011-07-15 07:15 UTC (History)
28 users (show)

See Also:


Attachments
Picture of the screen showing the bug (394.18 KB, image/jpeg)
2010-06-02 08:46 UTC, Maxime C
no flags Details
Video of the bug (304.85 KB, video/x-msvideo)
2010-06-02 08:52 UTC, Maxime C
no flags Details
Xorg Log file (27.87 KB, text/plain)
2010-06-02 12:26 UTC, Maxime C
no flags Details
dmesg just after a reboot with the screen plugged. (49.64 KB, text/plain)
2010-06-02 12:29 UTC, Maxime C
no flags Details
xrandr --verbose (6.41 KB, text/plain)
2010-06-02 12:32 UTC, Maxime C
no flags Details
intel_reg_dump (10.88 KB, text/plain)
2010-10-07 22:40 UTC, milki
no flags Details
xorg (27.18 KB, text/plain)
2010-10-07 22:41 UTC, milki
no flags Details
Poke SSC bits (5.23 KB, patch)
2011-01-12 15:10 UTC, Chris Wilson
no flags Details | Splinter Review
Vostro 3300 (8.63 KB, text/plain)
2011-05-10 04:27 UTC, jonatasmv@gmail.com
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime C 2010-05-28 17:20:08 UTC
Hello,

I recently bought a new laptop with an Intel HD Graphics chipset. (with intel core i5)

Here the lspci line :
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)

The symptoms :

When I plug my second screen on the VGA output, the screen resolution and frequency seems well recognized but in fact the display is not correct and I can't use it expect for reading videos.

It's a bit difficult to explain but it's like if you take each pixel and do a horizontal translation of 2 or 3 pixels on the left or right and repeat it randomly...

I've tried with several screens. I had a similar problem with my previous laptop with a ATI X1400 but fixed with modeset=0 (the problem was worst because I couln't use the native resolution of my screen). Here this solution freeze my computer.


I've tried with Ubuntu 10.04 and Archlinux (testing).
Kernel 2.6.31, 2.6.32, 2.6.33 and 2.6.34 tried.
Driver intel 2.9.0 and 2.11.0 tried.
libdrm 2.4.18
Comment 1 Jesse Barnes 2010-06-01 12:13:54 UTC
Would it be possible to take a picture or video of the corruption you see?

Also, can you use the xrandr tool to set other modes?  Do they work?  What if you create new modes using cvt & add them using xrandr?
Comment 2 Maxime C 2010-06-01 12:46:01 UTC
(In reply to comment #1)
> Would it be possible to take a picture or video of the corruption you see?
> 
> Also, can you use the xrandr tool to set other modes?  Do they work?  What if
> you create new modes using cvt & add them using xrandr?

I'll try tomorrow because I only have my phone to take pictures and the quality is worst than the problem itself :D.

I have the same problem without launching X ! (I think this bug is related to KMS)

I didn't try to create new modes and add them because the resolution is already the good one so I don't know what to try. And with a lower resolution I have the same issue (but the text is bigger so I can read it).
Comment 3 Maxime C 2010-06-02 08:46:52 UTC
Created attachment 36009 [details]
Picture of the screen showing the bug

The photo is of good quality ! It's exactly what I see on the screen.
Comment 4 Maxime C 2010-06-02 08:52:17 UTC
Created attachment 36010 [details]
Video of the bug
Comment 5 Jesse Barnes 2010-06-02 11:45:50 UTC
Can you attach your X log, dmesg and the output from "xrandr --verbose"?  I want to see what timings we're sending to the monitor.
Comment 6 Maxime C 2010-06-02 12:26:35 UTC
Created attachment 36015 [details]
Xorg Log file

There is no xorg.conf.
Comment 7 Maxime C 2010-06-02 12:29:33 UTC
Created attachment 36016 [details]
dmesg just after a reboot with the screen plugged.
Comment 8 Maxime C 2010-06-02 12:32:00 UTC
Created attachment 36017 [details]
xrandr --verbose
Comment 9 Jesse Barnes 2010-06-02 12:39:19 UTC
Zhenyu, possible PLL programming bug?
Comment 10 Maxime C 2010-06-02 13:00:39 UTC
(In reply to comment #8)
> Created an attachment (id=36017) [details]
> xrandr --verbose

And this is the same 
"  1680x1050 (0x84)  119.0MHz +HSync -VSync *current +preferred
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock   64.7KHz
        v: height 1050 start 1053 end 1059 total 1080           clock   59.9Hz"
with my other laptop. But it's working with this one (with a ATI card).

And I have the same problem with other screens.


(I am now using libdrm 2.4.20 but nothing has changed)
Comment 11 Maxime C 2010-06-09 15:39:19 UTC
(In reply to comment #9)
> Zhenyu, possible PLL programming bug?

Is there anything I can do to help ?

(I finally decided to accept the cluf of windows to try with Windows and the output is working great so it's a software issue.)
Comment 12 jujubinche 2010-07-08 07:21:46 UTC
*** Bug 28899 has been marked as a duplicate of this bug. ***
Comment 13 Chris Wilson 2010-07-20 06:49:16 UTC
(In reply to comment #9)
> Zhenyu, possible PLL programming bug?

Or in the light of the current fun, possible FIFO programming bug?
Comment 14 Chris Wilson 2010-08-06 11:39:52 UTC
Given Arrandale + VGA + NVSync, you probably want to try either Dave Airlie's drm-core-next or Linus's current tree to grab the modesetting fixes for the above combo.

Maxime, can you do that and see if that resolves the issue?
Comment 15 Maxime C 2010-08-07 05:30:10 UTC
(In reply to comment #14)
> Given Arrandale + VGA + NVSync, you probably want to try either Dave Airlie's
> drm-core-next or Linus's current tree to grab the modesetting fixes for the
> above combo.
> 
> Maxime, can you do that and see if that resolves the issue?

Hi,

I'm now using the last kernel from git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6
I will try to find a monitor next week to check whether the issue is fixed or not.

Thanks.
Comment 16 Alistair Buxton 2010-08-07 12:41:32 UTC
Somebody reported identical symptoms with a Clarkdale chip: 
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/600407

Same bug?
Comment 17 Maxime C 2010-08-07 13:03:16 UTC
(In reply to comment #16)
> Somebody reported identical symptoms with a Clarkdale chip: 
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/600407
> 
> Same bug?

I don't remember which kernels I tried but it looks more like this one :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/614238
Comment 18 Alistair Buxton 2010-08-08 07:47:55 UTC
Yes, I am trying to figure out if those two are the same bug or not. The latter is using Arrandale hardware but they both describe same symptoms.
Comment 19 Maxime C 2010-08-09 09:51:22 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > Given Arrandale + VGA + NVSync, you probably want to try either Dave Airlie's
> > drm-core-next or Linus's current tree to grab the modesetting fixes for the
> > above combo.
> > 
> > Maxime, can you do that and see if that resolves the issue?
> 
> Hi,
> 
> I'm now using the last kernel from
> git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6
> I will try to find a monitor next week to check whether the issue is fixed or
> not.
> 
> Thanks.

I just tried and nothing changed :(.

kernel 2.6.35, Linus tree from Saturday.
libdrm 2.4.21
not sure about the xf86-video-intel driver but it also happens before launching Xorg so I guess that doesn't matter ?

Is there a patch in drm-core-next, that could possibly fixes the issue ?
Comment 20 Wang Zhenyu 2010-08-15 21:32:22 UTC
Does it only happen to 1680x1050 mode? Have you tried other mode like 1024x768 to produce the same symptom? And this is only on VGA right?
Comment 21 Maxime C 2010-08-16 01:33:13 UTC
(In reply to comment #20)
> Does it only happen to 1680x1050 mode? Have you tried other mode like 1024x768
> to produce the same symptom? And this is only on VGA right?

Every resolution (tested on several different screens and video projector). The internal laptop display is fine and I only have a VGA output but according to other similars problems, it seems to affect only VGA.
Comment 22 Chris Wilson 2010-09-13 12:56:53 UTC
*** Bug 28858 has been marked as a duplicate of this bug. ***
Comment 23 Dawid Lorenz 2010-09-24 09:11:51 UTC
I have Dell Vostro 3300 laptop with Intel 4500HD + nVidia GF310M hybrid combo running under Fedora 13.

[evad@v3300 ~]$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)

Since I can't make nVidia card work in this setup due to completely different issue (hint: nVidia's new "Optimus" technology), I am forced to use intel card and I also experience that "fuzziness" on external monitor (tried on two different screens and VGA cables), exactly same as on attached picture/video. I am more than happy to help solve this issue asap.

A side note, might be helpful, might not -- ATI card users under Ubuntu apparently experienced the same problem with external screen VGA output and got it fixed somehow. Details:
http://beyondteck.blogspot.com/2010/05/flickering-monitor-in-ubuntu-1004-for.html
http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1485861 (post #9)
Comment 24 milki 2010-10-07 22:40:41 UTC
Created attachment 39279 [details]
intel_reg_dump

I opened a new thread on the mailing list:
http://lists.freedesktop.org/archives/intel-gfx/2010-October/008315.html

I am also experiencing waviness on my VGA output. As stated in the thread, I have a Shuttle SH55J2 which has the Intel H55 chipset
(Auburndale). I am xf86-video-intel-2.12.0-3 for arch linux and kernel 2.6.35.7-ARCH, which should correspond to 2.6.35.7-1.

I've attached my intel_reg_dump and will follow with my Xorg.conf as requested, though the problem starts during booting.
Comment 25 milki 2010-10-07 22:41:15 UTC
Created attachment 39280 [details]
xorg
Comment 26 Daniele Dellafiore 2010-10-12 01:31:39 UTC
same problem on brand new Dell Vostro V3300 with Ubuntu Maverick final and intel 2.12 driver. 

Please tell me what kind of info I can provide to help.
Comment 27 Fernando Hidalgo 2010-10-22 05:04:07 UTC
Hi, I have the same problem with a Dell Vostro 3300, i3 processor, Intel integrated graphic controller.

I have it since June that I bought it. The problem appear with my Acer proyectoy and also with a new Packard Bell flat screen, only that with last one sometimes the image flicker and sometimes doesn't appear, just a blank screen.

I was looking for internet and the are a lot of reports of this problems, not only with Dell. Also there a guy that say that have a solution but for it suggest to download and install a special 2.6 kernel version , I don't like a lot the idea, this is the link:

http://beyondteck.blogspot.com/2010/05/flickering-monitor-in-ubuntu-1004-for.html

I'm working with the last kernel that I can download from the update manager: :

Release 10.10 (maverick)
Kernel Linux 2.6.35-22-generic
GNOME 2.32.0

If you need more information, just let me know. I'm relatively newby in linux but I have a lot of years in IT.

Regards.
Comment 28 Daniele Dellafiore 2010-10-22 05:17:49 UTC
For Ubuntu users, there is this downstream bug open
https://bugs.launchpad.net/linux/+bug/614238 where you can report problem and monitor progress.
Comment 29 Fernando Hidalgo 2010-10-22 05:25:42 UTC
Oh.. thank you, I'm a bit lost on this of the bugs.
Comment 30 Dawid Lorenz 2010-10-22 09:33:17 UTC
(In reply to comment #27)
> Hi, I have the same problem with a Dell Vostro 3300, i3 processor, Intel
> integrated graphic controller.
> 
> I have it since June that I bought it. The problem appear with my Acer
> proyectoy and also with a new Packard Bell flat screen, only that with last one
> sometimes the image flicker and sometimes doesn't appear, just a blank screen.
> 
> I was looking for internet and the are a lot of reports of this problems, not
> only with Dell. Also there a guy that say that have a solution but for it
> suggest to download and install a special 2.6 kernel version , I don't like a
> lot the idea, this is the link:
> 
> http://beyondteck.blogspot.com/2010/05/flickering-monitor-in-ubuntu-1004-for.html

You might want to revisit this solution, as it concerns ATI cards, not Intel...
Comment 31 Daniele Dellafiore 2010-10-25 02:13:05 UTC
This bug is marked as NEEDINFO, what kind of additional info is needed?
Comment 32 Zsolt Présing 2010-10-27 13:48:23 UTC
Hi, I have tried to use Intel Driver 2.13git using these packages created for ubuntu:
https://launchpad.net/~glasen/+archive/intel-driver
This provides:
 xserver-xorg-video-intel version:2.13
 libdrm-intel1 version:2.4.22
Nothing changed. The bug still exists.

Also tried to install Intel microcode 2010-09-14:
during boot i see this:
"intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled"
which i have not recognized before using microcode update.

Also tried to use another laptop with ATI card and watched same bug with external monitor, BUT after setting "nomodeset" kernel parameter in grub, it worked!
If I set the same "nomodeset" for Intel, then I cannot start X server. I think that is because Intel Driver only works with KMS.

Using xf86-video-intel I can see the same bug.

I have tried several resolutions, several external monitors with VGA cable.
The kernel i use: 2.6.36-020636-generic.
Processor: Intel Core i5 mobile.
Comment 33 Zsolt Présing 2010-10-28 04:59:35 UTC
Hi! Just tried to use a 32 bit laptop with some kind of ATI card, with Ubuntu 10.04 and 10.10 versions.
Using 10.04 the output was buggy/wavy.
Using 10.10 the output was OK!

Problem occured with GNOME, KDE, xf86 and Xorg too.

So It looks like problem already solved for ATI cards!!!! I have found this bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/562138
reporting this error for ATI card, with older kernels, but not with newer kernels.
And these bugs looks also the same for ATI cards:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/541834
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/569597

Comments corresponding to bugs abova say that installing a kernel 2.6.34 or newer solves the problem for ATI cards. Not for Intel of course.

I dont know ho KMS works, but if KMS is implemented differently for different graphic cards, then maybe Intel part of KMS has the cause of this bug. Or a communication or API calls issue between KMS and kernel and Intel driver?

The man who fixed the bug for ATI cards probably could help.
Comment 34 Dawid Lorenz 2010-11-01 15:49:26 UTC
Just booted into Fedora 14 RC1 LiveCD with 2.6.35.6-45 kernel and xorg-x11-drv-intel-2.12.0-6 driver and I can only tell that this bug still persists. :(
Comment 35 Daniele Dellafiore 2010-11-08 03:20:17 UTC
Anyone working on this for upcoming  intel 2.14 driver?

Here is the change log
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/log/
Comment 36 Wang Zhenyu 2010-11-14 17:44:13 UTC
Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36 or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require newer xf86-video-intel driver.
Comment 37 Jasper Van der Jeugt 2010-11-15 00:21:38 UTC
(In reply to comment #36)
> Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> newer xf86-video-intel driver.

I've updated the kernel on my archlinux laptop to 2.6.36, the problem is still there. Haven't been able to test 2.6.36-rc yet.
Comment 38 Daniele Dellafiore 2010-11-15 03:07:13 UTC
(In reply to comment #36)
> Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> newer xf86-video-intel driver.

I can try the UBuntu Natty daily live that should have 2.6.37, if the early alpha is able to boot :)

Anyway if is A KMS issue and you cannot reproduce the problem, maybe this is not the right place for this issue. Is KMS supposed to be completely under the control of the kernel right now? If so should not we open a issue elsewhere?
Comment 39 fbastante 2010-11-16 00:44:08 UTC
(In reply to comment #36)
> Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> newer xf86-video-intel driver.

I tried yesterday the ubuntu maverick 2.6.37-rc1 and it's still there :-(
Comment 40 Fernando Hidalgo 2010-11-16 03:14:27 UTC
May be it is useful for you. Yesterday I realized that the waving gets worse from left to right side of the screen.
Comment 41 Dawid Lorenz 2010-11-16 03:19:40 UTC
(In reply to comment #38)
> (In reply to comment #36)
> > Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> > or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> > newer xf86-video-intel driver.
> 
> I can try the UBuntu Natty daily live that should have 2.6.37, if the early
> alpha is able to boot :)
> 
> Anyway if is A KMS issue and you cannot reproduce the problem, maybe this is
> not the right place for this issue. Is KMS supposed to be completely under the
> control of the kernel right now? If so should not we open a issue elsewhere?

Other question is how to force KMS off and then test this issue again? Is this possible at all (disabling KMS that is)?
Comment 42 Maxime C 2010-11-16 03:37:58 UTC
(In reply to comment #41)
> (In reply to comment #38)
> > (In reply to comment #36)
> > > Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> > > or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> > > newer xf86-video-intel driver.
> > 
> > I can try the UBuntu Natty daily live that should have 2.6.37, if the early
> > alpha is able to boot :)
> > 
> > Anyway if is A KMS issue and you cannot reproduce the problem, maybe this is
> > not the right place for this issue. Is KMS supposed to be completely under the
> > control of the kernel right now? If so should not we open a issue elsewhere?
> 
> Other question is how to force KMS off and then test this issue again? Is this
> possible at all (disabling KMS that is)?

You cannot use this chipset without KMS. That will just freeze. (At least when I tried)
Comment 43 Zsolt Présing 2010-11-16 03:40:25 UTC
As far as I know the newer (after v2.9 (current v2.13)) Intel drivers supports only KMS enabled mode. I tried out the 2.9 driver too, but it seems to be not supported using Arrandale CPU-s.

Using my old laptop with ATI card, which had the same problem with kernels older than 2.6.34, this problem could be solved by turning off KMS. KMS can be turned off by passing the "nomodeset" kernel parameter.

(In reply to comment #41)
> (In reply to comment #38)
> > (In reply to comment #36)
> > > Sorry I can't be able to produce this here. Could someone test if kernel 2.6.36
> > > or 2.6.37-rc has fixed this problem? It's purely KMS issue, so not require
> > > newer xf86-video-intel driver.
> > 
> > I can try the UBuntu Natty daily live that should have 2.6.37, if the early
> > alpha is able to boot :)
> > 
> > Anyway if is A KMS issue and you cannot reproduce the problem, maybe this is
> > not the right place for this issue. Is KMS supposed to be completely under the
> > control of the kernel right now? If so should not we open a issue elsewhere?
> 
> Other question is how to force KMS off and then test this issue again? Is this
> possible at all (disabling KMS that is)?
Comment 44 Dawid Lorenz 2010-11-16 03:42:22 UTC
Thanks for prompt response. That brings back a question of who is actually responsible for fixing this bug? Intel guys or kernel guys?
Comment 45 Fernando Hidalgo 2010-11-16 03:48:05 UTC
Here you have a clear and simple explanation about Intel video cards and KMS:

https://wiki.archlinux.org/index.php/Intel#KMS_.28Kernel_Mode_Setting.29

About who, Intel or Kernel? I don't know. I'm programmer and now I have a lot of free time. I was thinking to contact somebody to help to solve this issue, but I don't know exactly how the open source community work. I'm not able to solve it without a expert support. If anyone know how it works, feel free to contact me.

Regards.
Comment 46 Dawid Lorenz 2010-11-16 03:48:37 UTC
Found this: https://bugzilla.kernel.org/show_bug.cgi?id=21742 which is referring directly to this bug entry. However I feel it needs to be extended with more details in order to get proper attention from someone @kernel.org...
Comment 47 Daniele Dellafiore 2010-11-16 04:09:18 UTC
I think we should move our "weight" to the kernel bug to attract attention of people at kernel.org.
Comment 48 Chris Wilson 2011-01-12 15:10:44 UTC
Created attachment 41942 [details] [review]
Poke SSC bits
Comment 49 Chris Wilson 2011-01-12 15:13:10 UTC
The same guy is responsible for fixing bugs in both bugs.fd.o and bugzilla.kernel.org!

The pictures do look like the waves are due to the 5% spread of SSC, which is not meant to be applied to CRT outputs.
Comment 50 Alexey Guseynov 2011-01-13 07:11:48 UTC
(In reply to comment #48)
> Created an attachment (id=41942) [details]
> Poke SSC bits

Thank you for the patch. Can you please tell for what kernel version is it? I've tried lates ubuntu maveric kernels and lates vanilla kernel, but the patch does not apply well on drivers/gpu/drm/i915/intel_display.c.
I tried applying it manually and compiling, but compilation fails with 
/home/kibergus/linux-2.6.37/drivers/gpu/drm/i915/intel_display.c: In function ‘intel_crtc_mode_set’:
/home/kibergus/linux-2.6.37/drivers/gpu/drm/i915/intel_display.c:3825: error: implicit declaration of function ‘intel_panel_use_ssc’

I have following code on this line:
    if ((is_lvds || has_edp_encoder) &&
--->        intel_panel_use_ssc(dev_priv)) {
        temp |= DREF_SSC_SOURCE_ENABLE;
        if (has_edp_encoder) {

I'm a little bit confused because upached kernel calls this function too, but compiles fine.
Comment 51 Gustavo Padovan 2011-01-13 11:41:14 UTC
(In reply to comment #50)
> (In reply to comment #48)
> > Created an attachment (id=41942) [details] [details]
> > Poke SSC bits
> 
> Thank you for the patch. Can you please tell for what kernel version is it?
> I've tried lates ubuntu maveric kernels and lates vanilla kernel, but the patch
> does not apply well on drivers/gpu/drm/i915/intel_display.c.
> I tried applying it manually and compiling, but compilation fails with 
> /home/kibergus/linux-2.6.37/drivers/gpu/drm/i915/intel_display.c: In function
> ‘intel_crtc_mode_set’:
> /home/kibergus/linux-2.6.37/drivers/gpu/drm/i915/intel_display.c:3825: error:
> implicit declaration of function ‘intel_panel_use_ssc’
> 
> I have following code on this line:
>     if ((is_lvds || has_edp_encoder) &&
> --->        intel_panel_use_ssc(dev_priv)) {
>         temp |= DREF_SSC_SOURCE_ENABLE;
>         if (has_edp_encoder) {
> 
> I'm a little bit confused because upached kernel calls this function too, but
> compiles fine.

It need to be compiled against branch staging from Chris' tree:

git://git.kernel.org/pub/scm/linux/kernel/git/ickle/drm-intel.git
Comment 52 Gustavo Padovan 2011-01-13 12:19:15 UTC
(In reply to comment #49)
> The same guy is responsible for fixing bugs in both bugs.fd.o and
> bugzilla.kernel.org!
> 
> The pictures do look like the waves are due to the 5% spread of SSC, which is
> not meant to be applied to CRT outputs.

The patch fixes the problem for me. X is not working yet, but probably due to an out-of-date version of libdrm and/or xf86-video-intel to work with drm-intel tree. Thanks a lot Chris for fixing this issue. Great job! ;-)
Comment 53 Daniele Dellafiore 2011-01-13 12:26:00 UTC
Thanks for solving the issue!

Will you please let us know when the patch will arrive on the main .37 branch?
Comment 54 Dawid Lorenz 2011-01-13 13:35:21 UTC
(In reply to comment #51)
> It need to be compiled against branch staging from Chris' tree:
> 
> git://git.kernel.org/pub/scm/linux/kernel/git/ickle/drm-intel.git

Sorry for being potentially ignorant but could someone provide a brief instruction how to apply/compile/make this patch work? I can't wait to see this fixed, yet I have no idea about kernel development. :( I'm running stock kernel 2.6.35.10-74.fc14.i686.PAE on Fedora 14.

Thanks in advance.
Comment 55 Maxime C 2011-01-13 23:46:06 UTC
Thank you very much Chris! I just tried yesterday night, I compiled the kernel from git://git.kernel.org/pub/scm/linux/kernel/git/ickle/drm-intel.git

Without X, it's working well. And the bug is also fixed with Xorg but I cannot use it because now my screen switch off after few seconds and the laptop screen don't respond after few seconds too (only the mouse can move...).
I did not tried without applying the patch. Is this new problem linked to this patch or to something else? Do I need to update my Intel graphic driver?
Comment 56 Alexey Guseynov 2011-01-14 03:57:25 UTC
Chris, than you very much. Now i have normally working big LCD screen. But external and internal screens do not work well together. LVDS is always black and VGA works only when LVDS is disabled or when screens are in clone mode with identical resolution.
But I think, that it is another bug which is present in unpached kernels and was fixed in latest 2.6.37 kernel.
Anyway, big VGA is much better, than small LVDS. Than you very much.
Comment 57 Chris Wilson 2011-01-19 06:36:46 UTC
(In reply to comment #56)
> Chris, than you very much. Now i have normally working big LCD screen. But
> external and internal screens do not work well together. LVDS is always black
> and VGA works only when LVDS is disabled or when screens are in clone mode with
> identical resolution.
> But I think, that it is another bug which is present in unpached kernels and
> was fixed in latest 2.6.37 kernel.
> Anyway, big VGA is much better, than small LVDS. Than you very much.

I've applied the patch to -next since it needs more soak testing. Can you confirm and open a bug for VGA/LVDS misbehaviour? Thanks.
Comment 58 Daniele Dellafiore 2011-01-24 00:51:34 UTC
(In reply to comment #57)
 
> I've applied the patch to -next since it needs more soak testing. 

Hi. This means no chance to have it in 2.6.38 timeline?
Comment 59 Alexey Guseynov 2011-01-24 09:37:59 UTC
(In reply to comment #57)
> I've applied the patch to -next since it needs more soak testing. Can you
> confirm and open a bug for VGA/LVDS misbehaviour? Thanks.

I'm not familiar with kernel development process so I couldn't find out what -next is. Can you give an URL please?
(In reply to comment #57)
Comment 60 philip z 2011-01-24 09:41:56 UTC
If I'm not mistaken, http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git;a=shortlog;h=refs/heads/drm-intel-next is the branch which has the patch.
Comment 61 micha 2011-01-25 13:18:33 UTC
Sorry, i am a beginner. so, is there a easy way to solve this problem???
Comment 62 Maxime C 2011-01-25 13:36:18 UTC
(In reply to comment #61)
> Sorry, i am a beginner. so, is there a easy way to solve this problem???

Well, there is a patch that fixes this problem but there is also a regression that will prevent you to use both your internal and external screen... Actually, I did not managed to use it with Xorg...

So the good new is that we now know what caused this bug. The problem is that now you won't be able to use both your screens at the same time (that's worst for me because I was using my external screen for the videos).

We need to help the developers by testing and testing again and hopefully this bug will be fixed.
Comment 63 Dawid Lorenz 2011-01-25 14:38:10 UTC
(In reply to comment #62)
> (In reply to comment #61)
> > Sorry, i am a beginner. so, is there a easy way to solve this problem???
> 
> Well, there is a patch that fixes this problem but there is also a regression
> that will prevent you to use both your internal and external screen...
> Actually, I did not managed to use it with Xorg...
> 
> So the good new is that we now know what caused this bug. The problem is that
> now you won't be able to use both your screens at the same time (that's worst
> for me because I was using my external screen for the videos).

Is there a bug entry filed somewhere for that regression?
Comment 64 Maxime C 2011-01-25 14:40:08 UTC
(In reply to comment #63)
> Is there a bug entry filed somewhere for that regression?

I don't know...
Comment 65 Alexey Guseynov 2011-01-27 05:50:56 UTC
I've tested kernel from. http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git;a=shortlog;h=refs/heads/drm-intel-next
Behaviour is the same. But I don't think, tha it is a regression. Unpatched kernel does not work with two monitors well too. It works on some modes and does not in other.
And I'm quite confident, this this this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=29278
And it is already solved. At least with ubuntus drm-intel-next kernel I'm able to select any supported resolutions and they work well with exception of jitter described in this bug.
Comment 66 Maxime C 2011-01-27 07:09:21 UTC
(In reply to comment #65)
> Behaviour is the same. But I don't think, tha it is a regression. Unpatched
> kernel does not work with two monitors well too. It works on some modes and
> does not in other.

I disagree, I am using an unpatched kernel and I can use two monitors but with this VGA bug (which is not really a problem for watching videos so it is important for me). I can select any resolution mode I want (while it is supported by my screens of course).
Unless you're talking about 2.6.37 unpatched kernels? I am using 2.6.35 right now.

When I'm booting on my 2.6.37 patched kernel, I can't use any of my screens if I plug my external screen, except without X (so I'm also suspecting a driver problem, I'm not using the very last version of the intel driver and the other related libs).
Comment 67 obtrusive fly 2011-02-03 07:04:43 UTC
Hi,

I've tried to apply this patch on 2.6.35 kernel from Ubuntu distr (i don't want to loose extras) but the process failed. I also tried it with 2.6.38.-rc3 from kernel.org but with the same sad result. On exactly what version of kernel Chris patch can be applied?
Comment 68 Zsolt Présing 2011-02-03 08:39:35 UTC
I dont know the exact answer to you question, but maybe this is helpful:
http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-02-natty/
I use this kernel which has the patch already integrated.

(In reply to comment #67)
> Hi,
> 
> I've tried to apply this patch on 2.6.35 kernel from Ubuntu distr (i don't want
> to loose extras) but the process failed. I also tried it with 2.6.38.-rc3 from
> kernel.org but with the same sad result. On exactly what version of kernel
> Chris patch can be applied?
Comment 69 info 2011-02-04 05:08:48 UTC
(In reply to comment #67)
> Hi,
> 
> I've tried to apply this patch on 2.6.35 kernel from Ubuntu distr (i don't want
> to loose extras) but the process failed. I also tried it with 2.6.38.-rc3 from
> kernel.org but with the same sad result. On exactly what version of kernel
> Chris patch can be applied?

you can also use Chris kernel:
git://git.kernel.org/pub/scm/linux/kernel/git/ickle/drm-intel.git
(use drm-intel-next) the patch is already integrated.

But the patch create a new bug with the x-server, and it is not solved yet, is'nt it? (console (strg+alt+f1) works fine!)
Comment 70 obtrusive fly 2011-02-04 07:41:06 UTC
(In reply to comment #69)
> (In reply to comment #67)
> > Hi,
> > 
> > I've tried to apply this patch on 2.6.35 kernel from Ubuntu distr (i don't want
> > to loose extras) but the process failed. I also tried it with 2.6.38.-rc3 from
> > kernel.org but with the same sad result. On exactly what version of kernel
> > Chris patch can be applied?
> 
> you can also use Chris kernel:
> git://git.kernel.org/pub/scm/linux/kernel/git/ickle/drm-intel.git
> (use drm-intel-next) the patch is already integrated.
> 
> But the patch create a new bug with the x-server, and it is not solved yet,
> is'nt it? (console (strg+alt+f1) works fine!)

Now I have kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-02-natty/ installed on Ubuntu Maverick (10.10) and in fact I am able to use only external monitor - the laptop lcd remains black. Additionaly Xorg seems to be unstable particularly when laptop lcd is closed for a while or energy saver system is activated - after recovery both screens remains black.
Comment 71 info 2011-02-04 10:15:38 UTC
(In reply to comment #70)
> Now I have kernel from
> http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-02-natty/
> installed on Ubuntu Maverick (10.10) and in fact I am able to use only external
> monitor - the laptop lcd remains black. Additionaly Xorg seems to be unstable
> particularly when laptop lcd is closed for a while or energy saver system is
> activated - after recovery both screens remains black.

this kernel doesn't work for me... I got this failure: "[drm:intel_disable_trancoder] *ERROR* failed to disable transcoder" evertime i switch the terminal on the external monitor (console works fine). 

Tested on ubuntu 10.10 (64 bit) dell Vostro 3300 (Core i5, Intel HD Graphics chipset) 22" vga Monitor (1680*1050).
Comment 72 freedesktop 2011-02-10 15:22:17 UTC
Comment on attachment 41942 [details] [review]
Poke SSC bits

How can I apply this patch?
Comment 73 info 2011-02-11 00:43:54 UTC
(In reply to comment #72)
> (From update of attachment 41942 [details] [review])
> How can I apply this patch?

Kernel: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-02-natty (patch already integrated)
Comment 74 M K 2011-02-11 11:44:17 UTC
I have same problem (flickering as in photo) even after updating everything.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)

I'm quite not sure where to problem is.
Comment 75 M K 2011-02-14 05:35:36 UTC
(In reply to comment #73)
> (In reply to comment #72)
> > (From update of attachment 41942 [details] [review] [details])
> > How can I apply this patch?
> 
> Kernel:
> http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-02-natty
> (patch already integrated)

Can I apply those when I'm on Fedora 14 ? If so then how ? I'm new to linux and I bought these for company but we need to be able to use external monitors, so please, explain.
Comment 76 Javier Jardón 2011-03-05 04:48:15 UTC
Current status: seems that the patch was reverted from the linux-next branch.

From http://lists.freedesktop.org/archives/dri-devel/2011-February/008869.html:

"
The issue is that there is but a single clock source for the outputs, and
we were not correctly handling the cases where we needed both SSC and
non-SSC outputs. As a result the patch caused us to lose sync on external
DP in some configurations, and so I needed to back out the change until we
can fix it correctly.
-Chris
"
Comment 77 Chris Wilson 2011-03-29 08:10:55 UTC
*** Bug 33416 has been marked as a duplicate of this bug. ***
Comment 78 info 2011-03-29 08:31:06 UTC
(In reply to comment #77)
> *** Bug 33416 has been marked as a duplicate of this bug. ***

@Chris: if there has been any progress made?
Comment 79 Javier Jardón 2011-05-04 09:19:00 UTC

*** This bug has been marked as a duplicate of bug 36599 ***
Comment 80 Javier Jardón 2011-05-04 09:22:41 UTC
New patch available here: https://bugs.freedesktop.org/show_bug.cgi?id=36599#c7
Comment 81 Maxime C 2011-05-04 11:17:39 UTC
(In reply to comment #79)
> 
> *** This bug has been marked as a duplicate of bug 36599 ***

Hum, 19 people are following this one, it would have made more sense to mark 36599 as duplicate of 28306 instead... I'll do it.
Comment 82 Maxime C 2011-05-04 11:18:08 UTC
*** Bug 36599 has been marked as a duplicate of this bug. ***
Comment 83 Michel Filipe 2011-05-04 12:09:52 UTC
I tried the patch of https://bugs.freedesktop.org/show_bug.cgi?id=36599#c7, but it doesn't solve my problem.

Talking with Chris Wilson in IRC, he says: "..., can you add some printk() around the ssc just to check that I did it right". Can anyone do this?

MY SYSTEM ENVIRONMENT

chipset: Intel Corporation 5 Series/3400 Series Chipset
graphic card: Intel Corporation Core Processor Integrated Graphics Controller
(rev 02)
system architecture: i686
xf86-video-intel/xserver/mesa/libdrm version: libdrm-2.4.23
xserver-xorg-video-intel-2.14.0 xserver-7.6 mesa-7.10.2
kernel version: 2.6.38-8-generic-pae
Linux distribution: Ubuntu 11.04 beta 2
Machine or mobo model: Lenovo Thinkpad T410s 2901-ATU
Display connector: VGA
Comment 84 jonatasmv@gmail.com 2011-05-09 07:27:07 UTC
I have a vostro 3300 and what I can help I'm available. I'm using Ubuntu 4.11 and the video continues with the same problem.
Comment 85 Maxime C 2011-05-09 07:39:31 UTC
(In reply to comment #84)
> I have a vostro 3300 and what I can help I'm available. I'm using Ubuntu 4.11
> and the video continues with the same problem.

Ubuntu 11.04 :D. Anyway, if you wanna help, please try the patch provided by Chris (there are actually 2 different patchs available). Try them and give us feedback.

I am currently away from home (in Zurich) and I don't have any screen with a VGA plug at work. I'll be back in one month and half and I am willing to help as much as I can. But he would be great if that could be fixed before ;).

So please, anyone, try the patch, rebuild and give feedbacks.

@Chris, can you list the things you would like us to test? Thanks for your help.
Comment 86 info 2011-05-09 07:55:55 UTC
for now we use the drm-next-kernel: 
2.6.38-997-generic #201102081238 SMP Tue Feb 8 13:55:10 UTC 2011 i686 GNU/Linux

http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-02-08-natty/ (it is delete?)

it works on vostro 3300 when you switch off all visual effects and don't try to change vga-mode to single or dual screen (changes works after reboot).

Rdy for testing!
Comment 87 jonatasmv@gmail.com 2011-05-10 04:27:15 UTC
Created attachment 46540 [details]
Vostro 3300
Comment 88 jonatasmv@gmail.com 2011-05-10 04:27:54 UTC
Tentei pelo:
http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2011-04-01-natty/
"Linux voyager 2.6.38-997-generic #201104011244 SMP Fri Apr 1 14:00:24 UTC 2011 i686 i686 i386 GNU/Linux"
e com o update:
"Linux voyager 2.6.39-0-generic-pae #5~20110427-Ubuntu SMP Wed Apr 27 18:53:48 UTC 2011 i686 i686 i386 GNU/Linux"
E o problema continua. Após o uso desses kernel foi necessário algo a mais?
Comment 89 jonatasmv@gmail.com 2011-05-10 04:28:31 UTC
I tried by:
http://kernel.ubuntu.com/ kernel-ppa/mainline/drm-intel-next/2011-04-01-natty ~ /
"Linux 2.6.38-voyager-generic 997 201 104 011 244 # 1 SMP Fri Apr 14:00:24 UTC 2011 i686 i686 i386 GNU / Linux"
and with the update:
"Linux 2.6.39 voyager-0-generic-pae # 20110427 ~ 5-Ubuntu SMP Wed Apr 27 18:53:48 UTC 2011 i686 i686 i386 GNU / Linux"
And the problem continues. After using these kernel was needed something more?
Comment 90 jonatasmv@gmail.com 2011-05-13 05:14:23 UTC
But the problem is the processor model is a problem or set of hardware that causes this? Biggest problem would use Ubuntu 64bit or 32bit?
Comment 91 julio prada 2011-05-13 08:55:45 UTC
(In reply to comment #90)
> But the problem is the processor model is a problem or set of hardware that
> causes this? Biggest problem would use Ubuntu 64bit or 32bit?

I think it relates to Intel cpus that include a gpu, like the Core i and the p6xx series. But not all Pcs show the problem, i've seen Core i 5 laptops without the problem, but probably with nvidia gpus.
Comment 92 Dawid Lorenz 2011-05-13 11:33:00 UTC
(In reply to comment #91)
> (In reply to comment #90)
> > But the problem is the processor model is a problem or set of hardware that
> > causes this? Biggest problem would use Ubuntu 64bit or 32bit?
> 
> I think it relates to Intel cpus that include a gpu, like the Core i and the
> p6xx series. But not all Pcs show the problem, i've seen Core i 5 laptops
> without the problem, but probably with nvidia gpus.

I recently came across Toshiba Protege R700 laptop based on Core-i5 and Intel GPU and it didn't have that problem on VGA output.
Comment 93 jonatasmv@gmail.com 2011-05-13 11:39:06 UTC
But is the core of Intel Arrandale the problem? Because I already found on forums vostro3300 working fine. For if it were the case could change only if the CPU of the notebook?
Comment 94 Michel Filipe 2011-05-13 12:02:06 UTC
(In reply to comment #92)
> (In reply to comment #91)
> > (In reply to comment #90)
> > > But the problem is the processor model is a problem or set of hardware that
> > > causes this? Biggest problem would use Ubuntu 64bit or 32bit?
> > 
> > I think it relates to Intel cpus that include a gpu, like the Core i and the
> > p6xx series. But not all Pcs show the problem, i've seen Core i 5 laptops
> > without the problem, but probably with nvidia gpus.
> 
> I recently came across Toshiba Protege R700 laptop based on Core-i5 and Intel
> GPU and it didn't have that problem on VGA output.

Dawid, this Toshiba has only vga output or it has displayport too? Chris Wilson says that the problem is with graphic-cards with ssc and non-ssc ports. The actual driver doesn't work well with these graphic-cards.
Comment 95 Dawid Lorenz 2011-05-13 12:03:16 UTC
(In reply to comment #94)
> > I recently came across Toshiba Protege R700 laptop based on Core-i5 and Intel
> > GPU and it didn't have that problem on VGA output.
> 
> Dawid, this Toshiba has only vga output or it has displayport too? Chris Wilson
> says that the problem is with graphic-cards with ssc and non-ssc ports. The
> actual driver doesn't work well with these graphic-cards.

It has both VGA and HDMI outputs.
Comment 96 jonatasmv@gmail.com 2011-05-13 12:24:47 UTC
Yes, laptops with HDMI output works apparently. Notebooks with only VGA is the problem! Correct?
Comment 97 Michel Filipe 2011-05-13 13:31:22 UTC
(In reply to comment #96)
> Yes, laptops with HDMI output works apparently. Notebooks with only VGA is the
> problem! Correct?

No, my laptop has VGA and DisplayPort.
Comment 98 jonatasmv@gmail.com 2011-05-16 10:34:49 UTC
How can I help? In the current kernel patch is not correct? Even though the Oneiric?
Comment 99 julio prada 2011-05-16 10:47:54 UTC
(In reply to comment #98)
> How can I help? In the current kernel patch is not correct? Even though the
> Oneiric?

Hi Jonatas, I installed a fresh Ubuntu 11.04 and the bug is still there, can you help us? can I do something about it?
Comment 100 jonatasmv@gmail.com 2011-05-16 12:01:45 UTC
What is your notebook / installation and configuration?
Comment 101 julio prada 2011-05-16 16:47:45 UTC
(In reply to comment #100)
> What is your notebook / installation and configuration?

Its a Toshiba c645 laptop with a P6100 cpu with:

Intel Corporation Core Processor Integrated Graphics Controller

Fresh Ubuntu 11.04 desktop 32 bit intallation.

Looks like the problem presents on laptops with only VGA connector (not on HDMI).

I tested with 2 external monitors, one being a AOC f22s.

Chris Wilson was handling this bug, but at some moment I could not hear from him anymore, this is one of his lasts replies:

----------------------------------------------------------------------------
On Sun, 27 Feb 2011 20:15:14 -0300, "Gustavo F. Padovan" <gust...@padovan.org> 
wrote:
> In bug #28306 at freedesktop.org[0] you created that fixed the problem and 
> pushed
> it to the -next. However I'm not seeing that patch anymore in linux-next and I
> have to apply it by hand to have my VGA working properly. Is there a reason to
> remove this patch from -next?

The issue is that there is but a single clock source for the outputs, and
we were not correctly handling the cases where we needed both SSC and
non-SSC outputs. As a result the patch caused us to lose sync on external
DP in some configurations, and so I needed to back out the change until we
can fix it correctly.
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

----------------------------------------------------------------------------

I am using other pc now, but will get back home in 10 days, so, can anyone else give us his parameters?

Thanks,
Comment 102 jonatasmv@gmail.com 2011-05-16 17:48:25 UTC
Would make a patch to be applied to the current Ubuntu kernel, or always have to compile from git's Chris?
Comment 103 jonatasmv@gmail.com 2011-05-17 20:14:46 UTC
How do the drivers for Windows to run? How do they get around this problem in ssc?
Comment 104 julio prada 2011-05-17 20:22:24 UTC
-What is ssc?, please, i found a list of about 80 meanings for ssc!
-The same exact hardwware works well under Windows (hard to say)
Thanks
Julio


On Tue, May 17, 2011 at 9:14 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=28306
>
> --- Comment #103 from jonatasmv@gmail.com <jonatasmv@gmail.com> 2011-05-17
> 20:14:46 PDT ---
> How do the drivers for Windows to run? How do they get around this problem
> in
> ssc?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 105 Michel Filipe 2011-05-18 07:38:03 UTC
(In reply to comment #104)
> -What is ssc?, please, i found a list of about 80 meanings for ssc!
> -The same exact hardwware works well under Windows (hard to say)
> Thanks
> Julio
> 

Spread Spectrum Clock: http://en.wikipedia.org/wiki/Spread_spectrum

> 
> On Tue, May 17, 2011 at 9:14 PM, <bugzilla-daemon@freedesktop.org> wrote:
> 
> > https://bugs.freedesktop.org/show_bug.cgi?id=28306
> >
> > --- Comment #103 from jonatasmv@gmail.com <jonatasmv@gmail.com> 2011-05-17
> > 20:14:46 PDT ---
> > How do the drivers for Windows to run? How do they get around this problem
> > in
> > ssc?
> >
> > --
> > Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> > ------- You are receiving this mail because: -------
> > You are on the CC list for the bug.
> >
Comment 106 jonatasmv@gmail.com 2011-05-23 07:33:59 UTC
Any news? BSD systems have the same problem? Has anyone here ever used FreeBSD or other BSD with this video card?
Comment 107 jonatasmv@gmail.com 2011-05-26 08:03:25 UTC
I'm no expert in Xorg but I would use the drivers on Intel Display VESA standard VGA output and even losing performace? It would be a solution to solve the problem.
Comment 108 julio prada 2011-05-26 08:12:21 UTC
(In reply to comment #107)
> I'm no expert in Xorg but I would use the drivers on Intel Display VESA
> standard VGA output and even losing performace? It would be a solution to solve
> the problem.

Too bad not to get a word from Intel, I would prefer to wait until there is a solution without an important compromise, but for how long? thats the problem.
Comment 109 Seth Forshee 2011-05-31 07:57:14 UTC
Note that I've received feedback from a fair number of users testing the patch posted here:

https://bugs.freedesktop.org/show_bug.cgi?id=36599#c15

(That bug is marked as a duplicate of this one). The patch fixes the wavy output problem. Most have reported that one or both displays is all black after hotplugging a monitor however.
Comment 110 Anton N Sorensen 2011-06-01 01:31:23 UTC
(In reply to comment #109)
> Note that I've received feedback from a fair number of users testing the patch
> posted here:
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=36599#c15
> 
> (That bug is marked as a duplicate of this one). The patch fixes the wavy
> output problem. Most have reported that one or both displays is all black after
> hotplugging a monitor however.

Thanks for the effort, Seth.
I tried your build on my Dell Vostro 3300.
When hot-plugging an external monitor, both displays went black. I was able to get to a console by typing ctrl-alt-f1, but after ctrl-alt-f7, I could not even get back to a console.
When booting with both monitors in, the external monitor could display without any waviness (thumbs up!), but the ubuntu gui interface was not useable, as no icons appeared and even right-clicking the background showed no menu.
So this is a step in the right direction, but we are not quite there yet.

<rant>
So, back to feeling like a fool, cheated into buying a Vostro 3300 as it was claimed to be working fine with Ubuntu. :-(
</rant>
Comment 111 jonatasmv@gmail.com 2011-06-01 11:06:57 UTC
And which kernel was used? And what is the step-by-step instructions to install the patch? I think if we can keep the post active and get the solution to all owners of notebooks with this problem happy to work with Linux and its preferred dist.
Comment 112 Seth Forshee 2011-06-01 11:19:45 UTC
(In reply to comment #111)
> And which kernel was used? And what is the step-by-step instructions to install
> the patch? I think if we can keep the post active and get the solution to all
> owners of notebooks with this problem happy to work with Linux and its
> preferred dist.

The build I made was 2.6.39-rc7 plus the patch from bug 36599. I posted the packages for ubuntu at:

http://people.canonical.com/~sforshee/lp614238/linux-2.6.39-020639rc7.201105192014~lp614238/
Comment 113 Jesse Barnes 2011-06-08 11:09:29 UTC
It sounds like the original bug reported here is fixed.  That combined with the fact that this bug has gotten out of hand with several unrelated issues being reported prompts me to close it.  If you still see black screens during hot plug or other issues (even waviness, since it's likely a different cause), please open a new bug.
Comment 114 Gustavo Padovan 2011-06-08 11:31:45 UTC
(In reply to comment #113)
> It sounds like the original bug reported here is fixed.  That combined with the
> fact that this bug has gotten out of hand with several unrelated issues being
> reported prompts me to close it.  If you still see black screens during hot
> plug or other issues (even waviness, since it's likely a different cause),
> please open a new bug.

Jesse, in which tree is the patch that fix this issue? I can't find it anywhere.

Chris pushed it to mainline, but also reverted it dues to issue in SSC:

fc9a222 Revert "drm/i915: Disable SSC for outputs other than LVDS or DP"

So, there is no fix in mainline neither Keith's tree. That tells me the bug is still around and needs proper fix in maintainer's tree before set this bug as fixed in bugzilla.
Comment 115 julio prada 2011-06-08 12:46:25 UTC
(In reply to comment #114)
> (In reply to comment #113)
> > It sounds like the original bug reported here is fixed.  That combined with the
> > fact that this bug has gotten out of hand with several unrelated issues being
> > reported prompts me to close it.  If you still see black screens during hot
> > plug or other issues (even waviness, since it's likely a different cause),
> > please open a new bug.
> 
> Jesse, in which tree is the patch that fix this issue? I can't find it
> anywhere.
> 
> Chris pushed it to mainline, but also reverted it dues to issue in SSC:
> 
> fc9a222 Revert "drm/i915: Disable SSC for outputs other than LVDS or DP"
> 
> So, there is no fix in mainline neither Keith's tree. That tells me the bug is
> still around and needs proper fix in maintainer's tree before set this bug as
> fixed in bugzilla.

This is not the first time someone tries to close this bug without a solution, what is going on?
Comment 116 Seth Forshee 2011-06-10 07:12:03 UTC
Jesse, Chris, as noted in comment 114 the fix for this issue was reverted, and I can't see that any other fix has been supplied, so I'm reopening the bug. If another fix is available, could you please point out the tree/sha1 for that commit? At least one user who tested a 3.0-rc kernel is still seeing the issue. Thanks!
Comment 117 jonatasmv@gmail.com 2011-06-17 18:58:22 UTC
Anyone tried the new kernel 3.0 rc? Is there a patch applied to it for this our problem?
Comment 118 Michel Filipe 2011-06-24 09:30:12 UTC
This bug report was opened in middle of 2010 (2010-05-28) and actually we have only one patch posted in 2011-01-12 by Chris Wilson. I believe this is a CRITICAL bug, because two monitors is a very old feature that in 2011 we still can't use.

We have an Intel employee with knowledge (Chris Wilson) for fix this problem but Intel Open Source Center doesn't consider this bug important. This is a LACK OF RESPECT! This feature is basic and old in computer technology and who could help us send a fuck off. So, we bug has +1 year old without solution. 

I propose to send emails to intel-gfx@lists.freedesktop.org[1] requesting more respect and max priority to solve this. If someone know, post the email of IOSC manager to send messages requesting explains about this.

Sorry for this message in bugzilla but wait +1 year for a solution to a basic problem without protest is only for people with cockroach blood.

[1] http://lists.freedesktop.org/mailman/listinfo/intel-gfx
Comment 119 julio prada 2011-06-24 10:11:12 UTC
(In reply to comment #118)

I agree with you, but I dont know if Intel has any obligation here, they just dont care for us, even if we buy their products.
Somehow the "victims" of this Intel bud did not organize ourselves, I proposed to pay somebody to fix it but got not a single reply.
I already bought another laptop because the problem was critical.
Comment 120 info 2011-06-24 10:39:54 UTC
thumbs up!
Comment 121 Tomasz C. 2011-06-26 12:50:12 UTC
I sending to mailto:intel-gfx@lists.freedesktop.org this e-mail:

"I am writing on the bug:

https://bugs.freedesktop.org/show_bug.cgi?id=28306

 I am disappointed that this bug is not fixed for over a year.
 Delegated by Intel person (Chris Wilson) to repair this bug seems to
 ignore the person who reported confusion and people like me who bought
 a laptop at the Intel components because it has support for Linux. And
 even tried to close the report without repair this bug.
 Therefore I ask here is to repair this error was delegated by another person.
 The problem is possible to solve, because the Intel drivers for
 Windows, to display on the external screen is working properly.
 Maybe it is not an easy task, but it's not a reason to ignore society
 and try to close the case without a solution.

 Tomasz C."
Comment 122 Seth Forshee 2011-06-28 09:01:10 UTC
Jesse: Sorry, I missed the comment about opening a new bug if the issue persists. I'm re-closing this one and will open a new bug for the issue that was fixed by the SSC patch that had to be reverted.
Comment 123 julio prada 2011-06-28 11:23:47 UTC
(In reply to comment #122)
> Jesse: Sorry, I missed the comment about opening a new bug if the issue
> persists. I'm re-closing this one and will open a new bug for the issue that
> was fixed by the SSC patch that had to be reverted.

I think this bug should not be closed until the new is open
Comment 124 Maxime C 2011-06-28 14:39:39 UTC
(In reply to comment #123)
> (In reply to comment #122)
> > Jesse: Sorry, I missed the comment about opening a new bug if the issue
> > persists. I'm re-closing this one and will open a new bug for the issue that
> > was fixed by the SSC patch that had to be reverted.
> 
> I think this bug should not be closed until the new is open

Seth created this one: https://bugs.freedesktop.org/show_bug.cgi?id=38750