Bug 36599 - [i915 VGA] VGA output blurred
Summary: [i915 VGA] VGA output blurred
Status: RESOLVED DUPLICATE of bug 28306
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 18:52 UTC by Michel Filipe
Modified: 2011-05-31 09:02 UTC (History)
8 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (34.66 KB, text/x-log)
2011-04-25 18:53 UTC, Michel Filipe
no flags Details
xrandr --verbose (7.69 KB, text/plain)
2011-04-25 18:58 UTC, Michel Filipe
no flags Details
intel_reg_dumper output (7.17 KB, text/plain)
2011-04-25 18:59 UTC, Michel Filipe
no flags Details
vbios.dump (64.00 KB, application/octet-stream)
2011-04-25 19:02 UTC, Michel Filipe
no flags Details
Don't enable SSC on the common clock source when shared with a non-SSC output. (1.97 KB, patch)
2011-04-27 01:16 UTC, Chris Wilson
no flags Details | Splinter Review
Don't enable SSC on the common clock source when shared with a non-SSC output. (5.00 KB, patch)
2011-05-14 01:26 UTC, Chris Wilson
no flags Details | Splinter Review
intel_bios.c.rej of kernel-2.6.38 (300 bytes, application/x-reject)
2011-05-16 08:04 UTC, Michel Filipe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Filipe 2011-04-25 18:52:09 UTC
SYSTEM ENVIRONMENT

chipset: Intel Corporation 5 Series/3400 Series Chipset
graphic card: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
system architecture: i686
xf86-video-intel/xserver/mesa/libdrm version: libdrm-2.4.23 xserver-xorg-video-intel-2.14.0 xserver-7.6 mesa-7.10.2
kernel version: 2.6.38-8-generic-pae
Linux distribution: Ubuntu 11.04 beta 2
Machine or mobo model: Lenovo Thinkpad T410s 2901-ATU
Display connector: VGA

REPRODUCE STEPS

1 - I turn on the external lcd monitor;
2 - Plug the VGA cable of external lcd monitor in my graphic card;
3 - I see that image in lcd monitor is blurring;
4 - I cry! :S
Comment 1 Michel Filipe 2011-04-25 18:53:40 UTC
Created attachment 46076 [details]
Xorg.0.log
Comment 2 Michel Filipe 2011-04-25 18:58:19 UTC
Created attachment 46077 [details]
xrandr --verbose
Comment 3 Michel Filipe 2011-04-25 18:59:59 UTC
Created attachment 46078 [details]
intel_reg_dumper output
Comment 4 Michel Filipe 2011-04-25 19:02:45 UTC
Created attachment 46079 [details]
vbios.dump
Comment 5 Michel Filipe 2011-04-26 13:22:42 UTC
A better description about my problem: the image of external monitor shakes!
Comment 6 Chris Wilson 2011-04-27 01:15:12 UTC
This due to that we do not disable SSC when there is more than one output on the shared clock source. (Technically we we have both a SSC-capable output (LVDS, DP) and an non-SSC-capable (VGA)).
Comment 7 Chris Wilson 2011-04-27 01:16:05 UTC
Created attachment 46112 [details] [review]
Don't enable SSC on the common clock source when shared with a non-SSC output.

Try this patch for starters.
Comment 8 Michel Filipe 2011-04-28 06:25:32 UTC
Chris Wilson, I applied this patch in my custom kernel and it doesn't boot. The screen was black and my capslock button was blinking.

Do you have another solution?
Comment 9 Michel Filipe 2011-05-04 07:30:31 UTC
Sorry Chris Wilson, but I a newbie to compile kernel in debian distro. Compiling kernel with ou without patch I get kernel panic. lol

I'm learning how compile kernel with your patch and I will answer you soon.
Comment 10 Javier Jardón 2011-05-04 09:19:00 UTC
*** Bug 28306 has been marked as a duplicate of this bug. ***
Comment 11 Dawid Lorenz 2011-05-04 09:28:05 UTC
(In reply to comment #7)
> Created an attachment (id=46112) [details]
> Don't enable SSC on the common clock source when shared with a non-SSC output.
> 
> Try this patch for starters.

Sorry for being probably complete n00b, but is there a way of testing this patch without compiling the whole kernel?
Comment 12 Michel Filipe 2011-05-04 09:52:48 UTC
I have good news and bad news for you Chris Wilson.

Good news: the patch was applied with success in kernel and it isn't generate kernel panic.

Bad news: the patch doesn't solve the problem. 

Now I know how compile the kernel with kernel-package. :)
Comment 13 Gustavo Padovan 2011-05-04 10:50:42 UTC
(In reply to comment #7)
> Created an attachment (id=46112) [details]
> Don't enable SSC on the common clock source when shared with a non-SSC output.
> 
> Try this patch for starters.

Chris, patch doesn't work for me. Is there any log you want?
Comment 14 Maxime C 2011-05-04 11:18:08 UTC

*** This bug has been marked as a duplicate of bug 28306 ***
Comment 15 Chris Wilson 2011-05-14 01:26:30 UTC
Created attachment 46702 [details] [review]
Don't enable SSC on the common clock source when shared with a non-SSC output.
Comment 16 Michel Filipe 2011-05-16 08:02:57 UTC
(In reply to comment #15)
> Created an attachment (id=46702) [details]
> Don't enable SSC on the common clock source when shared with a non-SSC output.

I can't apply that patch in kernel-2.6.38. I get a hunk failed in drivers/gpu/drm/i915/intel_bios.c.
Comment 17 Michel Filipe 2011-05-16 08:04:32 UTC
Created attachment 46770 [details]
intel_bios.c.rej of kernel-2.6.38
Comment 18 Gustavo Padovan 2011-05-16 08:10:24 UTC
(In reply to comment #17)
> Created an attachment (id=46770) [details]
> intel_bios.c.rej of kernel-2.6.38

It should be applied against kernel 2.6.39.
Comment 19 Seth Forshee 2011-05-23 06:44:27 UTC
I provided a build for Ubuntu with this patch applied on the Launchpad bug (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/614238), and the feedback from testers looks somewhat mixed but generally positive. The wavy output seems to be gone, although most report that one or both displays are black when hotplugging an external monitor. Maybe that's an unrelated issue, I'm not sure.
Comment 20 Seth Forshee 2011-05-23 06:46:38 UTC
Hrm, I guess I should be specific about what patch was applied to the test build. The build was essentially 2.6.39-rc7 plus the patch from comment #15.
Comment 21 Aristide 2011-05-25 09:49:23 UTC
(In reply to comment #15)
> Created an attachment (id=46702) [details]
> Don't enable SSC on the common clock source when shared with a non-SSC output.

I tested this patch on the latest 2.6.39, debian version. The flickering is gone but it still allows to use one monitor at a time. Let me know if there's anything I can do to help.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.