Bug 2845 - i810 unable to detect 1400x1050 mode on a Dell latitude D610
Summary: i810 unable to detect 1400x1050 mode on a Dell latitude D610
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-29 01:55 UTC by Michel MENGIS
Modified: 2005-03-28 09:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg logfile (63.66 KB, text/plain)
2005-03-29 01:55 UTC, Michel MENGIS
no flags Details
xorg config file (3.48 KB, text/plain)
2005-03-29 01:56 UTC, Michel MENGIS
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel MENGIS 2005-03-29 01:55:19 UTC
by using your driver or intel's one (patched using my own patch to enable memory
allocation), I can't get more than 1400x1050 on my latitude D610 (with flat
panel 1400x1050).

By checking the log file I noticed some strange informations. in Xorg logfile
it's written that the V_BIOS has a bad checksum. it's perhaps the reason why the
driver didn't get any 1400x1050 mode.

As u told me by email, I add the correct modeline for my LCD panel (create by
using read-edid) to my config file. But it didn't solve this trouble.

Anyways, i810 driver tells that:
(WW) I810(0): config file hsync range 60-66.3158kHz not within DDC hsync ranges.
(II) I810(0): SEC:5034: Using hsync range of 60.00-66.32 kHz
(II) I810(0): SEC:5034: Using vrefresh value of 60.00 Hz
(II) I810(0): Not using mode "1400x1050" (no mode of this name)
(II) I810(0): Increasing the scanline pitch to allow tiling mode (1280 -> 2048).
(--) I810(0): Virtual size is 1280x1024 (pitch 2048)
(**) I810(0):  Built-in mode "1280x1024"
Comment 1 Michel MENGIS 2005-03-29 01:55:55 UTC
Created attachment 2234 [details]
Xorg logfile
Comment 2 Michel MENGIS 2005-03-29 01:56:36 UTC
Created attachment 2235 [details]
xorg config file
Comment 3 Alan Hourihane 2005-03-29 03:23:57 UTC
I think you must have misunderstood any email I sent.

Your BIOS looks as though it has the classic problem of not supporting the
1400x1050 video mode. 

I'm assigning this bug as a duplicate.

*** This bug has been marked as a duplicate of 643 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.