Bug 28871 - [2.12 regression] Appearance of some controls in Wine is broken
Summary: [2.12 regression] Appearance of some controls in Wine is broken
Status: RESOLVED DUPLICATE of bug 28798
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-01 11:54 UTC by Artem S. Tashkinov
Modified: 2011-03-16 08:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Wine application appearance with Linux Intel drivers 2.12 (37.02 KB, image/png)
2010-07-01 11:54 UTC, Artem S. Tashkinov
no flags Details
xtrace log for slider control (TRACKBAR_CLASS) (61.58 KB, text/plain)
2010-07-05 01:28 UTC, Artem S. Tashkinov
no flags Details
A minimum slider control application (4.86 KB, application/octet-stream)
2010-07-05 01:39 UTC, Artem S. Tashkinov
no flags Details
Proper rendering (problematic areas are highlighted) (8.11 KB, image/png)
2010-07-05 14:07 UTC, Artem S. Tashkinov
no flags Details
uTorrent appearance under Wine (47.73 KB, image/png)
2010-10-30 17:09 UTC, Artem S. Tashkinov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem S. Tashkinov 2010-07-01 11:54:47 UTC
Created attachment 36662 [details]
Wine application appearance with Linux Intel drivers 2.12

Testcase:

1) Install IrfanView and all plugins in Wine
2) Open any image in IrfanView
3) Hit "Save as"
4) Select PNG and in its save options
5) Enable "Use PNGOUT plugin"

The net result is attached.

There's no such problem with earlier intel drivers releases.
Comment 1 Chris Wilson 2010-07-04 09:37:20 UTC
Similar to bug 28798, it would seem to be a regression in the core rendering paths. Though which is not as clear cut as 28798. It looks like the wrong fg pixel is used, which is fairly surprising (but it might just mean the GC is in a mode that requires a fallback).

Artem, could you capture the commands using xtrace?
Comment 2 Artem S. Tashkinov 2010-07-05 01:28:48 UTC
Created attachment 36759 [details]
xtrace log for slider control (TRACKBAR_CLASS)
Comment 3 Artem S. Tashkinov 2010-07-05 01:39:11 UTC
Created attachment 36760 [details]
A minimum slider control application

If your version of wine or your system cannot run this binary you can recompile this application using this command:

$ winegcc slider.c -lcomctl32 -o slider
Comment 4 Chris Wilson 2010-07-05 02:54:14 UTC
Heh, I gave up installing wine when debootstrap complained (and still is) about making a 32bit jail.

From the xtrace, it really does not seem to be doing anything special, I guess the critical section is the XFillPolygon, which will generate spans, with a fairly mundane foreground colour.
Comment 5 Artem S. Tashkinov 2010-07-05 03:13:50 UTC
Your comment is absolutely cryptic to me :)

I hope you'll fix the issue (and probably you'll even make yourself install 32bit chroot for wine - BTW, why cannot you use a package manager? In Debian that will be 'apt-get install wine' OR wine-unstable, in Fedora it will be 'yum install wine' :)
Comment 6 Chris Wilson 2010-07-05 03:31:35 UTC
Done, apparently I had to specify a different mirror. The reason I need the jail is to avoid the complications of mixing multi-arch libraries and my own development trees. Using the package manager would just clobber too much, so building a jail for testing wine seems like the sanest approach.

Anyway, back to the bug... Can you add a snapshot of what you expect the control to look like? As far I can see, it looks normal here on this gm45.
Comment 7 Artem S. Tashkinov 2010-07-05 14:07:40 UTC
Created attachment 36770 [details]
Proper rendering (problematic areas are highlighted)
Comment 8 Artem S. Tashkinov 2010-07-05 14:09:32 UTC
Now compare the first and the last screenshots - I hope you can spot the difference.
Comment 9 Chris Wilson 2010-07-05 14:22:24 UTC
Yes, that's what your slider.exe looks like here. That testcase is 100% reproducible on your machine [i5]?
Comment 10 Artem S. Tashkinov 2010-07-05 14:58:54 UTC
(In reply to comment #9)
> Yes, that's what your slider.exe looks like here. That testcase is 100%
> reproducible on your machine [i5]?

Yep, it is.
Comment 11 Artem S. Tashkinov 2010-09-30 01:01:39 UTC
Chris, what's the status of this submission?
Comment 12 Artem S. Tashkinov 2010-10-30 17:09:48 UTC
Created attachment 39914 [details]
uTorrent appearance under Wine

uTorrent appearance in Wine is even more broken than anything else I've seen.
Comment 13 Artem S. Tashkinov 2011-01-05 00:39:28 UTC
Chris, I bet second generation Intel Core CPUs which were released recently also have this bug.

Will anyone try to solve it?
Comment 14 Chris Wilson 2011-01-05 02:27:35 UTC
It's on my list of bugs to fix.
Comment 15 André Brait 2011-03-15 11:07:05 UTC
(In reply to comment #14)
> It's on my list of bugs to fix.

The bug 30157 https://bugs.freedesktop.org/show_bug.cgi?id=30157 seems to be a duplicate of this one.
Comment 16 Jaime Rave 2011-03-15 17:06:17 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > It's on my list of bugs to fix.
> 
> The bug 30157 https://bugs.freedesktop.org/show_bug.cgi?id=30157 seems to be a
> duplicate of this one.

And this is a duplicate of bug 28798
Comment 17 Artem S. Tashkinov 2011-03-15 17:14:10 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #14)
> > > It's on my list of bugs to fix.
> > 
> > The bug 30157 https://bugs.freedesktop.org/show_bug.cgi?id=30157 seems to be a
> > duplicate of this one.
> 
> And this is a duplicate of bug 28798

And it was bisected almost three months ago ... hm, guess Intel developers don't run Windows applications under wine :)
Comment 18 Artem S. Tashkinov 2011-03-15 17:15:51 UTC

*** This bug has been marked as a duplicate of bug 28798 ***
Comment 19 Toralf Förster 2011-03-16 01:46:31 UTC
(In reply to comment #17)

> And it was bisected almost three months ago ... hm, guess Intel developers
> don't run Windows applications under wine :)
If you mean this : https://bugs.freedesktop.org/show_bug.cgi?id=28798#c6 it i s10 month ago.
Comment 20 Artem S. Tashkinov 2011-03-16 08:23:56 UTC
(In reply to comment #19)
> (In reply to comment #17)
> 
> > And it was bisected almost three months ago ... hm, guess Intel developers
> > don't run Windows applications under wine :)
> If you mean this : https://bugs.freedesktop.org/show_bug.cgi?id=28798#c6 it i
> s10 month ago.

I guess 2010-11-25 wasn't that far ago :) Or you bisected the issue months before letting everyone know? :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.