Bug 30157 - [GM45 wine] Strong lines in some parts of Shareaza and SQLYog
[GM45 wine] Strong lines in some parts of Shareaza and SQLYog
Status: RESOLVED DUPLICATE of bug 28798
Product: xorg
Classification: Unclassified
Component: Driver/intel
git
All All
: medium normal
Assigned To: Chris Wilson
Xorg Project Team
: regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-12 21:38 UTC by Jaime Rave
Modified: 2011-03-15 17:15 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Rave 2010-09-12 21:38:46 UTC
Forwarding this bug from Ubuntu launchpad (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/622068)

I have just upgrade to Ubuntu 10.10 and found that some lines in SQLYog and Shareaza while using Wine looks more intense than they have to be. I have made a regression test in Wine and found that this commit trigger the problem:

c29cf0591976f96c3adb30c3c3b6db59f4983251 is the first bad commit
commit c29cf0591976f96c3adb30c3c3b6db59f4983251
Author: Roderick Colenbrander <thunderbird2k@gmail.com>
Date: Tue Apr 6 19:07:25 2010 +0200

    winex11: Add support for 32-bit DDBs.

:040000 040000 73b8486e86ccd609ea2f0c8cf0c920b6ec3783dd
04bcf74196ee257fa4b8391041c627b89e6cbffe M dlls

I have reported the bug to Wine ( http://bugs.winehq.org/show_bug.cgi?id=23098 ) but after testing on a Radeon HD3450 running FGLRX and with a Radeon HD 4670 and the open source driver (xorg-x11-drv-ati-6.13.0-1.fc13.x86_64 and Mesa 7.8.1) they were unable to reproduce the problem, when I was using Ubuntu 10.04 I didn't have this issue (Only when I installed the xorg-edgers PPA). So my conclusion is that this must be an issue in the Intel driver.

There are screenshots in the Wine bug and some more information.

An easy way to test this bug is type 'winecfg' in the terminal, and the go to the 'Graphics' tab. The slider in the Screen Resolution section appear incorrectly.
Comment 1 Jaime Rave 2010-09-19 12:04:47 UTC
This bug is not just creating wider lines, is also creating black tabs and in some areas of other programs like Ares is just showing black areas.

This is the report about black tabs in Office 2007
http://bugs.winehq.org/show_bug.cgi?id=24430
Comment 2 Peter 2010-11-07 02:53:12 UTC
This is regression in xf86-video-driver. I've managed to bisect part of problem: 

commit 3055d40164590147d35b5e7059ebe5f5858c85fa
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Wed May 26 10:12:57 2010 +0100

    uxa: Use Composite rather than solid blitter for PolyRect

    Due to the relocation overhead, using a single composite with many
    rectangles outperforms many solid blits.

    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>


with this commit reverted winecfg slider is still black, but line it slides on is of normal text. Also reverting this commit fixes my inability to see tabs (they were black) during visio 2007 installation (which is the major regression for me). Actually if using driver at ec2437f958ec4f5ac5222b37cba4cd403b5c8855 wine works fine.
Comment 3 Toralf Förster 2010-11-08 05:01:05 UTC
Maybe bug http://bugs.winehq.org/show_bug.cgi?id=23424 is related to this issue too, however it isn't (any longer) possible to revert commit 3055d40 on current TRUNK of the git tree to test whether that commit breaks something in wine or not.
Comment 4 Tomas Jura 2010-12-08 14:07:08 UTC
Until the moment I read the comment #2, I thought that this bug is related to Xrender extension, but now I'm not sure.

When I set up wine registry by importing this registry file

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideWithRender"="N"

then everything works fine. 

Peter, will you check that this registry workaround eliminates your problem?
Comment 5 Chris Wilson 2010-12-08 14:40:47 UTC
The bug is in the ddx's core rendering routines. The workaround that you've found is for wine to do it's rendering locally and then push the image as a whole to the xserver (hopefully only updating the damage regions!). This may in fact be quicker than hitting the X core rendering paths...
Comment 6 Slavomir Danas 2010-12-09 10:29:06 UTC
I can confirm that the workaround had solved the issue for me and I haven't noticed any slowdown or artifacts in redering. Thank You very much, I quite happy with my desktop roght now. :)
Comment 7 Toralf Förster 2011-01-04 01:33:03 UTC
The wine - people are convinced that this issue is an issue of at least a X.org software piece. Now I'm wondering how I can help to solve this issue - b/c setting the registry key seems to be only a work around - and I rely on a working Lotus Notes at work.


Toralf Förster <toralf.foerster@gmx.de> writes:
> Alexandre Julliard wrote at 23:01:42
>> No, setting that registry value is a bad idea and should be discouraged.
>> It will break all sorts of things, particularly anything to do with
>> alpha blending.
> Oh - thx.
> Then I'm wondering what I can do to solve this issue : 
> http://bugs.winehq.org/show_bug.cgi?id=23424

Not a whole lot I'm afraid, except continue to push the X.org guys to
fix the bug, or revert to an old driver, or get a different graphics
card with working drivers...
Comment 8 Jaime Rave 2011-01-04 06:51:10 UTC
The workaround had solved most of the issue but for MS Office 2007 the problem is even worst when I set the registry key so is not useful in all the cases.
Comment 9 quentin.denis 2011-02-23 07:32:53 UTC
(In reply to comment #8)
> The workaround had solved most of the issue but for MS Office 2007 the problem
> is even worst when I set the registry key so is not useful in all the cases.

I can confirm worse results with Office:
http://img543.imageshack.us/i/screenshot21s.png/
Comment 10 Md Imam Hossain 2011-03-09 00:43:42 UTC
this bug affects Linux vector graphics program Inkscape.
the rulers are overwritten by black mouse pointers.

For Wine "ClientSideWithRender"="N" regkey tells Wine to not use XRender extension for font rendering, which partially solves wine issues but not Linux issues.
Comment 11 André Brait 2011-03-09 18:59:29 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > The workaround had solved most of the issue but for MS Office 2007 the problem
> > is even worst when I set the registry key so is not useful in all the cases.
> 
> I can confirm worse results with Office:
> http://img543.imageshack.us/i/screenshot21s.png/

I confirm worse results with Office 2007 too. 
It seems to happen with any Intel driver newer than 2.11.
Tested on a Core i3's integrated graphics.

I'm unable to reproduce the problem in both a VirtualBox VM running Arch Linux and my PC with an ATI HD5770.
Comment 12 Jaime Rave 2011-03-11 21:50:02 UTC
I'ts affecting also Metatrader 4. You can see the issue when using a color scheme Yellow over black or when inserting a Parabolic sar indicator that should hava lime color but appear black.

http://www.metatrader4.com/
Comment 13 Artem S. Tashkinov 2011-03-15 13:39:43 UTC
Actually this bug is a duplicate of bug 28871 which was filed two months earlier.
Comment 14 André Brait 2011-03-15 16:58:50 UTC
(In reply to comment #13)
> Actually this bug is a duplicate of bug 28871 which was filed two months
> earlier.

Yes, as I pointed in a comment in bug 28871 .

It's the same bug. 

Important to notice it affects other Linux apps other than Wine.
Comment 15 Artem S. Tashkinov 2011-03-15 17:15:36 UTC

*** This bug has been marked as a duplicate of bug 28798 ***