Bug 2976 - white screen with a Trident cyber 9397DVD card
Summary: white screen with a Trident cyber 9397DVD card
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Trident (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 2457 (view as bug list)
Depends on:
Blocks: 3557
  Show dependency treegraph
 
Reported: 2005-04-11 10:38 UTC by Fabrice Bellet
Modified: 2005-11-29 07:52 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabrice Bellet 2005-04-11 10:38:22 UTC
I observe the same problem on an old thinkpad 770Z with a trident cyber 9397dvd
video card, than the one described here:
 
https://www.redhat.com/archives/fedora-test-list/2005-March/msg00248.html

When gdm starts, the screen becomes completely white, and only the hw cursor
remains reactive. The laptop still runs fine, and is reacheable with ssh. When
switching back to a VT, the console is also completely garbled (vesafb is in
use), but it still works. I suspect a problem with the trident driver.

I use the Fedora development packages (xorg-x11-6.8.2-20 currently)
Comment 2 Wei-Lun Chao 2005-05-11 19:52:02 UTC
*** Bug 2457 has been marked as a duplicate of this bug. ***
Comment 3 Fabrice Bellet 2005-05-20 08:57:39 UTC
Here is a possible workaround that I found :
 . switch the LCD off (Fn-F3) (APM is in use, the laptop is too old for ACPI)
 . switch it on again, and the screen is okay again.

The problem can be reproducted easily :
 . switch to a VT (then the VGA screen out is garbled again : it only displays
white vertical strips)
 . switch back to X (then the white screen is back)
 . and previous workaround still works.

HTH
Comment 4 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-18 20:02:31 UTC
Same here. FC4 install, Trident 3DImage975 (Blade 3D (generic)). The X server
doesn't hang, just a blank screen. Nothing interesting in the logs.

Here is a little experiment I did:
1. Logged in as root from the text console;
2. Typed 'X&', the xserver loaded with a *white* background (not that
micro-checked pattern) with the 'X' cursor in the middle of the screen;
3. Went back to the console with Ctrl-Alt-F1 and typed 'DISPLAY=:0.0 xterm&';
4. Back to X, nothing new, same white background with the X cursor, *but*, when
I moved the cursor to the region of the screen where the xterm should have been
shown (the top-left quarter), the cursor disappeared, indicating that some kind
of window was there (and for some strange reason, the invisible window makes the
pointer disappear when it is over). Moving the cursor out of that region makes
it appear again. While the cursor is over that window, I can type commands and
even close the xterm window (^D).
Comment 5 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-18 20:06:21 UTC
Created attachment 2919 [details] [review]
patch to make monodoc stuff install to $prefix
Comment 6 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-18 20:06:48 UTC
Created attachment 2920 [details] [review]
mozilla patch
Comment 7 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-20 01:10:51 UTC
I met same problem during FC4 install. Mine is a Trident Cyber9525DVD PCI/AGP
card. A workaround is to tweak /etc/X11/xorg.conf, replace driver from "trident"
to "vesa"
Comment 8 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-21 10:22:23 UTC
(In reply to comment #7)
> I met same problem during FC4 install. Mine is a Trident Cyber9525DVD PCI/AGP
> card. A workaround is to tweak /etc/X11/xorg.conf, replace driver from "trident"
> to "vesa"
> 

This is not a good workaround because (at least) Totem doesn't work in FC4,
please see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=157488
Comment 9 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-23 07:25:39 UTC
> This is not a good workaround because (at least) Totem doesn't work in FC4,
> please see
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=157488

This is the only workaround I've found. Otherwise I can only use console. 
For movie viewer, I prefer mplayer and it works fine with vesa driver in my fc4
box. The only issue is hindered full screen display.
Comment 10 Mike A. Harris 2005-06-23 11:00:16 UTC
Try replacing the X server module "libvgahw.a" with the one I've provided
at the following URL:

ftp://people.redhat.com/mharris/libvgahw.a

Anyone experiencing this problem, who tries this test with good results,
should CC themselves on Red Hat bug:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

I've added this fd.o bug to our tracker, and will update this one if we
can conclude it is the same problem.

Thanks.
Comment 11 Jim Cornette 2005-06-23 16:48:27 UTC
I suggested that someone replace the  libvgahw file as MGA users, Intel users
found worked to workaround the FC4 version of the file. Bug 3557 was filed to
track same cure, different problem types of bugs.

The white screen was resolved by replacing the same library.
Comment 12 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-23 19:03:54 UTC
Replacing libvgahw.a with ftp://people.redhat.com/mharris/libvgahw.a in fc4
solves the blank white screen problem for my Trident Cyber9525DVD PCI/AGP card. 
Comment 13 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 05:30:37 UTC
Replacing libvgahw.a with ftp://people.redhat.com/mharris/libvgahw.a on
FC4/Trident CyberBladeXP solves white screen problem.
Comment 14 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 10:43:33 UTC
The fixed libvgahw.a from ftp://people.redhat.com/mharris/libvgahw.a worked for
me on a Toshiba Satellite 1800 using a Trident CyberBlade XPAi1, with a fresh
installation of Fedora FC4 (and a separate install of FC3!!). The white screen
has gone away.

R.
Comment 15 Stephen Clark 2005-07-23 00:48:23 UTC
I just replaced my libvgahw.a file with the one from mharris and it fixed the
problems I was having with fc4 on a HP Pavilion n5430 laptop with a cyberbladexp.
With the old libvgahw.a it would totally hose my screen even after I had exited X.
Comment 16 Luc Verhaegen 2005-08-03 08:17:10 UTC
*** Bug 3958 has been marked as a duplicate of this bug. ***
Comment 17 Alan Hourihane 2005-11-30 02:52:54 UTC
Closing. gcc4 bug caused miscompilation.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.