Bug 30011 - [r300g] several wine games crash with gallium
[r300g] several wine games crash with gallium
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-04 04:05 UTC by Rubén Fernández
Modified: 2010-10-30 12:30 UTC (History)
1 user (show)

See Also:


Attachments
Log generated with WINEDEBUG=warn (18.25 KB, text/plain)
2010-09-04 04:05 UTC, Rubén Fernández
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rubén Fernández 2010-09-04 04:05:04 UTC
some wine games (specifically, Tales of Monkey Island and Spore) run with mesa classic r300 (and ToMI, at least, renders correctly), yet they crash when run with the gallium driver.

Right after changing video mode, a popup appears with the message:

"The program SporeApp.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience. This can be caused by a problem in the program or a deficiency in Wine. You may want to check http://appdb.winehq.org for tips about running this application. If this problem is not present under Windows and has not been reported yet, you can report it at http://bugs.winehq.org."

and then exits.

I'll attach the log produced by wine; the most helpful line seems to be this:

0x7ceebdcb st_context_notify_invalid_framebuffer+0x2b [/home/cable/archivos/programas/sistema/X/extras/mesa/git/new/mesa/src/mesa/state_tracker/st_manager.c:494] in r300_dri.so: movl	$0x1,0x384(%eax)
Comment 1 Rubén Fernández 2010-09-04 04:05:34 UTC
Created attachment 38429 [details]
Log generated with WINEDEBUG=warn
Comment 2 Rubén Fernández 2010-09-04 04:07:04 UTC
By the way, my machine specs are:

Graphics Card: ATI Technologies Inc RV505 [Radeon X1550 64-bit]
CPU: Intel Core Duo 1.8 Ghz, 2.5 GB RAM
Linux kernel 2.6.35.2, libdrm 2.4.21
Comment 3 Sven Arvidsson 2010-09-04 05:15:32 UTC
This is probably the same as bug 29244.
Comment 4 Tom Stellard 2010-10-28 00:47:26 UTC
Is this still an issue in Mesa 7.9 or the latest version from git?
Comment 5 Rubén Fernández 2010-10-28 11:02:32 UTC
(In reply to comment #4)
> Is this still an issue in Mesa 7.9 or the latest version from git?

In 7.9, yes; but, I just checked the latest git, and the issue seems solved there.
All the failing applications now run (or fail for entirely different reasons)
Comment 6 Marek Olšák 2010-10-28 11:32:07 UTC
Could you please bisect what fixed it so that we can commit the fix to 7.9 as well?
Comment 7 Rubén Fernández 2010-10-30 12:30:17 UTC
(In reply to comment #6)
> Could you please bisect what fixed it so that we can commit the fix to 7.9 as
> well?

Yes, sure; it was this commit that did the trick:

http://cgit.freedesktop.org/mesa/mesa/commit/?id=3d6eec0a87ee5549e817cdabb4b6424960678189

made just one day the 7.9 release! what luch.

It says it's already a candidate for 7.9, though