Bug 30150 - SofiaSIP consumes maximum upload and download bandwidth
Summary: SofiaSIP consumes maximum upload and download bandwidth
Status: RESOLVED FIXED
Alias: None
Product: Telepathy
Classification: Unclassified
Component: rakia (show other bugs)
Version: 0.10
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Mikhail Zabaluev
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2010-09-12 15:06 UTC by Philip Withnall
Modified: 2012-06-06 07:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Withnall 2010-09-12 15:06:43 UTC
I've caught SofiaSIP consuming maximum upload and download bandwidth a couple of times now, both when I've come home for the weekend. I suspect it may be caused by hibernating my laptop (with my SofiaSIP account enabled) on one network, then resuming it on another, since it's only happened when I've come home for the weekend (doing just that). However, it might also be caused by the network setup I have at home. Restarting my laptop or the SIP CM stops it using all the bandwidth, and once I've done this I can't reproduce the problem again.

This is with:
 • telepathy-glib-0.10.7
 • telepathy-sofiasip-0.6.3
 • sofia-sip-1.12.10

An excerpt of the SofiaSIP debug log from Empathy follows. These messages are repeated every five seconds:

tpsip/events-DEBUG: 12/09/10 22:50:06.526789: tpsip_connection_sofia_callback: event nua_r_register: 200 OK
tpsip/events-DEBUG: 12/09/10 22:50:06.531056: tpsip_connection_sofia_callback: connection 0x9ba1be8, refcount 1
tpsip/events-DEBUG: 12/09/10 22:50:06.531701: tpsip_connection_sofia_callback: dispatching to target 0x9ba1be8 (handle 0x9bb8b90)
tpsip/events-DEBUG: 12/09/10 22:50:06.532118: tpsip_connection_sofia_callback: exit
tpsip/events-DEBUG: 12/09/10 22:50:06.672424: tpsip_connection_sofia_callback: event nua_i_outbound: 102 NAT binding changed
tpsip/events-DEBUG: 12/09/10 22:50:06.673342: tpsip_connection_sofia_callback: connection 0x9ba1be8, refcount 1
tpsip/events-DEBUG: 12/09/10 22:50:06.675302: tpsip_connection_sofia_callback: dispatching to target 0x9ba1be8 (handle 0x9bb8b90)
tpsip/events-DEBUG: 12/09/10 22:50:06.675771: tpsip_connection_sofia_callback: event nua_i_outbound for target 0x9ba1be8 was not consumed
tpsip/events-DEBUG: 12/09/10 22:50:06.676175: tpsip_connection_sofia_callback: exit
tpsip/events-DEBUG: 12/09/10 22:50:11.551542: tpsip_connection_sofia_callback: event nua_i_outbound: 102 NAT binding changed
tpsip/events-DEBUG: 12/09/10 22:50:11.555440: tpsip_connection_sofia_callback: connection 0x9ba1be8, refcount 1
tpsip/events-DEBUG: 12/09/10 22:50:11.556128: tpsip_connection_sofia_callback: dispatching to target 0x9ba1be8 (handle 0x9bb8b90)
tpsip/events-DEBUG: 12/09/10 22:50:11.559312: tpsip_connection_sofia_callback: event nua_i_outbound for target 0x9ba1be8 was not consumed
tpsip/events-DEBUG: 12/09/10 22:50:11.559797: tpsip_connection_sofia_callback: exit
tpsip/events-DEBUG: 12/09/10 22:50:11.560206: tpsip_connection_sofia_callback: event nua_r_register: 100 Outbound NAT Detected
tpsip/events-DEBUG: 12/09/10 22:50:11.560606: tpsip_connection_sofia_callback: connection 0x9ba1be8, refcount 1
tpsip/events-DEBUG: 12/09/10 22:50:11.560991: tpsip_connection_sofia_callback: dispatching to target 0x9ba1be8 (handle 0x9bb8b90)
tpsip/events-DEBUG: 12/09/10 22:50:11.561388: tpsip_connection_sofia_callback: exit
Comment 1 Mikhail Zabaluev 2010-09-13 05:31:31 UTC
This is bad. I'd like to look at the packet traffic to understand what causes the looping behavior. Can you capture the SIP packets? Or, you can define TPORT_LOG=1 in either the session environment, or export it in the user shell and launch telepathy-sofiasip from the same, e.g.:
TPSIP_PERSIST=1 /usr/lib/telepathy/telepathy-sofiasip

The "sofiasip" debug category in the Empathy log window will get dumps of SIP messages when ran this way.

As a workaround, try to disable NAT binding detection in SIP parameters. You may want to switch to the TCP transport to maintain a connection to the proxy with less NAT worries.
Comment 2 Philip Withnall 2010-09-13 05:40:51 UTC
(In reply to comment #1)
> This is bad. I'd like to look at the packet traffic to understand what causes
> the looping behavior. Can you capture the SIP packets? Or, you can define
> TPORT_LOG=1 in either the session environment, or export it in the user shell
> and launch telepathy-sofiasip from the same, e.g.:
> TPSIP_PERSIST=1 /usr/lib/telepathy/telepathy-sofiasip
> 
> The "sofiasip" debug category in the Empathy log window will get dumps of SIP
> messages when ran this way.

Would a Wireshark log be OK, or do you want both? I can't reproduce the problem now until I next change networks and come back to this one (that's the only way I've found which will trigger it), so if there's any more debugging information you would possibly need, please let me know now and I'll see if I can capture it when I next manage to trigger the problem.
Comment 3 Mikhail Zabaluev 2010-09-13 05:46:24 UTC
(In reply to comment #2)
> Would a Wireshark log be OK, or do you want both?

A Wireshark capture is fine. You can mail it to me if you don't want exposing your IP addresses, user names and similar details.
Comment 4 Mikhail Zabaluev 2010-12-27 09:30:42 UTC
I apologize if any mail with traffic captures was sent to me, but I can't retrace it in my email backlog.

This might be caused by bug #32615.
Comment 5 Philip Withnall 2010-12-28 03:20:05 UTC
I haven't been able to reproduce this again yet (I've only been able to when moving my laptop from university to home, and that doesn't happen very often). I'll send you a Wireshark log and comment on here when I can.
Comment 6 Mikhail Zabaluev 2011-01-04 04:41:01 UTC
FYI: I have a fix to the sofia-sip library which may solve your problem:
http://gitorious.org/~mzabaluev/sofia-sip/mzabaluev-sofia-sip/commits/fix-ob-contacts
Comment 7 Mikhail Zabaluev 2011-01-31 07:22:26 UTC
A fix for a possible cause has been integrated into sofia-sip master branch.
Comment 8 Jean-François Fortin Tam 2012-06-06 07:17:54 UTC
This has been supposedly fixed a long time ago. If it still occurs, feel free to reopen this bug report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.