Bug 30754 - X server crashes with SEGFAULT when using virtualbox on Evergreen
Summary: X server crashes with SEGFAULT when using virtualbox on Evergreen
Status: RESOLVED DUPLICATE of bug 32188
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 31299 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-10 09:05 UTC by Maggioni Marcello
Modified: 2011-01-06 19:21 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
X backtrace (8.24 KB, text/plain)
2010-11-23 21:44 UTC, Frédéric L. W. Meunier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maggioni Marcello 2010-10-10 09:05:14 UTC
Using virtualbox PUEL with latest evergreen drivers causes crashes when switching to fullscreen.

Virtualbox OSE instead is able to switch to fullscreen without crashing, but the system is subject to occasional X crashes after sometime while virtualbox is running (never experienced these with virtualbox not running)
Comment 1 Alex Deucher 2010-10-11 09:55:48 UTC
Can you attach a backtrace from the crash and your xorg log and dmesg output?  For info about getting a good backtrace:
http://wiki.x.org/wiki/Development/Documentation/ServerDebugging
Comment 2 Alex Deucher 2010-11-01 11:01:28 UTC
*** Bug 31299 has been marked as a duplicate of this bug. ***
Comment 3 Frédéric L. W. Meunier 2010-11-23 21:43:50 UTC
I also get random crashes with Bluefish, an editor.

Is this a new issue or the same ? I'm attaching the backtrace.

You can compare with the one I added at https://bugs.freedesktop.org/show_bug.cgi?id=31299

This time, I'm using xorg-server 1.9.2, Mesa 7.9 git (20101122) and xf86-video-ati 6.13.99 git (20101119).
Comment 4 Frédéric L. W. Meunier 2010-11-23 21:44:52 UTC
Created attachment 40526 [details]
X backtrace
Comment 5 Frédéric L. W. Meunier 2011-01-06 18:32:52 UTC
After reading some things, I thought that it could be an issue in the kernel, but moving from 2.6.36 to 2.6.37 didn't improve things. And this time, I was able to reproduce it in VirtualBox 4.0 without starting the VM, just going to the settings and changing something.

Anyway, this time I used xorg-server 1.9.3 git (20101231), Mesa 7.9 git (20110105) and xf86-video-ati 6.13.99 git (20101217).
Comment 6 Alex Deucher 2011-01-06 19:21:11 UTC

*** This bug has been marked as a duplicate of bug 32188 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.