Bug 31138 - [r200] gltron fails with "drmRadeonCmdBuffer: -22 ..."
Summary: [r200] gltron fails with "drmRadeonCmdBuffer: -22 ..."
Status: RESOLVED DUPLICATE of bug 25544
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-26 09:57 UTC by Daniel Richard G.
Modified: 2010-10-26 12:03 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
RADEON_DEBUG=all gltron >gltron-radeon-debug.txt 2>&1 (63.52 KB, text/plain)
2010-10-26 09:57 UTC, Daniel Richard G.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Richard G. 2010-10-26 09:57:27 UTC
Created attachment 39790 [details]
RADEON_DEBUG=all gltron >gltron-radeon-debug.txt 2>&1

I have an ATI FireGL 8800 that has worked beautifully in the past, and am running an up-to-date Ubuntu Maverick (on amd64) with the following bleeding-edge elements:

* Ubuntu's 2.6.36 mainline kernel package; details at http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-maverick/

* Mesa packages from git 20101023 (master branch); details at https://launchpad.net/~xorg-edgers/+archive/radeon/+packages?field.status_filter=published&field.series_filter=maverick

* xserver-xorg-video-ati packages from git 20101020 (master branch); details at same URL


When I start up gltron (a small OpenGL TRON-lightcycle game), I see this on the terminal:

$ gltron
[error] cannot load .gltronrc from /home/guest/.gltronrc
[warning] old config file found, overriding using defaults
[warning] defunct config file found, overriding using defaults
[status] loading artpack 'default'
using min_filter: 9987 (setting: 3)
[scripting audio] found track '	song_revenge_of_cats.it	'
[sound] initializing sound
[sound] loading song song_revenge_of_cats.it
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

The dmesg output shows this:

Oct 25 21:02:56 maxtor kernel: [ 1354.406015] [drm:r100_cs_track_texture_check] *ERROR* No texture bound to unit 1
Oct 25 21:02:56 maxtor kernel: [ 1354.406022] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

I'm attaching RADEON_DEBUG=all output for this, as it's pretty small. (Note that the above terminal output is intermingled.)

This bug has persisted since at least Ubuntu Lucid, and does not appear to have been fixed by other resolutions for the "drmRadeonCmdBuffer: -22" error. (I am, to put it lightly, frustrated that the stability of the r200 driver has regressed from where it was ~2 years ago.)
Comment 1 Alan Swanson 2010-10-26 12:03:21 UTC

*** This bug has been marked as a duplicate of bug 25544 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.