Bug 31708 - [RADEON:KMS:TTM] kernel oops when loading large images with firefox
Summary: [RADEON:KMS:TTM] kernel oops when loading large images with firefox
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 03:07 UTC by Manuel Lauss
Modified: 2012-09-15 15:18 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Forbid big bo allcoation (5.40 KB, patch)
2010-11-18 10:51 UTC, Jerome Glisse
no flags Details | Splinter Review
Forid big bo allocation (3.15 KB, patch)
2010-11-19 12:56 UTC, Jerome Glisse
no flags Details | Splinter Review
Forbid big bo allcoation (3.10 KB, patch)
2010-11-22 09:23 UTC, Jerome Glisse
no flags Details | Splinter Review
Forbid big bo allcoation (2.06 KB, patch)
2010-11-22 09:24 UTC, Jerome Glisse
no flags Details | Splinter Review
kern.log NULL pointer dereference bug (4.30 KB, text/plain)
2012-09-14 15:42 UTC, Reiner
no flags Details
kern.log unable to handle kernel paging request bug (8.80 KB, text/plain)
2012-09-14 15:48 UTC, Reiner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Lauss 2010-11-18 03:07:16 UTC
The following kernel oops happens whenever a very large image is loaded in firefox:
(RV350, 855PM AGP):

------------[ cut here ]------------
kernel BUG at /usr/src/linux-2.6.git/drivers/gpu/drm/ttm/ttm_bo.c:1123!
invalid opcode: 0000 [#1] PREEMPT
last sysfs file: /sys/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:10/PNP0C09:00/PNP0C0A:00/power_supply/BAT1/energy_full
Modules linked in: ipw2200 libipw

Pid: 5117, comm: X Not tainted 2.6.37-rc2 #1 /VGN-A197XP(DE)
EIP: 0060:[<b143104a>] EFLAGS: 00013202 CPU: 0
EIP is at ttm_bo_check_placement+0x1a/0x20
EAX: d8ae262c EBX: ee97a40c ECX: 00000000 EDX: 00004000
ESI: 00000000 EDI: 04258000 EBP: b1466370 ESP: df8f3d74
DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 0068
Process X (pid: 5117, ti=df8f2000 task=ed535000 task.ti=df8f2000)
Stack:
b143379d 00000000 cd4b19c8 018f3da8 d8ae262c d8ae2600 ee97a000 00000000
cd4ab6c0 b14662a0 00000000 d8ae2614 00000000 00000000 00000001 00000000
04258000 b1466370 00000000 04258000 ee97b648 ee97a40c 00000001 cd4ab6c0
Call Trace:
[<b143379d>] ? ttm_bo_init+0x16d/0x350
[<b14662a0>] ? radeon_bo_create+0xe0/0x1b0
[<b1466370>] ? radeon_ttm_bo_destroy+0x0/0x90
[<b147a618>] ? radeon_gem_object_create+0x78/0x100
[<b147a702>] ? radeon_gem_create_ioctl+0x62/0xd0
[<b141eefe>] ? drm_ioctl+0x19e/0x440
[<b147a6a0>] ? radeon_gem_create_ioctl+0x0/0xd0
[<b1090165>] ? do_sync_read+0xa5/0xe0
[<b1047f69>] ? ktime_get+0x59/0x100
[<b141ed60>] ? drm_ioctl+0x0/0x440
[<b109e47c>] ? do_vfs_ioctl+0x9c/0x700
[<b102d55c>] ? irq_exit+0x2c/0x70
[<b109eb1d>] ? sys_ioctl+0x3d/0x70
[<b1002d50>] ? sysenter_do_call+0x12/0x26
Code: 0f 0b eb fe 8d b6 00 00 00 00 8d bc 27 00 00 00 00 8b 0a 85 c9 75 0a 8b 52 04 85 d2 75 06 31 c0 c3 8b 52 04 29 ca 39 50 40 76 f3 <0f> 0b eb ff
EIP: [<b143104a>] ttm_bo_check_placement+0x1a/0x20 SS:ESP 0068:df8f3d74
---[ end trace a8625bcdd779303f ]---


Linux agpgart interface v0.103
agpgart-intel 0000:00:00.0: Intel 855PM Chipset
agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xe0000000
[drm] Initialized drm 1.1.0 20060810
[drm] radeon defaulting to kernel modesetting.
[drm] radeon kernel modesetting enabled.
ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 9
radeon 0000:01:00.0: PCI INT A -> Link[LNKE] -> GSI 9 (level, low) -> IRQ 9
[drm] initializing kernel modesetting (RV350 0x1002:0x4E50).
[drm] register mmio base: 0xFF5F0000
[drm] register mmio size: 65536
agpgart-intel 0000:00:00.0: AGP 2.0 bridge
agpgart-intel 0000:00:00.0: putting AGP V2 device into 4x mode
radeon 0000:01:00.0: putting AGP V2 device into 4x mode
radeon 0000:01:00.0: GTT: 256M 0xE0000000 - 0xEFFFFFFF
[drm] Generation 2 PCI interface, using max accessible memory
radeon 0000:01:00.0: VRAM: 128M 0xD0000000 - 0xD7FFFFFF (64M used)
[drm] radeon: irq initialized.
[drm] Detected VRAM RAM=128M, BAR=128M
[drm] RAM width 128bits DDR
[TTM] Zone  kernel: Available graphics memory: 513282 kiB.
[TTM] Initializing pool allocator.
[drm] radeon: 64M of VRAM memory ready
[drm] radeon: 256M of GTT memory ready.
[drm] radeon: 1 quad pipes, 1 Z pipes initialized.
radeon 0000:01:00.0: WB disabled
[drm] Loading R300 Microcode
[drm] radeon: ring at 0x00000000E0001000
[drm] ring test succeeded in 1 usecs
[drm] radeon: ib pool ready.
[drm] ib test succeeded in 0 usecs
[drm] Panel ID String: 1920X1200 WUXGA         
[drm] Panel Size 1920x1200
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm]   VGA
[drm]   DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[drm]   Encoders:
[drm]     CRT1: INTERNAL_DAC1
[drm] Connector 1:
[drm]   DVI-D
[drm]   HPD1
[drm]   DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
[drm]   Encoders:
[drm]     DFP1: INTERNAL_TMDS1
[drm] Connector 2:
[drm]   LVDS
[drm]   Encoders:
[drm]     LCD1: INTERNAL_LVDS
[drm] Connector 3:
[drm]   S-video
[drm]   Encoders:
[drm]     TV1: INTERNAL_DAC2
[drm] fb mappable at 0xD0040000
[drm] vram apper at 0xD0000000
[drm] size 9216000
[drm] fb depth is 24
[drm]    pitch is 7680
Console: switching to colour frame buffer device 240x75
fb0: radeondrmfb frame buffer device
drm: registered panic notifier
[drm] Initialized radeon 2.7.0 20080528 for 0000:01:00.0 on minor 0
Comment 1 Manuel Lauss 2010-11-18 04:47:29 UTC
When the BUG() in ttm_bo.c:1123 triggers, the values are as follows:

bo->mem.num_pages = 16984, placement->lpfn =16384, placement->fpfn = 0

Hope that helps a bit.
Comment 2 Manuel Lauss 2010-11-18 05:07:36 UTC
I applied the following patch to the kernel; with it firefox loads and displays
the image.

diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
index 3ca77dc..e67831c 100644
--- a/drivers/gpu/drm/ttm/ttm_bo.c
+++ b/drivers/gpu/drm/ttm/ttm_bo.c
@@ -1119,8 +1119,13 @@ EXPORT_SYMBOL(ttm_bo_validate);
 int ttm_bo_check_placement(struct ttm_buffer_object *bo,
                                struct ttm_placement *placement)
 {
-       BUG_ON((placement->fpfn || placement->lpfn) &&
-              (bo->mem.num_pages > (placement->lpfn - placement->fpfn)));
+        if (((placement->fpfn || placement->lpfn) &&
+              (bo->mem.num_pages > (placement->lpfn - placement->fpfn)))) {
+              printk(KERN_ALERT "bo->mem.num_pages = %d, placement->lpfn =%d, placement->fpfn = %d\n",
+                              bo->mem.num_pages, placement->lpfn, placement->fpfn);
+               WARN_ON(1);
+               return -ENOMEM;
+        }
 
        return 0;
 }



I get tons of warnings like these, but otherwise system seems fine:

bo->mem.num_pages = 16984, placement->lpfn =16384, placement->fpfn = 0
------------[ cut here ]------------
WARNING: at /usr/src/linux-2.6.git/drivers/gpu/drm/ttm/ttm_bo.c:1126 ttm_bo_check_placement+0x50/0x60()
Hardware name: VGN-A197XP(DE)
Modules linked in: ipw2200 libipw
Pid: 2354, comm: X Not tainted 2.6.37-rc2-00039-g3385e32-dirty #1
Call Trace:
 [<b1028318>] ? warn_slowpath_common+0x78/0xb0
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b1466220>] ? radeon_ttm_bo_destroy+0x0/0x90
 [<b1028369>] ? warn_slowpath_null+0x19/0x20
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b143364d>] ? ttm_bo_init+0x16d/0x350
 [<b1466150>] ? radeon_bo_create+0xe0/0x1b0
 [<b1466220>] ? radeon_ttm_bo_destroy+0x0/0x90
 [<b147a4c8>] ? radeon_gem_object_create+0x78/0x100
 [<b147a5b2>] ? radeon_gem_create_ioctl+0x62/0xd0
 [<b141ed6e>] ? drm_ioctl+0x19e/0x440
 [<b147a550>] ? radeon_gem_create_ioctl+0x0/0xd0
 [<b1090035>] ? do_sync_read+0xa5/0xe0
 [<b1047e39>] ? ktime_get+0x59/0x100
 [<b141ebd0>] ? drm_ioctl+0x0/0x440
 [<b109e34c>] ? do_vfs_ioctl+0x9c/0x700
 [<b10903c4>] ? vfs_read+0x104/0x150
 [<b109e9ed>] ? sys_ioctl+0x3d/0x70
 [<b1002d50>] ? sysenter_do_call+0x12/0x26
---[ end trace 7b2edf2d7bc65699 ]---
bo->mem.num_pages = 16984, placement->lpfn =16384, placement->fpfn = 0
------------[ cut here ]------------
WARNING: at /usr/src/linux-2.6.git/drivers/gpu/drm/ttm/ttm_bo.c:1126 ttm_bo_check_placement+0x50/0x60()
Hardware name: VGN-A197XP(DE)
Modules linked in: ipw2200 libipw
Pid: 2354, comm: X Tainted: G        W   2.6.37-rc2-00039-g3385e32-dirty #1
Call Trace:
 [<b1028318>] ? warn_slowpath_common+0x78/0xb0
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b1466220>] ? radeon_ttm_bo_destroy+0x0/0x90
 [<b1028369>] ? warn_slowpath_null+0x19/0x20
 [<b14311f0>] ? ttm_bo_check_placement+0x50/0x60
 [<b143364d>] ? ttm_bo_init+0x16d/0x350
 [<b1466150>] ? radeon_bo_create+0xe0/0x1b0
 [<b1466220>] ? radeon_ttm_bo_destroy+0x0/0x90
 [<b147a4c8>] ? radeon_gem_object_create+0x78/0x100
 [<b147a5b2>] ? radeon_gem_create_ioctl+0x62/0xd0
 [<b141ed6e>] ? drm_ioctl+0x19e/0x440
 [<b147a550>] ? radeon_gem_create_ioctl+0x0/0xd0
 [<b1090035>] ? do_sync_read+0xa5/0xe0
 [<b1047e39>] ? ktime_get+0x59/0x100
 [<b141ebd0>] ? drm_ioctl+0x0/0x440
 [<b109e34c>] ? do_vfs_ioctl+0x9c/0x700
 [<b10903c4>] ? vfs_read+0x104/0x150
 [<b109e9ed>] ? sys_ioctl+0x3d/0x70
 [<b1002d50>] ? sysenter_do_call+0x12/0x26
---[ end trace 7b2edf2d7bc6569a ]---
radeon 0000:01:00.0: object_init failed for (69566464, 0x00000006)
[drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (69566464, 4, 4096, -12)
Comment 3 Thomas Hellström 2010-11-18 10:38:04 UTC
This looks like a radeon driver bug.
Comment 4 Jerome Glisse 2010-11-18 10:51:59 UTC
Created attachment 40397 [details] [review]
Forbid big bo allcoation

Does the attached patch fix the issue ? (no special message in kernel log should appear) Also with that patch what is the behavior of firefox ?
Comment 5 Manuel Lauss 2010-11-18 11:42:10 UTC
Thank you, the patch fixes the issue for me.
Comment 6 Jerome Glisse 2010-11-19 12:56:50 UTC
Created attachment 40419 [details] [review]
Forid big bo allocation

Can you please try if the attached patch also works ? It's a different patch from the previous one. Also what is the behavior of firefox ? Does it print some error message ? Does it fail at showing the big picture ?
Comment 7 Manuel Lauss 2010-11-21 11:32:36 UTC
Sorry for the delay:  Your second patch doesn't work, same oops.
As for firefox behavior wrt. your first patch:  it simply shows the image.
Comment 8 Jerome Glisse 2010-11-22 07:29:44 UTC
Quite frankly i don't see how it could oops in the same way, the new patch forbid allocation of big bo and thus should never hit the code that oops. Please attach the new kernel log with the new oops.
Comment 9 Jerome Glisse 2010-11-22 07:30:30 UTC
Also can you provide a link where i can test my self the situation.
Comment 10 Jerome Glisse 2010-11-22 09:23:09 UTC
Created attachment 40481 [details] [review]
Forbid big bo allcoation

Here is a new patch, should definitly solve the issue, even if the previous version was enough for me on similar vram sized gpu.
Comment 11 Jerome Glisse 2010-11-22 09:24:21 UTC
Created attachment 40482 [details] [review]
Forbid big bo allcoation

Attached wrong patch sorry here it's please test and report
Comment 12 Manuel Lauss 2010-11-22 09:48:04 UTC
(In reply to comment #11)
> Created an attachment (id=40482) [details]
> Forbid big bo allcoation
> 
> Attached wrong patch sorry here it's please test and report

This one works.  Image(s) are displayed as they should.
Comment 13 Alex Deucher 2010-12-15 12:11:49 UTC
*** Bug 32422 has been marked as a duplicate of this bug. ***
Comment 14 Da Fox 2010-12-20 10:25:03 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Created an attachment (id=40482) [details] [details]
> > Forbid big bo allcoation
> > 
> > Attached wrong patch sorry here it's please test and report
> 
> This one works.  Image(s) are displayed as they should.

Hi, I'm the reporter of bug #32422. This patch appears to be already applied to 2.6.47-rc6. However the image at http://xkcd.com/802_large/ still display corrupted for me.
Comment 15 Reiner 2012-09-14 07:08:40 UTC
I can confirm this bug with the following configuration:
- Thinkpad R40 w/ ATI Radeon Mobility M7 (AGP)
- XUbuntu 12.04.01 with kernel 3.2.0-30-generic #48-Ubuntu SMP
- X.Org X Server 1.11.3
- open radeon driver 6.14.99
- KMS, DRI, EXA (bug does not occur with XAA, but then 2D performance is poor; fiddling with EXA options did not get rid of the bug)

full Xorg log:

[    34.083] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[    34.083] X Protocol Version 11, Revision 0
[    34.083] Build Operating System: Linux 2.6.42-26-generic i686 Ubuntu
[    34.084] Current Operating System: Linux boris 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:54:40 UTC 2012 i686
[    34.084] Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-30-generic root=UUID=c29eb28f-af18-48d5-99ff-8f871967d672 ro quiet splash vt.handoff=7
[    34.084] Build Date: 04 August 2012  01:51:24AM
[    34.084] xorg-server 2:1.11.4-0ubuntu10.7 (For technical support please see http://www.ubuntu.com/support) 
[    34.084] Current version of pixman: 0.24.4
[    34.084] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    34.084] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    34.084] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 14 07:47:48 2012
[    34.107] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    34.107] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    34.108] (==) No Layout section.  Using the first Screen section.
[    34.108] (==) No screen section available. Using defaults.
[    34.108] (**) |-->Screen "Default Screen Section" (0)
[    34.108] (**) |   |-->Monitor "<default monitor>"
[    34.108] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    34.108] (**) |   |-->Device "Radeon"
[    34.108] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    34.108] (==) Automatically adding devices
[    34.108] (==) Automatically enabling devices
[    34.108] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    34.108] 	Entry deleted from font path.
[    34.108] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    34.108] 	Entry deleted from font path.
[    34.109] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    34.109] 	Entry deleted from font path.
[    34.109] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    34.109] 	Entry deleted from font path.
[    34.109] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    34.109] 	Entry deleted from font path.
[    34.109] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    34.109] 	Entry deleted from font path.
[    34.109] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/Type1,
	built-ins
[    34.109] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    34.109] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    34.109] (II) Loader magic: 0xdea5a0
[    34.109] (II) Module ABI versions:
[    34.109] 	X.Org ANSI C Emulation: 0.4
[    34.109] 	X.Org Video Driver: 11.0
[    34.109] 	X.Org XInput driver : 16.0
[    34.109] 	X.Org Server Extension : 6.0
[    34.110] (--) PCI:*(0:1:0:0) 1002:4c57:1014:0527 rev 0, Mem @ 0xe0000000/134217728, 0xc0100000/65536, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[    34.110] (II) Open ACPI successful (/var/run/acpid.socket)
[    34.110] (II) LoadModule: "extmod"
[    34.129] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    34.129] (II) Module extmod: vendor="X.Org Foundation"
[    34.129] 	compiled for 1.11.3, module version = 1.0.0
[    34.129] 	Module class: X.Org Server Extension
[    34.129] 	ABI class: X.Org Server Extension, version 6.0
[    34.129] (II) Loading extension MIT-SCREEN-SAVER
[    34.129] (II) Loading extension XFree86-VidModeExtension
[    34.129] (II) Loading extension XFree86-DGA
[    34.129] (II) Loading extension DPMS
[    34.129] (II) Loading extension XVideo
[    34.129] (II) Loading extension XVideo-MotionCompensation
[    34.129] (II) Loading extension X-Resource
[    34.129] (II) LoadModule: "dbe"
[    34.130] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    34.130] (II) Module dbe: vendor="X.Org Foundation"
[    34.130] 	compiled for 1.11.3, module version = 1.0.0
[    34.130] 	Module class: X.Org Server Extension
[    34.130] 	ABI class: X.Org Server Extension, version 6.0
[    34.130] (II) Loading extension DOUBLE-BUFFER
[    34.130] (II) LoadModule: "glx"
[    34.130] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    34.130] (II) Module glx: vendor="X.Org Foundation"
[    34.130] 	compiled for 1.11.3, module version = 1.0.0
[    34.130] 	ABI class: X.Org Server Extension, version 6.0
[    34.130] (==) AIGLX enabled
[    34.130] (II) Loading extension GLX
[    34.130] (II) LoadModule: "record"
[    34.130] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    34.131] (II) Module record: vendor="X.Org Foundation"
[    34.131] 	compiled for 1.11.3, module version = 1.13.0
[    34.131] 	Module class: X.Org Server Extension
[    34.131] 	ABI class: X.Org Server Extension, version 6.0
[    34.131] (II) Loading extension RECORD
[    34.131] (II) LoadModule: "dri"
[    34.131] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    34.131] (II) Module dri: vendor="X.Org Foundation"
[    34.131] 	compiled for 1.11.3, module version = 1.0.0
[    34.131] 	ABI class: X.Org Server Extension, version 6.0
[    34.131] (II) Loading extension XFree86-DRI
[    34.131] (II) LoadModule: "dri2"
[    34.131] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    34.132] (II) Module dri2: vendor="X.Org Foundation"
[    34.133] 	compiled for 1.11.3, module version = 1.2.0
[    34.133] 	ABI class: X.Org Server Extension, version 6.0
[    34.133] (II) Loading extension DRI2
[    34.133] (II) LoadModule: "radeon"
[    34.142] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    34.142] (II) Module radeon: vendor="X.Org Foundation"
[    34.142] 	compiled for 1.11.3, module version = 6.14.99
[    34.142] 	Module class: X.Org Video Driver
[    34.142] 	ABI class: X.Org Video Driver, version 11.0
[    34.142] (II) RADEON: Driver for ATI Radeon chipsets:
	ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
	ATI Radeon Mobility X300 (M24) 3152 (PCIE),
	ATI FireGL M24 GL 3154 (PCIE), ATI FireMV 2400 3155 (PCI),
	ATI Radeon X600 (RV380) 3E50 (PCIE),
	ATI FireGL V3200 (RV380) 3E54 (PCIE), ATI Radeon IGP320 (A3) 4136,
	ATI Radeon IGP330/340/350 (A4) 4137, ATI Radeon 9500 AD (AGP),
	ATI Radeon 9500 AE (AGP), ATI Radeon 9600TX AF (AGP),
	ATI FireGL Z1 AG (AGP), ATI Radeon 9800SE AH (AGP),
	ATI Radeon 9800 AI (AGP), ATI Radeon 9800 AJ (AGP),
	ATI FireGL X2 AK (AGP), ATI Radeon 9600 AP (AGP),
	ATI Radeon 9600SE AQ (AGP), ATI Radeon 9600XT AR (AGP),
	ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP), ATI Radeon 9650,
	ATI FireGL RV360 AV (AGP), ATI Radeon 7000 IGP (A4+) 4237,
	ATI Radeon 8500 AIW BB (AGP), ATI Radeon IGP320M (U1) 4336,
	ATI Radeon IGP330M/340M/350M (U2) 4337,
	ATI Radeon Mobility 7000 IGP 4437, ATI Radeon 9000/PRO If (AGP/PCI),
	ATI Radeon 9000 Ig (AGP/PCI), ATI Radeon X800 (R420) JH (AGP),
	ATI Radeon X800PRO (R420) JI (AGP),
	ATI Radeon X800SE (R420) JJ (AGP), ATI Radeon X800 (R420) JK (AGP),
	ATI Radeon X800 (R420) JL (AGP), ATI FireGL X3 (R420) JM (AGP),
	ATI Radeon Mobility 9800 (M18) JN (AGP),
	ATI Radeon X800 SE (R420) (AGP), ATI Radeon X800XT (R420) JP (AGP),
	ATI Radeon X800 VE (R420) JT (AGP), ATI Radeon X850 (R480) (AGP),
	ATI Radeon X850 XT (R480) (AGP), ATI Radeon X850 SE (R480) (AGP),
	ATI Radeon X850 PRO (R480) (AGP), ATI Radeon X850 XT PE (R480) (AGP),
	ATI Radeon Mobility M7 LW (AGP),
	ATI Mobility FireGL 7800 M7 LX (AGP),
	ATI Radeon Mobility M6 LY (AGP), ATI Radeon Mobility M6 LZ (AGP),
	ATI FireGL Mobility 9000 (M9) Ld (AGP),
	ATI Radeon Mobility 9000 (M9) Lf (AGP),
	ATI Radeon Mobility 9000 (M9) Lg (AGP), ATI FireMV 2400 PCI,
	ATI Radeon 9700 Pro ND (AGP), ATI Radeon 9700/9500Pro NE (AGP),
	ATI Radeon 9600TX NF (AGP), ATI FireGL X1 NG (AGP),
	ATI Radeon 9800PRO NH (AGP), ATI Radeon 9800 NI (AGP),
	ATI FireGL X2 NK (AGP), ATI Radeon 9800XT NJ (AGP),
	ATI Radeon Mobility 9600/9700 (M10/M11) NP (AGP),
	ATI Radeon Mobility 9600 (M10) NQ (AGP),
	ATI Radeon Mobility 9600 (M11) NR (AGP),
	ATI Radeon Mobility 9600 (M10) NS (AGP),
	ATI FireGL Mobility T2 (M10) NT (AGP),
	ATI FireGL Mobility T2e (M11) NV (AGP), ATI Radeon QD (AGP),
	ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),
	ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),
	ATI Radeon 9100 QM (AGP), ATI Radeon 7500 QW (AGP/PCI),
	ATI Radeon 7500 QX (AGP/PCI), ATI Radeon VE/7000 QY (AGP/PCI),
	ATI Radeon VE/7000 QZ (AGP/PCI), ATI ES1000 515E (PCI),
	ATI Radeon Mobility X300 (M22) 5460 (PCIE),
	ATI Radeon Mobility X600 SE (M24C) 5462 (PCIE),
	ATI FireGL M22 GL 5464 (PCIE), ATI Radeon X800 (R423) UH (PCIE),
	ATI Radeon X800PRO (R423) UI (PCIE),
	ATI Radeon X800LE (R423) UJ (PCIE),
	ATI Radeon X800SE (R423) UK (PCIE),
	ATI Radeon X800 XTP (R430) (PCIE), ATI Radeon X800 XL (R430) (PCIE),
	ATI Radeon X800 SE (R430) (PCIE), ATI Radeon X800 (R430) (PCIE),
	ATI FireGL V7100 (R423) (PCIE), ATI FireGL V5100 (R423) UQ (PCIE),
	ATI FireGL unknown (R423) UR (PCIE),
	ATI FireGL unknown (R423) UT (PCIE),
	ATI Mobility FireGL V5000 (M26) (PCIE),
	ATI Mobility FireGL V5000 (M26) (PCIE),
	ATI Mobility Radeon X700 XL (M26) (PCIE),
	ATI Mobility Radeon X700 (M26) (PCIE),
	ATI Mobility Radeon X700 (M26) (PCIE),
	ATI Radeon X550XTX 5657 (PCIE), ATI Radeon 9100 IGP (A5) 5834,
	ATI Radeon Mobility 9100 IGP (U3) 5835,
	ATI Radeon XPRESS 200 5954 (PCIE),
	ATI Radeon XPRESS 200M 5955 (PCIE), ATI Radeon 9250 5960 (AGP),
	ATI Radeon 9200 5961 (AGP), ATI Radeon 9200 5962 (AGP),
	ATI Radeon 9200SE 5964 (AGP), ATI FireMV 2200 (PCI),
	ATI ES1000 5969 (PCI), ATI Radeon XPRESS 200 5974 (PCIE),
	ATI Radeon XPRESS 200M 5975 (PCIE),
	ATI Radeon XPRESS 200 5A41 (PCIE),
	ATI Radeon XPRESS 200M 5A42 (PCIE),
	ATI Radeon XPRESS 200 5A61 (PCIE),
	ATI Radeon XPRESS 200M 5A62 (PCIE),
	ATI Radeon X300 (RV370) 5B60 (PCIE),
	ATI Radeon X600 (RV370) 5B62 (PCIE),
	ATI Radeon X550 (RV370) 5B63 (PCIE),
	ATI FireGL V3100 (RV370) 5B64 (PCIE),
	ATI FireMV 2200 PCIE (RV370) 5B65 (PCIE),
	ATI Radeon Mobility 9200 (M9+) 5C61 (AGP),
	ATI Radeon Mobility 9200 (M9+) 5C63 (AGP),
	ATI Mobility Radeon X800 XT (M28) (PCIE),
	ATI Mobility FireGL V5100 (M28) (PCIE),
	ATI Mobility Radeon X800 (M28) (PCIE), ATI Radeon X850 5D4C (PCIE),
	ATI Radeon X850 XT PE (R480) (PCIE),
	ATI Radeon X850 SE (R480) (PCIE), ATI Radeon X850 PRO (R480) (PCIE),
	ATI unknown Radeon / FireGL (R480) 5D50 (PCIE),
	ATI Radeon X850 XT (R480) (PCIE),
	ATI Radeon X800XT (R423) 5D57 (PCIE),
	ATI FireGL V5000 (RV410) (PCIE), ATI Radeon X700 XT (RV410) (PCIE),
	ATI Radeon X700 PRO (RV410) (PCIE),
	ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X700 (RV410) (PCIE),
	ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X1800,
	ATI Mobility Radeon X1800 XT, ATI Mobility Radeon X1800,
	ATI Mobility FireGL V7200, ATI FireGL V7200, ATI FireGL V5300,
	ATI Mobility FireGL V7100, ATI Radeon X1800, ATI Radeon X1800,
	ATI Radeon X1800, ATI Radeon X1800, ATI Radeon X1800,
	ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
	ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
	ATI Mobility Radeon X1400, ATI Radeon X1300/X1550,
	ATI Radeon X1550 64-bit, ATI Mobility Radeon X1300,
	ATI Mobility Radeon X1300, ATI Mobility Radeon X1300,
	ATI Mobility Radeon X1300, ATI Radeon X1300, ATI Radeon X1300,
	ATI RV505, ATI RV505, ATI FireGL V3300, ATI FireGL V3350,
	ATI Radeon X1300, ATI Radeon X1550 64-bit, ATI Radeon X1300/X1550,
	ATI Radeon X1600, ATI Radeon X1300/X1550, ATI Mobility Radeon X1450,
	ATI Radeon X1300/X1550, ATI Mobility Radeon X2300,
	ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
	ATI Mobility Radeon X1350, ATI Mobility Radeon X1450,
	ATI Radeon X1300, ATI Radeon X1550, ATI Mobility Radeon X1350,
	ATI FireMV 2250, ATI Radeon X1550 64-bit, ATI Radeon X1600,
	ATI Radeon X1650, ATI Radeon X1600, ATI Radeon X1600,
	ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,
	ATI Radeon X1650, ATI Radeon X1650, ATI Radeon X1600,
	ATI Radeon X1300 XT/X1600 Pro, ATI FireGL V3400,
	ATI Mobility FireGL V5250, ATI Mobility Radeon X1700,
	ATI Mobility Radeon X1700 XT, ATI FireGL V5200,
	ATI Mobility Radeon X1700, ATI Radeon X2300HD,
	ATI Mobility Radeon HD 2300, ATI Mobility Radeon HD 2300,
	ATI Radeon X1950, ATI Radeon X1900, ATI Radeon X1950,
	ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
	ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
	ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
	ATI AMD Stream Processor, ATI Radeon X1900, ATI Radeon X1950,
	ATI RV560, ATI RV560, ATI Mobility Radeon X1900, ATI RV560,
	ATI Radeon X1950 GT, ATI RV570, ATI RV570, ATI FireGL V7400,
	ATI RV560, ATI Radeon X1650, ATI Radeon X1650, ATI RV560,
	ATI Radeon 9100 PRO IGP 7834, ATI Radeon Mobility 9200 IGP 7835,
	ATI Radeon X1200, ATI Radeon X1200, ATI Radeon X1200,
	ATI Radeon X1200, ATI Radeon X1200, ATI RS740, ATI RS740M, ATI RS740,
	ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 XT,
	ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro, ATI Radeon HD 2900 GT,
	ATI FireGL V8650, ATI FireGL V8600, ATI FireGL V7600,
	ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
	ATI Radeon 4800 Series, ATI Radeon HD 4850 x2,
	ATI FirePro V8750 (FireGL), ATI FirePro V7760 (FireGL),
	ATI Mobility RADEON HD 4850, ATI Mobility RADEON HD 4850 X2,
	ATI Radeon 4800 Series, ATI FirePro RV770, AMD FireStream 9270,
	AMD FireStream 9250, ATI FirePro V8700 (FireGL),
	ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
	ATI Mobility RADEON HD 4870, ATI Radeon 4800 Series,
	ATI Radeon 4800 Series, ATI FirePro M7750, ATI M98, ATI M98, ATI M98,
	ATI Mobility Radeon HD 4650, ATI Radeon RV730 (AGP),
	ATI Mobility Radeon HD 4670, ATI FirePro M5750,
	ATI Mobility Radeon HD 4670, ATI Radeon RV730 (AGP),
	ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
	ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
	ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
	ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
	ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
	ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI Radeon HD 4770,
	ATI FirePro M5750, ATI RV610, ATI Radeon HD 2400 XT,
	ATI Radeon HD 2400 Pro, ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000,
	ATI RV610, ATI Radeon HD 2350, ATI Mobility Radeon HD 2400 XT,
	ATI Mobility Radeon HD 2400, ATI RADEON E2400, ATI RV610,
	ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
	ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
	ATI Mobility Radeon HD 3850 X2, ATI RV670,
	ATI Mobility Radeon HD 3870, ATI Mobility Radeon HD 3870 X2,
	ATI Radeon HD3870 X2, ATI FireGL V7700, ATI Radeon HD3850,
	ATI Radeon HD3690, AMD Firestream 9170, ATI Radeon HD 4550,
	ATI Radeon RV710, ATI Radeon RV710, ATI Radeon RV710,
	ATI Radeon HD 4350, ATI Mobility Radeon 4300 Series,
	ATI Mobility Radeon 4500 Series, ATI Mobility Radeon 4500 Series,
	ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
	ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
	ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
	ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
	ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
	ATI FireGL V3600, ATI Radeon HD 2600 LE,
	ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
	ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
	ATI Radeon HD 3450, ATI Radeon HD 3450, ATI Radeon HD 3430,
	ATI Radeon HD 3450, ATI FirePro V3700, ATI FireMV 2450,
	ATI FireMV 2260, ATI FireMV 2260, ATI Radeon HD 3600 Series,
	ATI Radeon HD 3650 AGP, ATI Radeon HD 3600 PRO,
	ATI Radeon HD 3600 XT, ATI Radeon HD 3600 PRO,
	ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
	ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
	ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
	ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
	ATI Radeon HD 3300 Graphics, ATI Radeon HD 3200 Graphics,
	ATI Radeon 3000 Graphics, SUMO, SUMO, SUMO2, SUMO2, SUMO2, SUMO2,
	SUMO, SUMO, SUMO, SUMO, SUMO, SUMO, SUMO, ATI Radeon HD 4200,
	ATI Radeon 4100, ATI Mobility Radeon HD 4200,
	ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
	AMD Radeon HD 6310 Graphics, AMD Radeon HD 6310 Graphics,
	AMD Radeon HD 6250 Graphics, AMD Radeon HD 6250 Graphics,
	AMD Radeon HD 6300 Series Graphics,
	AMD Radeon HD 6200 Series Graphics, PALM, PALM, CYPRESS,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
	AMD Firestream 9350, ATI Radeon HD 5800 Series,
	ATI Radeon HD 5800 Series, ATI Radeon HD 5800 Series,
	ATI Radeon HD 5800 Series, ATI Radeon HD 5900 Series,
	ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
	ATI Mobility Radeon HD 5800 Series,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI Mobility Radeon HD 5800 Series, ATI Radeon HD 5700 Series,
	ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
	ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
	ATI Mobility Radeon HD 5000 Series,
	ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI FirePro (FireGL) Graphics Adapter, ATI Radeon HD 5670,
	ATI Radeon HD 5570, ATI Radeon HD 5500 Series, REDWOOD,
	ATI Mobility Radeon HD 5000 Series,
	ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon Graphics,
	ATI Mobility Radeon Graphics, CEDAR,
	ATI FirePro (FireGL) Graphics Adapter,
	ATI FirePro (FireGL) Graphics Adapter, ATI FirePro 2270, CEDAR,
	ATI Radeon HD 5450, CEDAR, CEDAR, CAYMAN, CAYMAN, CAYMAN, CAYMAN,
	CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN,
	AMD Radeon HD 6900 Series, AMD Radeon HD 6900 Series, CAYMAN, CAYMAN,
	CAYMAN, AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series,
	BARTS, BARTS, Mobility Radeon HD 6000 Series,
	Mobility Radeon HD 6000 Series, BARTS, BARTS, BARTS, BARTS,
	AMD Radeon HD 6800 Series, AMD Radeon HD 6800 Series,
	AMD Radeon HD 6700 Series, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
	TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
	TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
	CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS,
	CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS
[    34.164] (++) using VT number 7

[    34.165] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    34.165] (II) [KMS] Kernel modesetting enabled.
[    34.165] (II) RADEON(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    34.165] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[    34.165] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    34.165] (==) RADEON(0): Default visual is TrueColor
[    34.165] (**) RADEON(0): Option "SWcursor" "off"
[    34.165] (**) RADEON(0): Option "EnablePageFlip" "on"
[    34.165] (**) RADEON(0): Option "AccelDFS" "on"
[    34.165] (**) RADEON(0): Option "ColorTiling" "on"
[    34.165] (**) RADEON(0): Option "RenderAccel" "on"
[    34.165] (**) RADEON(0): Option "AccelMethod" "EXA"
[    34.165] (**) RADEON(0): Option "DRI" "on"
[    34.165] (**) RADEON(0): Option "EXAVSync" "off"
[    34.165] (**) RADEON(0): Option "EXAPixmaps" "on"
[    34.165] (==) RADEON(0): RGB weight 888
[    34.165] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[    34.165] (--) RADEON(0): Chipset: "ATI Radeon Mobility M7 LW (AGP)" (ChipID = 0x4c57)
[    34.165] (II) RADEON(0): AGP card detected
[    34.165] drmOpenDevice: node name is /dev/dri/card0
[    34.165] drmOpenDevice: open result is 9, (OK)
[    34.165] drmOpenByBusid: Searching for BusID pci:0000:01:00.0
[    34.165] drmOpenDevice: node name is /dev/dri/card0
[    34.165] drmOpenDevice: open result is 9, (OK)
[    34.165] drmOpenByBusid: drmOpenMinor returns 9
[    34.165] drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[    34.165] (II) Loading sub module "exa"
[    34.165] (II) LoadModule: "exa"
[    34.166] (II) Loading /usr/lib/xorg/modules/libexa.so
[    34.166] (II) Module exa: vendor="X.Org Foundation"
[    34.166] 	compiled for 1.11.3, module version = 2.5.0
[    34.166] 	ABI class: X.Org Video Driver, version 11.0
[    34.166] (II) RADEON(0): KMS Color Tiling: enabled
[    34.166] (II) RADEON(0): KMS Pageflipping: enabled
[    34.166] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[    34.184] (II) RADEON(0): Output VGA-0 has no monitor section
[    34.184] (II) RADEON(0): Output LVDS has no monitor section
[    34.204] (II) RADEON(0): Output S-video has no monitor section
[    34.239] (II) RADEON(0): EDID for output VGA-0
[    34.239] (II) RADEON(0): EDID for output LVDS
[    34.239] (II) RADEON(0): Printing probed modes for output LVDS
[    34.239] (II) RADEON(0): Modeline "1024x768"x60.0   65.00  1024 1040 1176 1344  768 770 776 806 (48.4 kHz)
[    34.239] (II) RADEON(0): Modeline "800x600"x59.9   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz)
[    34.239] (II) RADEON(0): Modeline "848x480"x59.7   31.50  848 872 952 1056  480 483 493 500 -hsync +vsync (29.8 kHz)
[    34.239] (II) RADEON(0): Modeline "720x480"x59.7   26.75  720 744 808 896  480 483 493 500 -hsync +vsync (29.9 kHz)
[    34.239] (II) RADEON(0): Modeline "640x480"x59.4   23.75  640 664 720 800  480 483 487 500 -hsync +vsync (29.7 kHz)
[    34.251] (II) RADEON(0): EDID for output S-video
[    34.251] (II) RADEON(0): Output VGA-0 disconnected
[    34.261] (II) RADEON(0): Output LVDS connected
[    34.261] (II) RADEON(0): Output S-video disconnected
[    34.261] (II) RADEON(0): Using exact sizes for initial modes
[    34.261] (II) RADEON(0): Output LVDS using initial mode 1024x768
[    34.261] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    34.261] (II) RADEON(0): mem size init: gart size :fdff000 vram size: s:2000000 visible:1f00000
[    34.261] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
[    34.261] (==) RADEON(0): DPI set to (96, 96)
[    34.261] (II) Loading sub module "fb"
[    34.261] (II) LoadModule: "fb"
[    34.262] (II) Loading /usr/lib/xorg/modules/libfb.so
[    34.262] (II) Module fb: vendor="X.Org Foundation"
[    34.262] 	compiled for 1.11.3, module version = 1.0.0
[    34.262] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    34.262] (II) Loading sub module "ramdac"
[    34.262] (II) LoadModule: "ramdac"
[    34.262] (II) Module "ramdac" already built-in
[    34.262] (--) Depth 24 pixmap format is 32 bpp
[    34.262] (II) RADEON(0): [DRI2] Setup complete
[    34.262] (II) RADEON(0): [DRI2]   DRI driver: radeon
[    34.262] (II) RADEON(0): [DRI2]   VDPAU driver: radeon
[    34.262] (II) RADEON(0): Front buffer size: 3072K
[    34.262] (II) RADEON(0): VRAM usage limit set to 25804K
[    34.262] (==) RADEON(0): Backing store disabled
[    34.262] (II) RADEON(0): Direct rendering enabled
[    34.262] (II) RADEON(0): Render acceleration enabled for R100 type cards.
[    34.262] (II) RADEON(0): Setting EXA maxPitchBytes
[    34.262] (II) EXA(0): Driver allocated offscreen pixmaps
[    34.262] (II) EXA(0): Driver registered support for the following operations:
[    34.262] (II)         Solid
[    34.263] (II)         Copy
[    34.263] (II)         Composite (RENDER acceleration)
[    34.263] (II)         UploadToScreen
[    34.263] (II)         DownloadFromScreen
[    34.263] (II) RADEON(0): Acceleration enabled
[    34.263] (==) RADEON(0): DPMS enabled
[    34.263] (==) RADEON(0): Silken mouse enabled
[    34.263] (II) RADEON(0): Set up textured video
[    34.263] (II) RADEON(0): [XvMC] Associated with Radeon Textured Video.
[    34.263] (II) RADEON(0): [XvMC] Extension initialized.
[    34.263] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    34.263] (--) RandR disabled
[    34.263] (II) Initializing built-in extension Generic Event Extension
[    34.263] (II) Initializing built-in extension SHAPE
[    34.263] (II) Initializing built-in extension MIT-SHM
[    34.263] (II) Initializing built-in extension XInputExtension
[    34.263] (II) Initializing built-in extension XTEST
[    34.263] (II) Initializing built-in extension BIG-REQUESTS
[    34.263] (II) Initializing built-in extension SYNC
[    34.263] (II) Initializing built-in extension XKEYBOARD
[    34.263] (II) Initializing built-in extension XC-MISC
[    34.263] (II) Initializing built-in extension SECURITY
[    34.263] (II) Initializing built-in extension XINERAMA
[    34.263] (II) Initializing built-in extension XFIXES
[    34.263] (II) Initializing built-in extension RENDER
[    34.263] (II) Initializing built-in extension RANDR
[    34.263] (II) Initializing built-in extension COMPOSITE
[    34.263] (II) Initializing built-in extension DAMAGE
[    34.377] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    34.377] (II) AIGLX: enabled GLX_INTEL_swap_event
[    34.377] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    34.378] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    34.378] (II) AIGLX: Loaded and initialized radeon
[    34.378] (II) GLX: Initialized DRI2 GL provider for screen 0
[    34.380] (II) RADEON(0): Setting screen physical size to 270 x 203
[    34.425] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[    34.440] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    34.441] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    34.441] (II) LoadModule: "evdev"
[    34.441] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.444] (II) Module evdev: vendor="X.Org Foundation"
[    34.444] 	compiled for 1.11.3, module version = 2.7.0
[    34.444] 	Module class: X.Org XInput Driver
[    34.444] 	ABI class: X.Org XInput driver, version 16.0
[    34.444] (II) Using input driver 'evdev' for 'Power Button'
[    34.444] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.446] (**) Power Button: always reports core events
[    34.446] (**) evdev: Power Button: Device: "/dev/input/event2"
[    34.446] (--) evdev: Power Button: Vendor 0 Product 0x1
[    34.446] (--) evdev: Power Button: Found keys
[    34.446] (II) evdev: Power Button: Configuring as keyboard
[    34.446] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    34.446] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    34.446] (**) Option "xkb_rules" "evdev"
[    34.446] (**) Option "xkb_model" "pc105"
[    34.446] (**) Option "xkb_layout" "us"
[    34.447] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[    34.447] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    34.447] (II) Using input driver 'evdev' for 'Video Bus'
[    34.447] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.447] (**) Video Bus: always reports core events
[    34.447] (**) evdev: Video Bus: Device: "/dev/input/event4"
[    34.447] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    34.448] (--) evdev: Video Bus: Found keys
[    34.448] (II) evdev: Video Bus: Configuring as keyboard
[    34.448] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:03/LNXVIDEO:00/input/input4/event4"
[    34.448] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    34.448] (**) Option "xkb_rules" "evdev"
[    34.448] (**) Option "xkb_model" "pc105"
[    34.448] (**) Option "xkb_layout" "us"
[    34.449] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    34.449] (II) No input driver specified, ignoring this device.
[    34.449] (II) This device may have been added with another device file.
[    34.449] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    34.449] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    34.449] (II) Using input driver 'evdev' for 'Sleep Button'
[    34.449] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.449] (**) Sleep Button: always reports core events
[    34.449] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[    34.449] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    34.449] (--) evdev: Sleep Button: Found keys
[    34.449] (II) evdev: Sleep Button: Configuring as keyboard
[    34.449] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input1/event1"
[    34.449] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    34.449] (**) Option "xkb_rules" "evdev"
[    34.450] (**) Option "xkb_model" "pc105"
[    34.450] (**) Option "xkb_layout" "us"
[    34.461] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[    34.461] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    34.461] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    34.461] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.461] (**) AT Translated Set 2 keyboard: always reports core events
[    34.461] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event3"
[    34.461] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    34.461] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    34.461] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    34.461] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event3"
[    34.461] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    34.461] (**) Option "xkb_rules" "evdev"
[    34.461] (**) Option "xkb_model" "pc105"
[    34.461] (**) Option "xkb_layout" "us"
[    34.466] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[    34.466] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    34.466] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    34.466] (II) LoadModule: "synaptics"
[    34.467] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    34.467] (II) Module synaptics: vendor="X.Org Foundation"
[    34.467] 	compiled for 1.11.3, module version = 1.6.2
[    34.467] 	Module class: X.Org XInput Driver
[    34.467] 	ABI class: X.Org XInput driver, version 16.0
[    34.467] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    34.467] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    34.467] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    34.467] (**) Option "Device" "/dev/input/event5"
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    34.467] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    34.467] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    34.467] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input5/event5"
[    34.467] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 10)
[    34.467] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    34.467] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    34.467] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[    34.475] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    34.475] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    34.475] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    34.475] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    34.475] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    34.475] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    34.475] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    34.484] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event6)
[    34.484] (**) ThinkPad Extra Buttons: Applying InputClass "evdev keyboard catchall"
[    34.484] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'
[    34.485] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    34.485] (**) ThinkPad Extra Buttons: always reports core events
[    34.485] (**) evdev: ThinkPad Extra Buttons: Device: "/dev/input/event6"
[    34.490] (--) evdev: ThinkPad Extra Buttons: Vendor 0x1014 Product 0x5054
[    34.490] (--) evdev: ThinkPad Extra Buttons: Found keys
[    34.490] (II) evdev: ThinkPad Extra Buttons: Configuring as keyboard
[    34.490] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input6/event6"
[    34.490] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 11)
[    34.490] (**) Option "xkb_rules" "evdev"
[    34.490] (**) Option "xkb_model" "pc105"
[    34.490] (**) Option "xkb_layout" "us"
[    38.270] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
[    38.270] (II) No input driver specified, ignoring this device.
[    38.270] (II) This device may have been added with another device file.
[    38.274] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event7)
[    38.274] (**) TPPS/2 IBM TrackPoint: Applying InputClass "evdev pointer catchall"
[    38.274] (**) TPPS/2 IBM TrackPoint: Applying InputClass "trackpoint catchall"
[    38.274] (II) Using input driver 'evdev' for 'TPPS/2 IBM TrackPoint'
[    38.274] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    38.274] (**) TPPS/2 IBM TrackPoint: always reports core events
[    38.274] (**) evdev: TPPS/2 IBM TrackPoint: Device: "/dev/input/event7"
[    38.274] (--) evdev: TPPS/2 IBM TrackPoint: Vendor 0x2 Product 0xa
[    38.274] (--) evdev: TPPS/2 IBM TrackPoint: Found 3 mouse buttons
[    38.274] (--) evdev: TPPS/2 IBM TrackPoint: Found relative axes
[    38.274] (--) evdev: TPPS/2 IBM TrackPoint: Found x and y relative axes
[    38.274] (II) evdev: TPPS/2 IBM TrackPoint: Configuring as mouse
[    38.274] (**) Option "Emulate3Buttons" "true"
[    38.274] (**) Option "EmulateWheel" "true"
[    38.274] (**) Option "EmulateWheelButton" "2"
[    38.274] (**) Option "YAxisMapping" "4 5"
[    38.274] (**) evdev: TPPS/2 IBM TrackPoint: YAxisMapping: buttons 4 and 5
[    38.274] (**) Option "XAxisMapping" "6 7"
[    38.274] (**) evdev: TPPS/2 IBM TrackPoint: XAxisMapping: buttons 6 and 7
[    38.274] (**) evdev: TPPS/2 IBM TrackPoint: EmulateWheelButton: 2, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    38.274] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/serio2/input/input7/event7"
[    38.274] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 12)
[    38.274] (II) evdev: TPPS/2 IBM TrackPoint: initialized for relative axes.
[    38.275] (**) TPPS/2 IBM TrackPoint: (accel) keeping acceleration scheme 1
[    38.275] (**) TPPS/2 IBM TrackPoint: (accel) acceleration profile 0
[    38.275] (**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
[    38.275] (**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
Comment 16 Michel Dänzer 2012-09-14 10:49:11 UTC
(In reply to comment #15)
> I can confirm this bug with the following configuration:
> - Thinkpad R40 w/ ATI Radeon Mobility M7 (AGP)
> - XUbuntu 12.04.01 with kernel 3.2.0-30-generic #48-Ubuntu SMP

I doubt it's exactly the same bug (this one should be fixed since 2.6.37?), so it would be better to track your problem in a separate report.

Please provide the dmesg output corresponding to your problem, but please attach files instead of pasting them in comments.
Comment 17 Reiner 2012-09-14 15:42:47 UTC
Created attachment 67172 [details]
kern.log NULL pointer dereference bug

Thanks Michel. Here is kern.log re the bug that occurred when loading the large image in Firefox. I have since had a slightly different kind of Oops, also while using Firefox, for which I provide a separate attachment.
Comment 18 Reiner 2012-09-14 15:48:27 UTC
Created attachment 67175 [details]
kern.log unable to handle kernel paging request bug

This Oops occurred also while Firefox was rendering something, but am unsure of what exactly it was on the page that caused the crash since it was a fairly complex web site.
Comment 19 Michel Dänzer 2012-09-15 08:19:39 UTC
Reiner, your first problem looks like bug 54527. AFAICT the change causing that was backported to 3.2.25, but should be fixed again in 3.2.29. Your second problem looks like the system is genuinely out of memory.

Neither is the same as the problem this report is about, which should be long fixed. Resolving.
Comment 20 Reiner 2012-09-15 14:25:38 UTC
Dear Michel,

I actually stumbled across the commit 2744f4e762141d0b1233f962ebe706d60cd460d2 by Alex in http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.2.29 and sent him a PM to which he was kind enough to reply:
'As Michel noted on the bug, it appears to be a different issue in your case.  An alternate workaround would be to use shadowfb.  Add: Option "NoAccel" "True"
To the device section of your xorg.conf'
From your reply, I gather you think that Alex's commit actually does fix the issue. Only one way to find out ... I will report back once I have tried 3.2.29 in place of my stock XUbuntu 3.2.0 kernel. Perhaps the other issue will go away as well.
Comment 21 Reiner 2012-09-15 15:18:33 UTC
The issue w loading large images in Firefox was resolved by installing the 3.4.0 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/ .


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.