Bug 31771 - r600g: sauerbraten missing gun (r600c works)
Summary: r600g: sauerbraten missing gun (r600c works)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-19 10:37 UTC by Török Edwin
Modified: 2011-01-07 10:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
~/.sauerbraten/config.cfg (11.27 KB, application/octet-stream)
2010-11-19 10:37 UTC, Török Edwin
Details
~/.sauerbraten/init.cfg (254 bytes, application/octet-stream)
2010-11-19 10:37 UTC, Török Edwin
Details
r600c screenshot (good) (143.46 KB, image/jpeg)
2010-11-19 10:40 UTC, Török Edwin
Details
r600g screenshot (bad) (121.94 KB, image/jpeg)
2010-11-19 10:40 UTC, Török Edwin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Török Edwin 2010-11-19 10:37:34 UTC
Created attachment 40411 [details]
~/.sauerbraten/config.cfg

Similar bug to https://bugs.freedesktop.org/show_bug.cgi?id=31667 , but this time in an open-source game.
See attached screenshots: r600g shows no gun, r600c does.

To reproduce:
1. Copy the .cfg attached to this bug to ~/.sauerbraten
2. Run sauerbraten (version 0.0.20100728.dfsg-2 if you're using Debian)
3. Campaign -> Start Level 9
4. Wait till it loads
5. You should see a gun, instead you just see the targeting reticule

Sauerbraten says:
LIBGL_DRIVERS_PATH=$HOME/mesa/lib/gallium sauerbraten
Using home directory: /home/edwin/.sauerbraten
init: sdl
init: net
init: game
init: video: mode
init: video: misc
init: gl
Renderer: Gallium 0.4 on AMD RV730 (X.Org)
Driver: 2.1 Mesa 7.10-devel
Rendering using the OpenGL assembly/GLSL shader path.
init: console
init: gl: effects
init: world
init: sound
init: cfg
init: mainloop
read map packages/base/lost.ogz (0.5 seconds)
game mode is SP

This is with latest mesa git, commit 185d862cd8cd0a56dd86daa01d9c692ff4abfb54:
OpenGL renderer string: Gallium 0.4 on AMD RV730
OpenGL version string: 2.1 Mesa 7.10-devel
OpenGL shading language version string: 1.20
Comment 1 Török Edwin 2010-11-19 10:37:58 UTC
Created attachment 40412 [details]
~/.sauerbraten/init.cfg
Comment 2 Török Edwin 2010-11-19 10:40:05 UTC
Created attachment 40413 [details]
r600c screenshot (good)
Comment 3 Török Edwin 2010-11-19 10:40:55 UTC
Created attachment 40414 [details]
r600g screenshot (bad)
Comment 4 Alex Deucher 2010-11-19 12:08:18 UTC
This is probably a duplicate of bug 31613
Comment 5 Török Edwin 2010-11-19 13:00:26 UTC
(In reply to comment #4)
> This is probably a duplicate of bug 31613

Tried reverting that commit, it didn't help.
Comment 6 Tilman Sauerbeck 2011-01-07 10:35:27 UTC
Fixed by

commit 97e2aa31c6e735d5f6bd1d67a4dd8da2605aedc8
Author: Henri Verbeet <hverbeet@gmail.com>
Date:   Fri Jan 7 17:06:11 2011 +0100

    r600g: Split ALU clauses based on used constant cache lines.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.