Bug 34595 - [bisected piketon]oglc half_float_vertex(misc.fillmode.wireframe) regressed
Summary: [bisected piketon]oglc half_float_vertex(misc.fillmode.wireframe) regressed
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All Linux (All)
: high major
Assignee: Chris Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-23 00:52 UTC by fangxun
Modified: 2011-03-01 19:27 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-02-23 00:52:07 UTC
System Environment:
--------------------------
Arch:           x86_64
Platform:       piketon 
Libdrm:         (master)2.4.23-14-ga697fb6acad7992c3d23bb6a663663694782eb7b
Mesa:           (master)94ccc31ba4f64ac480137fd90f1ded44d2072f6e
Xserver:      (master)xorg-server-1.9.99.902-3-g93a73
993708b1345c86ec3ec06b02ed236595673
Xf86_video_intel:  master)2.14.0-29-g9599fde65a0d8b7e7c85199346f7b620bdd8388d
Kernel: (drm-intel-next)f4166442e7533ca2668d639d939b1bbdb8e6b423


Bug detailed description:
-------------------------
This regression happens on piketon with mesa master branch. Bisect shows 559435d9152acc7162e4e60aae6591c7c6c8274b is the first bad commit.
commit 559435d9152acc7162e4e60aae6591c7c6c8274b
Author:     Chris Wilson <chris@chris-wilson.co.uk>
AuthorDate: Fri Feb 11 14:45:10 2011 +0000
Commit:     Chris Wilson <chris@chris-wilson.co.uk>
CommitDate: Mon Feb 21 12:59:35 2011 +0000

    i965: emit one vb packet per vbo

    Track reuse of the vertex buffer objects and so minimise the number of
    vertex buffers used by the hardware (and their relocations).
Comment 1 Chris Wilson 2011-02-23 01:06:54 UTC
Should be fixed by

commit 3377faffcdc7227bd27381894c87c7600547744f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Feb 22 11:18:25 2011 +0000

    i965: Zero the offset into the vbo when uploading non-interleaved
    
    Fixes regression from 559435d9152acc7162e4e60aae6591c7c6c8274b.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 2 fangxun 2011-02-23 02:27:28 UTC
Tested with 3377faffcdc7227bd27381894c87c7600547744f, regression still happens.
BTW, 559435d9152acc7162e4e60aae6591c7c6c8274b also causes following 8 cases regressed.
draw-buffers2(misc.pushPop)
draw-buffers2(basic.blending.functional)
draw-buffers2(advanced.blending.ordering)
draw-buffers2(advanced.blending.defaultFramebuffer)
draw-buffers2(advanced.blending.global)
draw-buffers2(advanced.blending.setOnOther)
draw-buffers2(advanced.blending.drawGLSL)
half_float_vertex(misc.fillmode.wireframe)
Comment 3 fangxun 2011-02-23 03:46:33 UTC
 (In reply to comment #2)
> Tested with 3377faffcdc7227bd27381894c87c7600547744f, regression still happens.
> BTW, 559435d9152acc7162e4e60aae6591c7c6c8274b also causes following 8 cases
> regressed.
> draw-buffers2(misc.pushPop)
> draw-buffers2(basic.blending.functional)
> draw-buffers2(advanced.blending.ordering)
> draw-buffers2(advanced.blending.defaultFramebuffer)
> draw-buffers2(advanced.blending.global)
> draw-buffers2(advanced.blending.setOnOther)
> draw-buffers2(advanced.blending.drawGLSL)
> half_float_vertex(misc.fillmode.wireframe)

Sorry, I make a mistake, half_float_vertex(misc.fillmode.wireframe)is caused by commit 559435d9152acc7162e4e60aae6591c7c6c8274b.

following draw-buffers2 subcases is casused by commit aac120977d1ead319141d48d65c9bba626ec03b8, pls see bug 34597.
draw-buffers2(misc.pushPop)
draw-buffers2(basic.blending.functional)
draw-buffers2(advanced.blending.ordering)
draw-buffers2(advanced.blending.defaultFramebuffer)
draw-buffers2(advanced.blending.global)
draw-buffers2(advanced.blending.setOnOther)
draw-buffers2(advanced.blending.drawGLSL)
Comment 4 Chris Wilson 2011-02-24 04:35:19 UTC
Again, can you add the oglc output (cf bug 34603) for the failing test case?
Comment 5 Chris Wilson 2011-02-24 06:09:38 UTC
commit 764a90023080dd6aadcf4b57163844fd8f6ca803
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Feb 24 14:06:55 2011 +0000

    i965: Upload all vertices used
    
    ... and take advantage of start_vertex_bias to trim to [min_index,
    max_index] where possible (i.e. when we need to upload all arrays).
    
    Fixes half_float_vertex(misc.fillmode.wireframe)
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=34595
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 6 fangxun 2011-03-01 00:42:54 UTC
chris, I unable to find the fixed commit 764a90023080dd6aadcf4b57163844fd8f6ca803.
Comment 7 Chris Wilson 2011-03-01 01:43:38 UTC
Oops, left it on the wrong machine. Pushed upstream as 6ddfb322f58c7e00db73e25689ee55ffa1111bd9
Comment 8 fangxun 2011-03-01 19:27:32 UTC
Verified with mesa master commit 6ddfb322f58c7e00db73e25689ee55ffa1111bd9.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.