Bug 34968 - Bad fps in Lightsmark benchmark
Bad fps in Lightsmark benchmark
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86 (IA32) Linux (All)
: high normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-03 03:53 UTC by Md Imam Hossain
Modified: 2011-05-27 08:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Md Imam Hossain 2011-03-03 03:53:12 UTC
Just released Mesa 7.10.1
Official Ubuntu 10.10 Xorg
Linux 2.6.36-02063603-generic

In some areas of Lightsmark 2008 benchmark fps is not as good as older more stable Mesa versions such as Mesa 7.7.1, 7.8.3-rc1, 7.9-series.

some like half fps.
Comment 1 Gordon Jin 2011-03-03 17:08:13 UTC
What's your hardware? resolution?
Comment 2 Md Imam Hossain 2011-03-03 18:06:33 UTC
Software:

Ubuntu 10.10
Linux 2.6.36-02063603-generic
Official Ubuntu Xorg
libdrm-2.4.22 release
xf86-video-intel 2.13.0 release
Mesa 7.10.1

Hardware:
Intel Dual Core 2.20 GHz
RAM 3 GB
Intel GMA 4500M 256 MB
Comment 3 Md Imam Hossain 2011-03-03 18:10:44 UTC
Three major bugs for Mesa 7.10.1, kicking me back to stay with Mesa 7.8.3-rc1

Bug 32949 - cannot play Windows games with WINE with GLSL enabled
This bug itself - which I guess has performance impact on other games
Bug 33926 - I do not know other Linux native games are affected by this bug
Comment 4 Chris Wilson 2011-03-04 12:12:26 UTC
And please include the actual measurements.

commit d1fc920f613aa349e6721963e22e12c6eb49e3f9
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Tue Mar 1 11:15:34 2011 -0800

    intel: Support glCopyTexImage() from ARGB8888 to XRGB8888.
    
    Nexuiz was hitting a software fallback.

also fixes a fallback that Lightsmark was hitting. And Lightsmark is also sensitive to libgomp.so, so make sure you are using the same version of the compiler whilst comparing.
Comment 5 Md Imam Hossain 2011-03-04 20:34:51 UTC
still low at beginning and other areas as well, like before with patched Mesa 7.10.1.
but I do not know about libgomp.so, which version I have to use and how to compare. I did not compile libgomp.so, it comes with Ubuntu 10.10.
Comment 6 Md Imam Hossain 2011-04-18 21:16:38 UTC
Closing the bug, since the bug is not verifiable.
Comment 7 Md Imam Hossain 2011-05-06 06:58:44 UTC
After playing with Mesa for 3 hours, I found that

Mesa 7.10.1 and Mesa 7.11-devel (mesa git) has this bug:

what: LightsMark: http://dee.cz/lightsmark/
benchmark has half fps in some areas (like 5 fps but before that was 11 fps).

This bug was not present in Mesa 7.9 series but 7.10.
This bug was fixed by that commit 1991d92207cf629ba4ceead4bfc3f768d7b9e402
https://bugs.freedesktop.org/show_bug.cgi?id=32995

but reintroduced by commit 0f7325b89038937bd428f7c89ed9859189a0ab0b
http://cgit.freedesktop.org/mesa/mesa/commit/?id=0f7325b89038937bd428f7c89ed9859189a0ab0b

If I revert this commit in Mesa 7.10 and Mesa 7.11-devel then everything becomes normal again like before with Mesa 7.9 (11 fps).

Thank you.
Comment 8 Md Imam Hossain 2011-05-19 07:07:16 UTC
changing importance to high so that this issue does not effect other programs
Comment 9 Eric Anholt 2011-05-27 08:22:08 UTC
commit 615117ce4efd041459f7d4b0c77aa8e248345e66
Author: Eric Anholt <eric@anholt.net>
Date:   Mon May 23 09:12:07 2011 -0700

    i965/fs: Track fixed GRF regs separate from allocated GRF file in scheduling.
    
    There's an assumption here that fixed GRFs will never intersect with
    the allocated GRFs.  That's true today, though it might change some
    day if we decide to register-allocate the regs containing push
    constants once they're dead.
    
    This fixes a regression in 0f7325b89038937bd428f7c89ed9859189a0ab0b in
    Lightsmark from the texture instructions now containing g0 references
    instead of having that be implied.  Performance is improved 15.2% +/-
    3.6% (n=3).
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=34968