Bug 3498 - Password required on document that opens without using Acrobat
Password required on document that opens without using Acrobat
Status: RESOLVED FIXED
Product: poppler
Classification: Unclassified
Component: general
unspecified
x86 (IA32) FreeBSD
: high major
Assigned To: poppler-bugs
:
: 53917 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-08 13:44 UTC by Daniel Stone
Modified: 2012-08-22 09:47 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
testcase (68.80 KB, application/pdf)
2010-10-01 19:35 UTC, Jose Aliste
Details
Patch fixing the issue. (859 bytes, patch)
2012-08-04 00:57 UTC, Jose Aliste
Details | Splinter Review
My take on fixing the bug (545 bytes, patch)
2012-08-04 14:01 UTC, Albert Astals Cid
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-08 13:44:39 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=301498
------------------------------------------------------------
Please describe the problem:
The following document opens fine with adobe acrobat but evince states that it
is locked and requires a password:

http://ucfv.ca/ar/200505/UCFVTimetable.pdf

The link is from http://ucfv.ca/ar

Note that GPDF does this as well; I've not tried XPDF yet - so I'm not sure if
this is a "default" password with adobe or whether evince is sharing a bug with
GPDF.

Steps to reproduce:
1. Open http://ucfv.ca/ar/200505/UCFVTimetable.pdf with evince.
2. 
3. 


Actual results:
Evince asks for a password to open the document.

Expected results:
Evince should just open the document.

Does this happen every time?
Yes.

------------------------------------------------------------

A little more info; acrobat reader states "security method is password security"
--- odd considering it opens without typing one, and that it is a public 
document.

------------------------------------------------------------

Here's my test w/ xpdf.  It printed that stuff out, then asked me for a
password, I hit [OK] and it wouldn't let me see the document.  

[clarkbw@rhbw bin]$ xpdf UCFVTimetable.pdf
Error: Unsupported version/revision (4/4) of Standard security handler
Error: Couldn't read xref table

Acroread 5 couldn't open the document.  It popped up an error about decrypting 
it.

[clarkbw@rhbw bin]$ pdf2ps UCFVTimetable.pdf
****This file uses an unknown standard security handler revision: 4
Error: /undefined in pdf_check_user_password

------------------------------------------------------------

I'm using version 7 to read it.  The site says version 6 is required - I 
couldn't read it with 5.

------------------------------------------------------------
Comment 1 Kristian Høgsberg 2006-03-28 10:24:09 UTC
Looks like comments, attachments and reported information got lost during the
disk crash - closing.
Comment 2 Elijah Newren 2006-06-10 11:13:50 UTC
According to http://bugzilla.gnome.org/show_bug.cgi?id=301498, this was just the
upstream copy of that bug.  Comments from that bug:

-Comment 0-
The following document opens fine with adobe acrobat but evince states that it
is locked and requires a password:

http://ucfv.ca/ar/200505/UCFVTimetable.pdf

The link is from http://ucfv.ca/ar

Note that GPDF does this as well; I've not tried XPDF yet - so I'm not sure if
this is a "default" password with adobe or whether evince is sharing a bug with
GPDF.

Steps to reproduce:
1. Open http://ucfv.ca/ar/200505/UCFVTimetable.pdf with evince.

-Comment 4-
Here's my test w/ xpdf.  It printed that stuff out, then asked me for a
password, I hit [OK] and it wouldn't let me see the document.  

[clarkbw@rhbw bin]$ xpdf UCFVTimetable.pdf
Error: Unsupported version/revision (4/4) of Standard security handler
Error: Couldn't read xref table

Acroread 5 couldn't open the document.  It popped up an error about decrypting it.

[clarkbw@rhbw bin]$ pdf2ps UCFVTimetable.pdf
****This file uses an unknown standard security handler revision: 4
Error: /undefined in pdf_check_user_password

-Comment 6-
I'm using [acrobat] version 7 to read it.  The site says version 6 is required -
I couldn't read it with 5.

-Gnome bug 321152-
Apparently also happens with another file that reporter gives this info on:

I have a link to pdf file. You can download it from rapidshare.
It is a book. Not very legal, you know ;-) 

http://rapidshare.de/files/6809105/toni_natahaus.ru_.rar.html

mirror:
http://www.megaupload.com/?d=WP2K15C2"

-Gnome bug 344497-
Apparently also happens with this file: 
http://www.highpoint-tech.com/manuals/RR2300_UM_EN_1.0_031306.pdf
Comment 4 Feng JIANG 2007-04-04 23:53:46 UTC
(In reply to comment #2)
> Link to another similar documents
> http://formeradvent.temp.powweb.com/Proclamacion06_1_2.pdf
> http://www.islenska.de./pdf/Islenska.de_Preiskrieg%20in%20Island.pdf

I ran into this problem days ago, and it persists on latest version of Evince version (0.8.0). Some webpages say this problem has not been solved yet.

Although the first document mentioned is not available now, one shared thing between the second document and mine is that: they both allow viewing without password, but some operations (e.g.: printing) are password-protected. Adobe Reader (for Linux and Windows) seems to handle these documents quite well, but Evince don't. So I guess if this bug is caused by incomplete implementation of pdf security management somewhere in poppler?

Hope this helpful.
Comment 5 Brad Hards 2007-10-27 01:10:51 UTC
There weren't a lot of useable samples in this bug, but 
http://www.islenska.de./pdf/Islenska.de_Preiskrieg%20in%20Island.pdf
and 
http://www.highpoint-tech.com/manuals/RR2300_UM_EN_1.0_031306.pdf

both work with the Qt4 test tool.

Please advise if this is still a problem
Comment 6 Benjamin Close 2008-01-11 02:37:09 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 7 Mark Trompell 2008-12-02 04:40:33 UTC
I wonder if these documents are protected by Adobe Lifecycle management.
Acroread 8.1.2 asks to accept to connect to such a server, who knows if older versions sid just silently connect.
Evince asks for a password for such documents.
Comment 8 Jose Aliste 2010-10-01 19:35:16 UTC
Created attachment 39110 [details]
testcase

New test case of a file with password security that opens in acrobat  and does not open in evince.  Originally reported in https://bugzilla.gnome.org/show_bug.cgi?id=631144
Comment 9 Albert Astals Cid 2010-10-03 02:06:30 UTC
Problem in document from #8 is that it uses AESV3 encryption that we do not support
Comment 10 sonicwarrior 2011-10-07 04:15:19 UTC
This bug is 6 years old and still not fixed?

Additional examples (I'm using Ubuntu 10.10/AMD64 with libpoppler 0.14.3/evince 2.32.0):

http://www.jlmaudio.com/Baby%20Animal%20Mic%20Pre%20with%20JLM14%20&%20OPA2604.pdf

http://www.jlmaudio.com/Baby%20Animal%20Mic%20Pre%20PCB%20Full%20Circuit.pdf
Comment 11 Albert Astals Cid 2012-08-03 14:19:01 UTC
Seems to work with poppler 0.20
Comment 12 Jan Kratochvil 2012-08-03 14:36:47 UTC
It still requires password and fails to open the attachment 39110 [details]
with poppler-0.20.1-2.fc18.x86_64 and evince-3.5.4-2.fc18.x86_64.
Comment 13 Albert Astals Cid 2012-08-03 14:51:03 UTC
Something is broken in the glib frontend, using qt4/tests/test-poppler-qt4 renders the like like a charm
Comment 14 Jose Aliste 2012-08-04 00:57:50 UTC
Created attachment 65106 [details] [review]
Patch fixing the issue.

Indeed, currently the glib frontend passes a NULL pointer as password when creating the Doc, while the qt4 frontend passes an empty Goostring.

So it seems that the file in the comment 8 actually needs an empty password, instead of not needing one... 

So, the patch attached makes the glib frontend to behave as the qt4 frontend and fixes the issue.
Comment 15 Jan Kratochvil 2012-08-04 06:15:47 UTC
For evince one cannot enter an empty password. With the Comment 14 patch it really works, without asking for any password, thanks. It requires patched poppler-0.20. Patched popppler-0.18 still did not work ("Weird encryption info").

I found even with xpdf and poppler-0.18 it works, just one has to click empty password.  But even with poppler-0.20 from Comment 14 xpdf asks for password and non-empty password does not work; this is not acceptable for users, is it a bug of xpdf or can it be fixed in poppler? This is xpdf regression against Adobe Acrobat Reader.

       0.18  0.18+patch 0.20  0.20+patch
evince FAIL  FAIL       FAIL  PASS
xpdf   EMPTY EMPTY      EMPTY EMPTY
PASS  = opened without asking anything
FAIL  = cannot open (probably because one cannot enter empty password)
EMPTY = opened but one has to click empty password; not acceptable for users
Comment 16 Albert Astals Cid 2012-08-04 13:44:26 UTC
Jan, we do not develop xpdf nor xpdf uses poppler, so i don't really understand your question at all.
Comment 17 Albert Astals Cid 2012-08-04 14:01:32 UTC
Created attachment 65121 [details] [review]
My take on fixing the bug

Jose, i'd prefer to commit this patch since this way we also fix the utils that have the same problem the glib frontend has (passing null null as passwords).

What do you think?
Comment 18 Jan Kratochvil 2012-08-04 14:29:28 UTC
(In reply to comment #16)
> Jan, we do not develop xpdf nor xpdf uses poppler, so i don't really understand
> your question at all.

OK, true, sorry, I got confused by Fedora xpdf dependency on poppler-utils.
Comment 19 Jose Aliste 2012-08-04 14:43:00 UTC
Albert, I agree that fixing it in core is bettter, so please go ahead. And thanks for asking.
Comment 20 Albert Astals Cid 2012-08-05 13:10:03 UTC
Pushed.
Comment 21 Albert Astals Cid 2012-08-22 09:47:24 UTC
*** Bug 53917 has been marked as a duplicate of this bug. ***