Bug 35165 - [SNB]Flashing spots come out when running Enemy-territory
[SNB]Flashing spots come out when running Enemy-territory
Status: VERIFIED DUPLICATE of bug 39730
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
All Linux (All)
: medium major
Assigned To: Kenneth Graunke
Depends on:
  Show dependency treegraph
Reported: 2011-03-09 17:06 UTC by meng
Modified: 2015-05-18 05:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

The photo for screen mess (41.39 KB, image/jpeg)
2011-03-09 17:11 UTC, meng
Xorg (20.00 KB, text/plain)
2011-03-09 17:11 UTC, meng

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2011-03-09 17:06:13 UTC
System Environment:
Platform:  SNB
Libdrm:    (master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:      (7.10)3ed9054cc598a38d2cbcadd3f81943635148514c
Xserver:   (master)xorg-server-1.10.0
Kernel:    (drm-intel-fixes) 91355834646328e7edc6bd25176ae44bcd7386c7 

Bug detailed description:
When running enemy-territory, flashing spots come out and some trees become dimness possibly on SNB. And it could work normally again sometimes.It works fine on Piketon.It also existed on 2010Q4 release.Pls see attached photo.

Reproduce steps:
1. start X
2. run enemy-territory
Comment 1 meng 2011-03-09 17:11:23 UTC
Created attachment 44291 [details]
The photo for screen mess
Comment 2 meng 2011-03-09 17:11:57 UTC
Created attachment 44292 [details]
Comment 3 Joel 2011-07-31 18:21:35 UTC
A wild guess (N.B.) of mine is that this is caused by mesa doing some error with z-coordinates. In meng's screenshot it's seen as sky being mixed over the tree's texture, in a checkerbox pattern.

I've observed similar pattern on trees in Neverwinter nights, but it's much more visible on certain overlapping items on the ground. For example I can see through rugs and other flat textures easily. But other geometries are less affected. (I have a good screenshot of this available if anyone is interested)

The pattern is also not constant in NWN, but changes all the time like unstable pixels.
Comment 4 Joel 2011-08-30 04:48:05 UTC

*** This bug has been marked as a duplicate of bug 39730 ***