Bug 39730 - [SNB] flickering pixels in supertuxkart characters
Summary: [SNB] flickering pixels in supertuxkart characters
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 35165 39732 39733 40544 41893 41993 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-01 15:09 UTC by Benjamin Hodgetts
Modified: 2012-01-25 01:53 UTC (History)
19 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Minecraft (524.12 KB, image/jpeg)
2011-08-01 15:09 UTC, Benjamin Hodgetts
Details
Warcraft 3 (838.26 KB, image/jpeg)
2011-08-20 02:59 UTC, Benjamin Hodgetts
Details
SuperTuxKart (216.35 KB, image/jpeg)
2011-08-20 03:00 UTC, Benjamin Hodgetts
Details
Spring Engine (NOTA) (608.18 KB, image/jpeg)
2011-08-20 03:02 UTC, Benjamin Hodgetts
Details
Warzone 2100 (368.87 KB, image/jpeg)
2011-08-20 03:03 UTC, Benjamin Hodgetts
Details
Screencap of artifact that still exists after quick solution (629.40 KB, image/png)
2011-11-09 20:41 UTC, Austin Holbrook
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Hodgetts 2011-08-01 15:09:35 UTC
Created attachment 49803 [details]
Minecraft

All the blocks in the world seem to have what look like crawling black ants on them, specifically around the edges (this is also happening in other games, not just Minecraft).

System environment: 
-- chipset: Sandybridge (HD3000)
-- system architecture: 64-bit
-- xf86-video-intel: 2.15.0
-- xserver: 1.10.3
-- mesa: 7.11
-- libdrm: 7.11
-- kernel: 3.0
-- Linux distribution: Arch
-- Machine or mobo model: Dell XPS 15 L502X
-- Display connector: LVDS
Comment 1 Benjamin Hodgetts 2011-08-01 15:26:13 UTC
Forgot to mention that the game runs unplayably slow, 2fps or so. Not sure if it's related as the hardware is clearly enough to cope.
Comment 2 Austin Holbrook 2011-08-19 21:08:46 UTC
Bug affects me as well. Happens in other games, but seems to show up the worst in Minecraft.
Comment 3 Benjamin Hodgetts 2011-08-20 02:44:38 UTC
*** Bug 39732 has been marked as a duplicate of this bug. ***
Comment 4 Benjamin Hodgetts 2011-08-20 02:44:45 UTC
*** Bug 39733 has been marked as a duplicate of this bug. ***
Comment 5 Benjamin Hodgetts 2011-08-20 02:59:14 UTC
Created attachment 50393 [details]
Warcraft 3
Comment 6 Benjamin Hodgetts 2011-08-20 03:00:46 UTC
Created attachment 50394 [details]
SuperTuxKart
Comment 7 Benjamin Hodgetts 2011-08-20 03:02:18 UTC
Created attachment 50395 [details]
Spring Engine (NOTA)
Comment 8 Benjamin Hodgetts 2011-08-20 03:03:24 UTC
Created attachment 50396 [details]
Warzone 2100
Comment 9 Benjamin Hodgetts 2011-08-20 03:04:29 UTC
Just adding to this list, I've found that this bug affects:

Minecraft
Stunt Racer
Spring (the 3D TA remake engine)
SuperTuxKart (specifically certain karts)
Warzone 2100

I'm sure there are many others but that should be sufficient for now.
Comment 10 Benjamin Hodgetts 2011-08-20 05:00:40 UTC
Also can be seen on the leaves and the back of the players head in UT2004.
Comment 11 Austin Holbrook 2011-08-23 16:11:31 UTC
Issue is not fixed in 7.11. It also happens across all distros that I've tried.
Comment 12 Benjamin Hodgetts 2011-08-23 16:25:13 UTC
This bug is logged against 7.11 ;)  (it just doesn't let you select it in the drop-down list).

It's still an issue with current GIT too.
Comment 13 Joel 2011-08-30 04:48:05 UTC
*** Bug 35165 has been marked as a duplicate of this bug. ***
Comment 14 Joel 2011-08-30 05:00:41 UTC
I've observed that the artifacts can be temporary removed by the debugfs API on my affected game.

mkdir /tmp/debugfs
mount -t debugfs /tmp/debugfs /tmp/debugfs
echo 1 > /tmp/debugfs/dri/0/i915_wedged

Could be a clue?
Comment 15 Austin Holbrook 2011-08-31 18:27:57 UTC
I noticed that installing the AdventureCraft mod for Minecraft actually prevents this from happening. Every now and then you can see the artifacts, but they quickly disappear.
Comment 16 Joel 2011-09-01 17:59:01 UTC
*** Bug 40544 has been marked as a duplicate of this bug. ***
Comment 17 Eric Anholt 2011-09-02 19:53:15 UTC
I'm deciding that this bug report is now only about SuperTuxKart, so we can focus on that.  It may all be related, but talk about the other apps will only serve as a distraction from solving the problem.

Steps to reproduce:
1) start supertuxkart
2) choose "race"
3) mouseover the purple bird character
4) Observe flickering pixels

By forcing alphatest off (brw_draw.c: smash ctx->Color.AlphaEnabled to false), the flickering goes away.  Most of the alpha-enabled drawing in the app uses (GL_GREATER, 0.0), while the two failing characters use (GL_GREATER, 0.5).  Switching to GL_ALWAYS doesn't workaround, nor does disabling the alpha test bit in the CC unit.  always_flush_batch=true does not workaround, either.
Comment 18 Eric Anholt 2011-09-02 20:08:43 UTC
Smashing the fb write to have an alpha of 1.0 also doesn't affect the problem, though it does show off the ways the app uses the alpha test.
Comment 19 Joel 2011-09-03 03:19:33 UTC
Some trial and error on my end revealed that it's enough to remove ctx->Color.AlphaEnabled from the test in:

In mesa/drivers/dri/i965/gen6_wm_state.c
if (fp->program.UsesKill || ctx->Color.AlphaEnabled)
   dw5 |= GEN6_WM_KILL_ENABLE;
Comment 20 Joel 2011-09-03 03:36:43 UTC
((forgot to say that above is no fix as it introduce other artifacts))
Comment 21 Austin Holbrook 2011-09-08 13:50:22 UTC
Any updates on the bug? And should a bug be filed against the Intel drivers?
Comment 22 Eric Anholt 2011-09-09 11:37:28 UTC
Interesting.  After a fresh reboot, I wasn't able to reproduce the problem until I ran Minecraft and looked at its artifacts for a while, at which point supertuxkart's artifacts came back.
Comment 23 Austin Holbrook 2011-09-12 19:31:02 UTC
The flickering pixels are kind of hit and miss for me. While they almost always appear in Minecraft, they don't always appear in the other games.
Comment 24 Victor Machado 2011-09-28 10:27:12 UTC
So there is no fix to this bug? I'm with all the git drivers and this error don't go away.
Comment 25 Austin Holbrook 2011-09-28 20:15:18 UTC
So far, it doesn't look like we have much information as to what's causing the problem. Might be tricky to see what's happening. I really hope that a fix is found, as this is driving me insane.
Comment 26 Victor Machado 2011-10-01 09:16:39 UTC
I do not know much about language C but I found this in mesa git, which seems to be related to our problem: http://cgit.freedesktop.org/mesa/mesa/commit/?id=367020d87ce8c27aeb58b3887fbd29d216fdc151
Comment 27 Austin Holbrook 2011-10-04 21:49:27 UTC
I don't know much about C either, but hopefully posting another comment will get some attention to this bug.

I'm surprised this isn't affecting more people honestly. It seems like it would be easy to run into if you have a Sandy Bridge processor.
Comment 28 Victor Machado 2011-10-05 16:38:14 UTC
(In reply to comment #27)
> I don't know much about C either, but hopefully posting another comment will
> get some attention to this bug.
> 
> I'm surprised this isn't affecting more people honestly. It seems like it would
> be easy to run into if you have a Sandy Bridge processor.

I think all people with our video card, are being affected by this problem but seem to not realize it yet as we have seen does not affect all programs. Frankly most people who use linux do not seek to use it for games, for that reason I think the fix for this bug will not be released soon by the fact that hardly anyone will notice this bug.
Comment 29 Felix Stürmer 2011-10-13 00:29:24 UTC
Two new Thinkpad Laptops I have are affected by the same issue, in minecraft as well as in other games. Recently I added

i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1

as kernel boot parameters to reduce the power consumption of these laptops. Interestingly, this seemed to reduce the frequency and duration of these artifacts. While they used to remain until I shut down the program, they now tend to disappear again after a few seconds.

The system specs of one of the machines are:

System:    Host: skadi Kernel: 3.0-ARCH x86_64 (64 bit) Desktop Xfce 4.8.3 Distro: Arch Linux
Machine:   System: LENOVO product: 429136G version: ThinkPad X220
           Mobo: LENOVO model: 429136G Bios: LENOVO version: 8DET41WW (1.11 ) date: 03/28/2011
CPU:       Dual core Intel Core i7-2620M CPU (-HT-MCP-) clocked at 800.00 MHz 
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller 
           X.Org: 1.11.1 driver: intel Resolution: 1366x768@60.1hz
           GLX: Mesa DRI Intel Sandybridge Mobile GLX Version: 2.1 Mesa 7.11

If I can help with any more information or testing, please let me know.
Comment 30 Austin Holbrook 2011-10-13 20:26:55 UTC
(In reply to comment #29)
> Two new Thinkpad Laptops I have are affected by the same issue, in minecraft as
> well as in other games. Recently I added
> 
> i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1
> 
> as kernel boot parameters to reduce the power consumption of these laptops.
> Interestingly, this seemed to reduce the frequency and duration of these
> artifacts. While they used to remain until I shut down the program, they now
> tend to disappear again after a few seconds.
> 
> The system specs of one of the machines are:
> 
> System:    Host: skadi Kernel: 3.0-ARCH x86_64 (64 bit) Desktop Xfce 4.8.3
> Distro: Arch Linux
> Machine:   System: LENOVO product: 429136G version: ThinkPad X220
>            Mobo: LENOVO model: 429136G Bios: LENOVO version: 8DET41WW (1.11 )
> date: 03/28/2011
> CPU:       Dual core Intel Core i7-2620M CPU (-HT-MCP-) clocked at 800.00 MHz 
> Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics
> Controller 
>            X.Org: 1.11.1 driver: intel Resolution: 1366x768@60.1hz
>            GLX: Mesa DRI Intel Sandybridge Mobile GLX Version: 2.1 Mesa 7.11
> 

The behavior you're describing is what I was experiencing with the 2.6.39 kernel. The artifacts got noticably worse after upgrading to 3.x.
> If I can help with any more information or testing, please let me know.
Comment 31 Victor Machado 2011-10-15 18:06:25 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > Two new Thinkpad Laptops I have are affected by the same issue, in minecraft as
> > well as in other games. Recently I added
> > 
> > i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1
> > 
> > as kernel boot parameters to reduce the power consumption of these laptops.
> > Interestingly, this seemed to reduce the frequency and duration of these
> > artifacts. While they used to remain until I shut down the program, they now
> > tend to disappear again after a few seconds.
> > 
> > The system specs of one of the machines are:
> > 
> > System:    Host: skadi Kernel: 3.0-ARCH x86_64 (64 bit) Desktop Xfce 4.8.3
> > Distro: Arch Linux
> > Machine:   System: LENOVO product: 429136G version: ThinkPad X220
> >            Mobo: LENOVO model: 429136G Bios: LENOVO version: 8DET41WW (1.11 )
> > date: 03/28/2011
> > CPU:       Dual core Intel Core i7-2620M CPU (-HT-MCP-) clocked at 800.00 MHz 
> > Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics
> > Controller 
> >            X.Org: 1.11.1 driver: intel Resolution: 1366x768@60.1hz
> >            GLX: Mesa DRI Intel Sandybridge Mobile GLX Version: 2.1 Mesa 7.11
> > 
> 
> The behavior you're describing is what I was experiencing with the 2.6.39
> kernel. The artifacts got noticably worse after upgrading to 3.x.
> > If I can help with any more information or testing, please let me know.

So our problem aren't in mesa drivers? Let's try change the kernel for old versions, or dev versions.
Comment 32 Austin Holbrook 2011-10-16 13:52:21 UTC
(In reply to comment #31)
> So our problem aren't in mesa drivers? Let's try change the kernel for old
> versions, or dev versions.

It's unlikely that it isn't a bug with mesa, but something between kernel versions seems to have worsened the effect.
Comment 33 Joel 2011-10-25 02:07:34 UTC
*** Bug 41993 has been marked as a duplicate of this bug. ***
Comment 34 Joel 2011-10-25 02:09:37 UTC
*** Bug 41893 has been marked as a duplicate of this bug. ***
Comment 35 Eric Anholt 2011-11-07 18:22:32 UTC
We finally isolated the issue by cutting down the "fire" demo to a minimal case and poking around at that.  Proposed patch is at:

http://lkml.indiana.edu/hypermail/linux/kernel/1111.0/02876.html

You can apply that patch to test (and a Tested-by: would be appreciated if it fixes it), or as a one-shot fix you can try "sudo intel_reg_write 0x9404 0x00001000" from intel-gpu-tools (in any reports on success/failure of this test, please note which you tried.  Also, the intel_reg_write workaround doesn't appear to take effect until your GPU has gone thoroughly idle for a while.
Comment 36 Alejandro Lorenzo 2011-11-08 01:28:52 UTC
I have applied the proposede patch over Linux 3.1 kernel and it seems to solve the issues i reported on flightgear (#40544) 

I will test it more these days, however. 

Thank you very much ! :)
Comment 37 Michael Groh 2011-11-08 01:47:19 UTC
I have also applied that patch (onto the 3.1-rc6+ drm-intel-next) and it fixes my problems with Minecraft on Sandybridge.

If you want to, you can add my tested-by:

Michael "brot" Groh <brot@minad.de>

Thanks for your help Eric!
Comment 38 denstark 2011-11-08 08:09:32 UTC
I attempted to run the one-off fix but it came back with an error:

[tstella@elmdor ~]$ sudo intel_reg_write 0x9404 0x00001000
Couldn't map MMIO region: No such file or directory


xserver: 1.11.1.902
mesa 7.11-4
libdrm 2.4.27-1
kernel: 3.0
distro: Arch
Comment 39 Kenneth Graunke 2011-11-08 10:55:35 UTC
I'm pretty sure the "Couldn't map MMIO region" error from intel_reg_write means your intel-gpu-tools is too old.  We haven't done a release of that in a while, so you might need to install it from git.  Or, just try the kernel patch (which is now upstream in Keith's drm-intel-next tree.)
Comment 40 Victor Machado 2011-11-09 08:01:48 UTC
Applying the patch on kernel 3.2-rc1 works for me, thanks to your help Eric. =D
Comment 41 Victor Machado 2011-11-09 13:23:14 UTC
Sorry for the hasty reply, but the benchmarks Unigine Tropics and Sanctuary continue the mistakes of pixels. But Heroes Of NewerEarth SuperTuxKart and were corrected.
Comment 42 Austin Holbrook 2011-11-09 20:30:50 UTC
It fixed the issues in Minecraft for me. And, seems to have improved the performance slightly. I still notice weird artifacts in other applications once Minecraft starts running, but this is far less annoying than the other bug.

xorg-server - 1.11.2
mesa - 7.11
libdrm - 2.4.27
kernel - 3.1.0-4-ARCH
distro - Arch 64bit
Comment 43 Austin Holbrook 2011-11-09 20:41:52 UTC
Created attachment 53359 [details]
Screencap of artifact that still exists after quick solution

Sorry about the double reply. Here is a screenshot of some of the artifacts that still exist. I didn't apply the patch; I used the one-line solution, if it makes any difference.
Comment 44 Ricky Brent 2011-11-10 15:34:38 UTC
Running on Ubunut Ocelot (11.10) and a T420S (i5-2520M) -- I grabbed the latest intel-gpu-tools from git first to avoid the "Couldn't map MMIO region" error, then did:
 sudo ./intel_reg_write 0x9404 0x00001000

This entirely fixes the transparent pixel issues for me. (The main Minecraft guy's hand flickers briefly into a triangle now and then, but that's nothing by comparison.) 

Tons of thanks, Eric Anholt -- I'm using it for a pretty trivial purpose, but I'm really excited to be able to play games again. :)

System information:
-- chipset: Sandybridge (HD3000)
-- system architecture: 64-bit
-- xf86-video-intel: 2.15.0
-- xserver: 1.10.4
-- kernel: 3.0
Comment 45 windowsdowninthewinter 2011-11-15 08:36:55 UTC
This problem persists for me.

I think the version of Mesa I have already implements the patch mentioned. I also tried the 'one shot' solution with no luck.


ben@monitor:~$ uname -a
Linux monitor 3.1.1-030101-generic #201111111651 SMP Fri Nov 11 21:52:29 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux


ben@monitor:~$ cat /proc/cpuinfo
model name	: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid

motherboard is a zotac

any more info much appreciated (want to play minecraft on my new computer)


ben
Comment 46 farciarz 2011-11-15 09:00:52 UTC
One-shot solution doesn't work for me.
Warcraft 3 is not playable :/ Still pixels flickering

I have to use Nvidia GPU (it works ok)

Linux Mint 12 RC1.


2011/11/15 <bugzilla-daemon@freedesktop.org>

> https://bugs.freedesktop.org/show_bug.cgi?id=39730
>
> --- Comment #45 from windowsdowninthewinter@hush.com 2011-11-15 08:36:55
> PST ---
> This problem persists for me.
>
> I think the version of Mesa I have already implements the patch mentioned.
> I
> also tried the 'one shot' solution with no luck.
>
>
> ben@monitor:~$ uname -a
> Linux monitor 3.1.1-030101-generic #201111111651 SMP Fri Nov 11 21:52:29
> UTC
> 2011 x86_64 x86_64 x86_64 GNU/Linux
>
>
> ben@monitor:~$ cat /proc/cpuinfo
> model name    : Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
> flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
> cmov
> pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx
> rdtscp lm
> constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc
> aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr
> pdcm
> sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts
> dts
> tpr_shadow vnmi flexpriority ept vpid
>
> motherboard is a zotac
>
> any more info much appreciated (want to play minecraft on my new computer)
>
>
> ben
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 47 Victor Machado 2011-11-15 09:44:45 UTC
(In reply to comment #45)
> This problem persists for me.
> 
> I think the version of Mesa I have already implements the patch mentioned. I
> also tried the 'one shot' solution with no luck.
> 
> 
> ben@monitor:~$ uname -a
> Linux monitor 3.1.1-030101-generic #201111111651 SMP Fri Nov 11 21:52:29 UTC
> 2011 x86_64 x86_64 x86_64 GNU/Linux
> 
> 
> ben@monitor:~$ cat /proc/cpuinfo
> model name    : Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
> flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
> pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm
> constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc
> aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm
> sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts
> tpr_shadow vnmi flexpriority ept vpid
> 
> motherboard is a zotac
> 
> any more info much appreciated (want to play minecraft on my new computer)
> 
> 
> ben

Hello buddy, you have to apply the patch on kernel source not on mesa. Try the patch, he works for me.
Comment 48 Michael Gratton 2011-11-15 16:06:42 UTC
Can the people reporting they still have this problem comment on the following:

1. Did they apply the fix from just the first patch, or both?
2. If using the one-shot fix, did they execute the command before launching the app/game?

The second patch is found on the same thread as the first:

1st: http://lkml.indiana.edu/hypermail/linux/kernel/1111.0/02876.html
2nd: http://lkml.indiana.edu/hypermail/linux/kernel/1111.0/02877.html

The one-shot fix command that is equivalent to both patches is:

  sudo intel_reg_write 0x9404 0x00001800

(Note that the second value is 0x1800, not 0x1000)

Also note that the one-shot fix does not survive a logout, reboot, or resume from suspend/hibernate.
Comment 49 Joel 2011-11-18 07:43:03 UTC
I've successfully mitigated all flickering pixels using the one-shot fix in all games I currently have installed. (Supertuxkart, Neverwinter Nights and Vdrift)

I've not tested patching the kernel for it yet.

Some observations:

If the problems had already appeared, the one-shot fix would not help the situation. It required a reboot or simulating a gpu wedging (i915_wedged, to trigger some kind of reset) before the flickering would disappear. Disclaimer: Observation made using the previous, /wrong/ 1000 number.

I do however get more full solid flickers now, especially on shadows in Neverwinter Nights at certani camera angles. In supertuxkart it's much more rare, but sometimes kart flicker there. Tire tracks flicker more often, but I'm not sure this is a driver problem yet.
Comment 50 windowsdowninthewinter 2011-11-19 16:08:51 UTC
(In reply to comment #47)
> (In reply to comment #45)
> > This problem persists for me.
> > 
> > I think the version of Mesa I have already implements the patch mentioned. I
> > also tried the 'one shot' solution with no luck.
> > 
> > 
> > ben@monitor:~$ uname -a
> > Linux monitor 3.1.1-030101-generic #201111111651 SMP Fri Nov 11 21:52:29 UTC
> > 2011 x86_64 x86_64 x86_64 GNU/Linux
> > 
> > 
> > ben@monitor:~$ cat /proc/cpuinfo
> > model name    : Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
> > flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
> > pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm
> > constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc
> > aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm
> > sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts
> > tpr_shadow vnmi flexpriority ept vpid
> > 
> > motherboard is a zotac
> > 
> > any more info much appreciated (want to play minecraft on my new computer)
> > 
> > 
> > ben
> 
> Hello buddy, you have to apply the patch on kernel source not on mesa. Try the
> patch, he works for me.

ok how does i?
Comment 51 Chris Lord 2011-11-21 02:07:02 UTC
Just to note, the temporary fix of running 'intel_reg_write 0x9404 0x00001800' fixes the crawling transparent pixels for me, but does not fix the various other glitches while running Minecraft (sporadic junk textures and incorrect texture coordinates appearing everywhere (including in applications outside of Minecraft)) - This probably ought to be a separate bug.
Comment 52 farciarz 2011-11-21 08:33:49 UTC
intel_reg_write 0x9404 0x00001800 do the job for me,

I would like to install new kernel, can anybody tell me why 32-bit version is not avaiable http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/current/ ?
Comment 53 Nicholas Rempel 2011-12-02 13:17:34 UTC
I'm just chiming in to say that the command 'intel_reg_write 0x9404 0x00001800' does fix this problem for me.  Like Chris Lord said, though, there are still some other problems.
Comment 54 Austin Holbrook 2011-12-03 16:20:46 UTC
Can anyone see if the kernel patch solves the various other graphical glitches? Otherwise, the problem isn't entirely solved.
Comment 55 Konstantin Keller 2011-12-30 09:03:56 UTC
I was just wondering how I would install the kernel patch or where I could get a newer version of intel-gpu-tools because I get the MMIO error too.
Comment 56 Kenneth Graunke 2012-01-05 17:48:52 UTC
For what it's worth, the patches are included in the 3.2 kernel which was just released.  So you could use that.
Comment 57 Konstantin Keller 2012-01-05 17:51:51 UTC
(In reply to comment #56)
> For what it's worth, the patches are included in the 3.2 kernel which was just
> released.  So you could use that.

Yeah, I realized that now when I compiled my own version of 3.2. Thanks, it works now!
Comment 58 Kenneth Graunke 2012-01-25 01:53:56 UTC
Closing this bug.  We believe the primary issue here is fixed in the Linux 3.2 kernel, and many people seem to agree.  I'm guessing most of the people who had trouble were either trying to use intel_reg_write had trouble patching the kernel.

It sounds like a few people still have rendering glitches in various apps; feel free to open new bug reports and we'll take a look at them.  I think that will be clearer and more useful for everyone than keeping this bug report open.  Thanks for your patience.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.