Bug 36917 - Rendering glitches in ETQW
Summary: Rendering glitches in ETQW
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-06 12:27 UTC by Sven Arvidsson
Modified: 2011-06-18 07:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot (167.58 KB, image/jpeg)
2011-05-06 12:27 UTC, Sven Arvidsson
Details
Model rendered too bright (201.09 KB, image/jpeg)
2011-06-12 13:12 UTC, Sven Arvidsson
Details
Trees on the "Island" map (258.50 KB, image/jpeg)
2011-06-12 13:13 UTC, Sven Arvidsson
Details
[PATCH] r600g: fix RSQ to use abs value of operand on evergreen (1.29 KB, patch)
2011-06-16 21:54 UTC, Vadim Girlin
Details | Splinter Review
[PATCH] r600g: fix LIT to handle src==dst properly (1.35 KB, patch)
2011-06-17 13:13 UTC, Vadim Girlin
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2011-05-06 12:27:14 UTC
Created attachment 46406 [details]
Screenshot

The texture on the rotating globe in the menu of Enemy Territory Quake Wars isn't rendering correctly. Screenshot is attached.

System environment:
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- GPU: REDWOOD
-- Model: XFX Radeon HD 5670 1GB
-- Display connector: DVI
-- xf86-video-ati: 6.14.1
-- xserver: 1.10.1
-- mesa: 27d3e0b25cc3f2bd9f72778f0c9f54cb90c48622
-- drm: 2.4.25
-- kernel: 2.6.39-rc5
Comment 1 Sven Arvidsson 2011-06-12 13:12:49 UTC
Created attachment 47875 [details]
Model rendered too bright

It looks like ETQW suffers from a few other rendering glitches. The characters in the team selection seems to be rendered too bright (but are fine in-game), and trees on the map "Island" looks quite funky.

I'm not sure if this is the same problems found in bug 35434.
Comment 2 Sven Arvidsson 2011-06-12 13:13:30 UTC
Created attachment 47876 [details]
Trees on the "Island" map
Comment 3 Sven Arvidsson 2011-06-14 05:16:54 UTC
Rendering of trees (and water) is fixed on master, but broken on non-evergreen, see bug 38280.
Comment 4 Andy Furniss 2011-06-16 08:42:54 UTC
(In reply to comment #1)
> Created an attachment (id=47875) [details]
> Model rendered too bright
> 
> It looks like ETQW suffers from a few other rendering glitches. The characters
> in the team selection seems to be rendered too bright (but are fine in-game),
> and trees on the map "Island" looks quite funky.

I tested with my 4890 and the globe renders OK, but the menu model is too bright.

I've no idea when this started as I normally test in spectate mode or timenetdemo - so don't usually see it.
Comment 5 Sven Arvidsson 2011-06-16 10:22:54 UTC
(In reply to comment #4)
> 
> I tested with my 4890 and the globe renders OK, but the menu model is too
> bright.

I guess the globe is evergreen-only then, thanks for testing and commenting.

> I've no idea when this started as I normally test in spectate mode or
> timenetdemo - so don't usually see it.

I've tried a few different older versions, but so far I haven't found one where the model renders rigth, so I'm not sure if it's a regression or not.
Comment 6 Vadim Girlin 2011-06-16 21:54:25 UTC
Created attachment 48072 [details] [review]
[PATCH] r600g: fix RSQ to use abs value of operand on evergreen

This patch should fix globe rendering on evergreen.
Comment 7 Sven Arvidsson 2011-06-17 05:38:56 UTC
(In reply to comment #6)
> Created an attachment (id=48072) [details]
> [PATCH] r600g: fix RSQ to use abs value of operand on evergreen
> 
> This patch should fix globe rendering on evergreen.

Confirmed, it's working fine now! :)
Comment 8 Sven Arvidsson 2011-06-17 12:24:42 UTC
(In reply to comment #4)
> I tested with my 4890 and the globe renders OK, but the menu model is too
> bright.
> 
> I've no idea when this started as I normally test in spectate mode or
> timenetdemo - so don't usually see it.

I poked around a bit more, and it turns out that this only happens when "Lightning quality" is set to normal, it seems to be okay when set to high.

Doesn't seem to be a regression, it's present as far back as when S3TC support first was added, and I don't think the game runs without it.
Comment 9 Andy Furniss 2011-06-17 13:02:35 UTC
(In reply to comment #8)
> (In reply to comment #4)
> > I tested with my 4890 and the globe renders OK, but the menu model is too
> > bright.
> > 
> > I've no idea when this started as I normally test in spectate mode or
> > timenetdemo - so don't usually see it.
> 
> I poked around a bit more, and it turns out that this only happens when
> "Lightning quality" is set to normal, it seems to be okay when set to high.
> 
> Doesn't seem to be a regression, it's present as far back as when S3TC support
> first was added, and I don't think the game runs without it.

Yea, it's OK with lighting high for me also.

Unfortunately setting high causes a rendering error for me - distant foliage is rendered black.
Comment 10 Vadim Girlin 2011-06-17 13:13:03 UTC
Created attachment 48117 [details] [review]
[PATCH] r600g: fix LIT to handle src==dst properly

> Unfortunately setting high causes a rendering error for me - distant foliage is
> rendered black.

This patch should fix it.
Comment 11 Andy Furniss 2011-06-17 13:59:58 UTC
(In reply to comment #10)
> Created an attachment (id=48117) [details]
> [PATCH] r600g: fix LIT to handle src==dst properly
> 
> > Unfortunately setting high causes a rendering error for me - distant foliage is
> > rendered black.
> 
> This patch should fix it.

It does, thanks.
Comment 12 Sven Arvidsson 2011-06-18 07:15:16 UTC
The patch has been merged to master, so let's close this bug. Thanks for all your work on this Vadim! :)

I'm going to open a new bug about the rendering glitch with lightning set to normal.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.