Bug 37392 - [bisected i965]10 oglc pbo subcases failed, with INTEL_STRICT_CONFORMANCE=1
[bisected i965]10 oglc pbo subcases failed, with INTEL_STRICT_CONFORMANCE=1
Status: CLOSED DUPLICATE of bug 28924
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: low normal
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-19 21:40 UTC by fangxun
Modified: 2012-10-26 08:44 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
pbo texImage.1PBODefaults output (3.84 KB, text/plain)
2011-05-19 21:40 UTC, fangxun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-05-19 21:40:31 UTC
Created attachment 46926 [details]
pbo texImage.1PBODefaults output

System Environment:
--------------------------
Arch:           x86-64
Platform:       piketon 
Libdrm: (master)2.4.25-1-g61be94018ae9c403517d53f69357719224fa6ff3
Mesa: (master)116133af3499947500a6d0c877fbc8f564ee4c76
Xserver:(master)xorg-server-1.10.0-376-g0e7f61d72c4a929319e57c9b5b777e9413c23051
Xf86_video_intel:  (master)2.15.0-17-g9d6e02a135efdea1d169d1938359ab2b553e941c
Kernel: (drm-intel-next)daab1470018f025e0b1c8731dfb825ff421ffd9b

Bug detailed description:
-------------------------
Below cases failed on Sandybridge and Ironlake.
pbo(texImage.1PBODefaults), pbo(texImage.1PBOBufferSubData),
pbo(texImage.1PBOBufferMapping), pbo(texImage.multiPBOsDefaults), 
pbo(texImage.multiPBOsBufferMapping), pbo(texImage.1PBOChangeOffset), 
pbo(texImage.1PBOChangeUsageType), pbo(texImage.1PBOChangeAccessType), 
pbo(texImage.1PBOChangeInternalFormat), pbo(texImage.1PBOChangeDataSize). 
 
Bisect shows b126a0c0cb30b1e2f2df1953fe14d8596d1cf4f7 is the first bad commit.
commit b126a0c0cb30b1e2f2df1953fe14d8596d1cf4f7
Author:     Eric Anholt <eric@anholt.net>
AuthorDate: Tue Nov 2 09:11:17 2010 -0700
Commit:     Eric Anholt <eric@anholt.net>
CommitDate: Wed May 18 13:57:17 2011 -0700

    i965: Add support for correct GL_CLAMP behavior by clamping coordinates.

    This removes the stupid strict-conformance fallback code I broke when
    adding ARB_sampler_objects.

    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=36572
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> (v1)


Reproduce steps:
-------------------------
1. start X
2. INTEL_STRICT_CONFORMANCE=1 oglconform -z -s -suite all -v 2 -D 33 -test pbo texImage.1PBODefaults
Comment 1 fangxun 2011-05-20 00:30:27 UTC
oglc case texedge also failed due to b126a0c0cb30b1e2f2df1953fe14d8596d1cf4f7.
Comment 2 Eric Anholt 2011-05-20 13:29:23 UTC
Can you confirm that the problem still exists before if you remove INTEL_STRICT_CONFORMANCE?  Ironlake border color handling is broken, so if you didn't have that software-fallback knob set, I expect these tests will fail beforehand as well.

(Please remove INTEL_STRICT_CONFORMANCE from testing.  We want QA to be testing the code paths that actual users experience, and as a result we're planning on just removing that environment variable since it's harmful to testing).
Comment 3 fangxun 2011-05-24 02:51:55 UTC
If remove INTEL_STRICT_CONFORMANCE, these cases always fail.
Comment 4 Gordon Jin 2011-05-24 19:32:24 UTC
Eric/Ian, I'm not pursuing this. Feel free to close it as wont fix.
Comment 5 Eric Anholt 2011-05-25 09:20:35 UTC

*** This bug has been marked as a duplicate of bug 28924 ***