Bug 38173 - DXT3 and DXT5 broken on Cayman gpu
Summary: DXT3 and DXT5 broken on Cayman gpu
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 42067 43954 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-10 17:55 UTC by Vladimir
Modified: 2012-02-11 08:00 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
proposed (633 bytes, patch)
2011-12-20 23:49 UTC, Andre Maasikas
Details | Splinter Review
test02 with applied patch (86.15 KB, image/jpeg)
2011-12-27 21:18 UTC, Alexandre Demers
Details
test02 without patch (128.36 KB, image/jpeg)
2011-12-27 21:24 UTC, Alexandre Demers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2011-06-10 17:55:24 UTC
Using linux 3.0-rc2 kernel and mesa@git-eca3e91 + ati-ddx from git

libtxc_dxtn is also installed.

Radeon 6970 using g3d driver.
 
Runing texcmp test from demos.

DXT1 works fine, DXT3 and DXT5 gives broken image (on both ARGB and RGB modes)

same corruptions can be seen in sauerbraten menu (image on bg - corrupted) or in quake4, unigine tropics.

exactly same system with 6870 gpu - dxt1, dxt3, dxt5 works fine.
Comment 1 Alex Deucher 2011-12-06 05:56:36 UTC
*** Bug 42067 has been marked as a duplicate of this bug. ***
Comment 2 Alexandre Demers 2011-12-20 15:33:46 UTC
*** Bug 43954 has been marked as a duplicate of this bug. ***
Comment 3 Andre Maasikas 2011-12-20 23:49:55 UTC
Created attachment 54625 [details] [review]
proposed

Here's a thing to try ( we should set non_disp_tiling in CB for > 128bpp formats)
Makes UINT32 FLOAT32 work a bit better here.
There's still some alignment issues at small mipsizes thoug
Comment 4 Harald Judt 2011-12-21 02:34:25 UTC
I confirm that the patch helps with the problem. The textures start to look recognizable again, but parts of them are still displaced or corrupted.
Comment 5 Alexandre Demers 2011-12-27 21:18:15 UTC
Created attachment 54878 [details]
test02 with applied patch

Result with patch applied, there is still visual errors: matrix is not correctly ordered
Comment 6 Alexandre Demers 2011-12-27 21:24:12 UTC
Created attachment 54879 [details]
test02 without patch

This the result without the patch applied.
Comment 7 Alexandre Demers 2011-12-27 21:33:54 UTC
The expected image should be like Test02 from this serie:
http://unbirthgame.com/files/feat_test_images_round2.jpg

I hope this will help you in better figuring out other changes and fixes needed.
Comment 8 Alexandre Demers 2012-02-05 17:48:37 UTC
I'm adding an apitrace of RendererFeatTest64 is you want to play with it:
http://www.mediafire.com/?mnlmwe6x4j305zm
Comment 9 Andre Maasikas 2012-02-10 09:02:04 UTC
agd5f has commited patches which should fix this
5e1495b2d9311fa2b320766a1d299053904bd9c3
and
acca690c259824636ef1ff684a10bd1caca4751f
these may also appear in stable branches sometime
Comment 10 Alexandre Demers 2012-02-10 22:06:49 UTC
It seems to be rendering correctly now for me. Textures and texts that were corrupted are now fine.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.