Bug 42067 - [r600g] Compiz overlay icons corrupted on cayman (buggy s3tc support)
Summary: [r600g] Compiz overlay icons corrupted on cayman (buggy s3tc support)
Status: RESOLVED DUPLICATE of bug 38173
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-20 10:13 UTC by Harald Judt
Modified: 2011-12-06 05:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot with a corrupted terminal emblem. (28.34 KB, image/png)
2011-10-20 10:13 UTC, Harald Judt
no flags Details
Screenshot with a corrupted firefox emblem. (13.25 KB, image/png)
2011-10-20 10:14 UTC, Harald Judt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Judt 2011-10-20 10:13:58 UTC
Created attachment 52601 [details]
Screenshot with a corrupted terminal emblem.

Using compiz-0.8.8 ring switcher or scale plugins, the emblem icons (=icons at the lower right of the windows) are corrupted. They look fine on pre-cayman hardware. See the screenshot(s) attached.
Comment 1 Harald Judt 2011-10-20 10:14:35 UTC
Created attachment 52602 [details]
Screenshot with a corrupted firefox emblem.
Comment 2 Alex Deucher 2011-10-20 11:21:07 UTC
probably a duplicate of bug 38022 or bug 40221.
Comment 3 Harald Judt 2011-10-24 11:25:31 UTC
This was caused by enabling texture compression in core settings. Turning it off makes the icons look right again.
Comment 4 Harald Judt 2011-10-24 11:58:24 UTC
I think this might rather be a duplicate of bug 38173.
Comment 5 Harald Judt 2011-12-06 04:43:47 UTC
This problem is still there in linux-3.2-rc4, and clearly related to using s3tc libtxc_dxtn, as it does not happen when the library is not available.

Fixing this would also make it possible to play games on cayman gpus that require s3tc.
Comment 6 Alex Deucher 2011-12-06 05:56:36 UTC

*** This bug has been marked as a duplicate of bug 38173 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.