Bug 38440 - ETQW: Model in team select rendering too bright
ETQW: Model in team select rendering too bright
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
git
Other All
: medium normal
Assigned To: Default DRI bug account
:
: 37203 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-18 07:21 UTC by Sven Arvidsson
Modified: 2011-06-24 13:18 UTC (History)
0 users

See Also:


Attachments
screenshot of bug (201.09 KB, image/jpeg)
2011-06-18 07:21 UTC, Sven Arvidsson
Details
[PATCH] r600g: fragment/vertex color clamping (11.41 KB, patch)
2011-06-21 06:08 UTC, Vadim Girlin
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2011-06-18 07:21:10 UTC
Created attachment 48132 [details]
screenshot of bug

As previously mentioned in bug 36917, the game ETQW have a small rendering error in the team select menu. The model is rendered too bright when the setting "Lightning quality" is set to normal. There's no problem when the setting is changed to high.

This doesn't seem to be a regression as it is present as far back as when S3TC support was first added.

System environment:
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- GPU: REDWOOD
-- Model: XFX Radeon HD 5670 1GB
-- Display connector: DVI
-- xf86-video-ati: 6.14.2
-- xserver: 1.10.2
-- mesa: 2fe39b46e73aea37152777fe11d489e0b1bc3f92
-- drm: 2.4.25
-- kernel: 2.6.39.1
Comment 1 Andy Furniss 2011-06-21 03:26:36 UTC
(In reply to comment #0)
> Created an attachment (id=48132) [details]
> screenshot of bug
> 
> As previously mentioned in bug 36917, the game ETQW have a small rendering
> error in the team select menu. The model is rendered too bright when the
> setting "Lightning quality" is set to normal. There's no problem when the
> setting is changed to high.
> 
> This doesn't seem to be a regression as it is present as far back as when S3TC
> support was first added.

In addition to this one I have found another rendering error that only appears with lighting normal on my 4890.

On maps with sea - Island and Volacano, where the sky meets the sea there is a band of black/junk. It's thin from ground level, so best seen from high up.

Doesn't seem to be a regression, though I only went back to April.

My other settings are those you get with the high master setting + shadows on.
Comment 2 Vadim Girlin 2011-06-21 06:08:33 UTC
Created attachment 48227 [details] [review]
[PATCH] r600g: fragment/vertex color clamping

This patch should fix model brightness.
Comment 3 Sven Arvidsson 2011-06-21 06:49:32 UTC
(In reply to comment #2)
> 
> This patch should fix model brightness.

Indeed it does. Wow, you have really been rocking with all the fixes for r600g, thanks! :)



Andy, if the sky/sea issue isn't solved with this, can you post a screenshot?
Comment 4 Andy Furniss 2011-06-21 07:20:19 UTC
(In reply to comment #2)
> Created an attachment (id=48227) [details]
> [PATCH] r600g: fragment/vertex color clamping
> 
> This patch should fix model brightness.

It fixes both my issues with normal lighting on rv790 - thanks.
Comment 5 Sven Arvidsson 2011-06-23 13:38:31 UTC
I'm not sure what the procedure for this is, but it would be great if this patch would be merged in time for 7.11.
Comment 6 Sven Arvidsson 2011-06-24 12:00:28 UTC
*** Bug 37203 has been marked as a duplicate of this bug. ***
Comment 7 Sven Arvidsson 2011-06-24 13:18:37 UTC
commit eafd331cf3b024001abd3f64861f41cd33a9acb2
Author: Vadim Girlin <vadimgirlin@gmail.com>
Date:   Fri Jun 24 20:29:13 2011 +0400

    r600g: implement fragment and vertex color clamp
    
    Fixes https://bugs.freedesktop.org/show_bug.cgi?id=38440
    
    Signed-off-by: Vadim Girlin <vadimgirlin@gmail.com>