Bug 38447 - Can't emulate scroll wheel with two-button point stick
Summary: Can't emulate scroll wheel with two-button point stick
Status: RESOLVED DUPLICATE of bug 39174
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-18 09:25 UTC by Kirill A. Shutemov
Modified: 2012-11-16 18:57 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill A. Shutemov 2011-06-18 09:25:40 UTC
I have laptop HP EliteBook 8440p which has point stick and it's great. But unlike Thinkpad it had only two button. I want to emulate middle button and scroll whell on top of it. Is it possible?

I've tried following configuration:

$ xinput list-props 11    
Device 'PS/2 Generic Mouse':
        Device Enabled (125):   1
        Coordinate Transformation Matrix (127): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        Device Accel Profile (246):     0
        Device Accel Constant Deceleration (247):       1.000000
        Device Accel Adaptive Deceleration (248):       1.000000
        Device Accel Velocity Scaling (249):    10.000000
        Evdev Axis Inversion (250):     0, 0
        Evdev Axes Swap (252):  0
        Axis Labels (253):      "Rel X" (135), "Rel Y" (136)
        Button Labels (254):    "Button Left" (128), "Button Middle" (129), "Button Right" (130), "Button Wheel Up" (131), "Button Wheel Down" (132), "Button Horiz Wheel Left" (133), "Button Horiz Wheel Right" (134)
        Evdev Middle Button Emulation (255):    1
        Evdev Middle Button Timeout (256):      50
        Evdev Wheel Emulation (257):    1
        Evdev Wheel Emulation Axes (258):       6, 7, 4, 5
        Evdev Wheel Emulation Inertia (259):    10
        Evdev Wheel Emulation Timeout (260):    200
        Evdev Wheel Emulation Button (261):     2
        Evdev Drag Lock Buttons (262):  0

Debian sid.
Comment 1 Peter Hutterer 2011-06-19 21:14:53 UTC
if you mean emulate a middle button and then use that emulation as scroll trigger, then no, that won't work. evdev internally deals with real button numbers, not logical button numbers.
Comment 2 Kirill A. Shutemov 2011-06-20 03:52:15 UTC
And no plans to remove this restriction?
Comment 3 Peter Hutterer 2011-06-21 23:30:13 UTC
probably not, sorry. starting to emulate on top of emulated buttons opens a can of worms that I'd rather not deal with.
Comment 4 Eugene Syromyatnikov 2011-07-13 00:43:47 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=39174 may be this would be useful.
Comment 5 Peter Hutterer 2011-07-27 18:47:16 UTC
Deduplicating, one bug for this topic is enough.

*** This bug has been marked as a duplicate of bug 39174 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.