Bug 39174 - Support of both middle button and wheel emulation.
Summary: Support of both middle button and wheel emulation.
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL: http://paste.pocoo.org/show/338247/
Whiteboard:
Keywords:
: 38447 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-12 11:21 UTC by Eugene Syromyatnikov
Modified: 2018-08-10 20:54 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Support of both middle button and wheel emulation patch against debian's X.org evdev 2.3.2 (1.18 KB, patch)
2011-07-12 11:21 UTC, Eugene Syromyatnikov
no flags Details | Splinter Review
Support of both middle button and wheel emulation patch in 2.9.1 (2.16 KB, patch)
2015-03-23 09:41 UTC, ailin.nemui
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Syromyatnikov 2011-07-12 11:21:11 UTC
Created attachment 49021 [details] [review]
Support of both middle button and wheel emulation patch against debian's X.org evdev 2.3.2

This patch allows using of emulated middle button for wheel emulation (which is impossible otherwise).
Comment 1 Peter Hutterer 2011-07-27 18:47:16 UTC
*** Bug 38447 has been marked as a duplicate of this bug. ***
Comment 2 Peter Hutterer 2011-07-27 18:57:53 UTC
Review of attachment 49021 [details] [review]:

If you switch from queue to post for button events, you can get wrong
valuator data for those buttons (they may not have been parsed yet).
evdev always sends motion events out first, so if you move by x/y and click
in the same event, without the queue/post handling you'd get the click
followed by the move.


Also, this change would documentation in the man page as well as being a git-formatted patch as described here: http://wiki.x.org/wiki/Development/Documentation/SubmittingPatches
Comment 3 Leho Kraav (:macmaN :lkraav) 2012-11-16 19:02:19 UTC
Heya guys

I just spent a chunk of time trying to get this to work on my otherwise awesome Kensington Orbit Trackball and couldn't figure out why scrolling with the emulated button wouldn't trigger no matter what. I guess this bug and bug 38447 are the answer.

That being said, I'd really like to have this. Peter, you claim in bug 38447 that emulating scrolling on top of emulated buttons is potentially a worm can. Is anything changed in this regard maybe, with recent 1.13 and/or evdev 2.7+ developments?
Comment 4 Leho Kraav (:macmaN :lkraav) 2012-11-16 19:02:45 UTC
How far away from The Real Thing is Eugene's patch?
Comment 5 Leho Kraav (:macmaN :lkraav) 2012-11-17 09:04:43 UTC
In the meanwhile I found a workaround to achieve my desired functionality.
Comment 7 Peter Hutterer 2012-11-23 00:57:51 UTC
no updates on this feature. The original patch here was the wrong approach, it would mess with the posting of valuator data.

Again, I'm not keen on seeing this unless we have it well documented what the interaction is, and all combinations between wheel and middle button emulation in reproducible test cases so we know we don't introduce regressions.
Comment 8 ailin.nemui 2015-03-23 09:41:18 UTC
Created attachment 114545 [details] [review]
Support of both middle button and wheel emulation patch in 2.9.1

I attached an alternate patch for the benefit of people seeking for a resolution to this missing feature. It pipes the MB emu into the wheel Emu. This way would seem to cause the least interaction. I wrote more infos on http://lists.x.org/archives/xorg/2015-January/057119.html and http://anti.teamidiot.de/nei/2015/03/toshiba_z30_evdev_notes/
Comment 9 GitLab Migration User 2018-08-10 20:54:00 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-input-evdev/issues/1.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.