Bug 39218 - Cannot switch between integrated (Radeon 4200) and discrete (Radeon 6650M) on HP Pavilion dv6-6030er
Summary: Cannot switch between integrated (Radeon 4200) and discrete (Radeon 6650M) on...
Status: RESOLVED DUPLICATE of bug 37528
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/fglrx (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: atilinuxbugsunassigned
QA Contact: atilinuxbugsunassigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-14 01:57 UTC by kh3095
Modified: 2011-10-21 03:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kh3095 2011-07-14 01:57:45 UTC
I have a problem with switching between integrated Radeon 4200 and discrete Radeon 6600M (actually Radeon 6650M) on HP Pavilion dv6-6030er. In Win7 it is working properly, but in Debian GNU/Linux (testing) it doesn't work. Installed fglrx 11.6 (from unstable repository). There is an option in ATI Catalyst Control Center (amdccle) to switch between cards. It can be changed (and it asks to reboot), but after reboot or Xorg restart it returns back.

My lspci -nn: http://pastebin.com/VBWa10mt

My xorg.conf (created with aticonfig --initial): http://pastebin.com/ZkezxQ8H

My Xorg.0.log: http://pastebin.com/HCV6H9Um

Also I tried to change

BusID "PCI:1:5:0"

in my xorg.conf to

BusID "PCI:2:0:0"

(see my lspci -nn output). But after that I got segmentation fault: http://pastebin.com/6psjDc8S
Comment 1 kh3095 2011-07-14 03:30:57 UTC
Using Debian GNU/Linux testing.

fglrx: 11.6
xorg: 7.6+7
Comment 2 kh3095 2011-07-14 03:32:15 UTC
Linux kernel: 2.6.39+35.1
Comment 3 Oleg German 2011-10-21 03:31:17 UTC
AFAIK 6600m is muxless card

*** This bug has been marked as a duplicate of bug 37528 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.