Bug 41092 - [965gm] ringbuffer coherency failure upon resume
Summary: [965gm] ringbuffer coherency failure upon resume
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Daniel Vetter
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-21 13:13 UTC by Bryce Harrington
Modified: 2016-11-03 12:09 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (65.68 KB, text/plain)
2011-09-21 13:13 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (144.92 KB, text/plain)
2011-09-21 13:13 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (673.66 KB, text/plain)
2011-09-21 13:14 UTC, Bryce Harrington
no flags Details
XorgConf.txt (1.75 KB, text/plain)
2011-09-21 13:14 UTC, Bryce Harrington
no flags Details
XorgLog.txt (31.15 KB, text/plain)
2011-09-21 13:16 UTC, Bryce Harrington
no flags Details
gnoutchd-KernelLog.txt (163.01 KB, text/plain)
2012-02-18 21:36 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-i915_error_state.txt (673.65 KB, text/plain)
2012-02-18 21:36 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-intel_reg_dumper.txt (10.43 KB, text/plain)
2012-02-18 21:37 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-XorgLog.txt (32.80 KB, text/plain)
2012-02-18 21:38 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-vbios.dump (64.00 KB, application/octet-stream)
2012-02-18 21:39 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-v3.4-rc1+-i915_error_state (673.94 KB, text/plain)
2012-04-14 08:27 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-v3.4-rc1+-KernelLog.txt (105.45 KB, text/plain)
2012-04-14 08:28 UTC, Daniel Gnoutcheff
no flags Details
gnoutchd-v3.4-rc1+-intel_reg_dumper.txt (11.10 KB, text/plain)
2012-04-14 08:28 UTC, Daniel Gnoutcheff
no flags Details
Catch writes to address 0 (2.29 KB, patch)
2012-04-14 08:39 UTC, Chris Wilson
no flags Details | Splinter Review
i915_error_state on compaq 6720s (843.11 KB, text/plain)
2013-06-22 13:37 UTC, Björn Ruberg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-09-21 13:13:17 UTC
Forwarding this bug from Ubuntu reporter Damian Christey:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/850939

[Problem]
Initially this looks like a false GPU lockup, because it seems to mask the error, but then there is a 'fixme', followed immediately by a render ring initialization failure.  This appears to be going on during a resume from suspend.

[Original Description]
First time I've seen this one.

[14585.553826] PM: resume of drv:sd dev:2:0:0:0 complete after 485.400 msecs
[14585.553863] PM: resume of drv:scsi_disk dev:2:0:0:0 complete after 141.803 msecs
[14585.554026] PM: resume of drv:scsi_device dev:2:0:0:0 complete after 485.560 msecs
[14585.640171] firewire_core: rediscovered device fw0
[14585.700866] thinkpad_acpi: ACPI backlight control delay disabled
[14585.700874] render error detected, EIR: 0x00000010
[14585.700877] page table error
[14585.700878]   PGTBL_ER: 0x00000100
[14585.700881] [drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
[14585.700888] fixme: max PWM is zero.
[14585.700956] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 00000000 head 00000000 tail 00000000 start 00000000
[14585.702068] PM: resume of devices complete after 651.237 msecs
[14585.702248] PM: resume devices took 0.650 seconds
[14585.702295] PM: Finishing wakeup.
[14585.702297] Restarting tasks ... done.
[14585.716731] video LNXVIDEO:00: Restoring backlight state
[14585.860327] [drm] Changing LVDS panel from (+hsync, +vsync) to (-hsync, -vsync)
[14585.860483] ------------[ cut here ]------------
[14585.860518] WARNING: at /build/buildd/linux-3.0.0/drivers/gpu/drm/i915/intel_display.c:791 intel_enable_pipe+0x14a/0x150 [i915]()
[14585.860522] Hardware name: 6465CTO
[14585.860523] PLL state assertion failure (expected on, current off)
[14585.860525] Modules linked in: rfcomm bnep parport_pc ppdev snd_hda_codec_analog joydev thinkpad_acpi snd_seq_midi binfmt_misc snd_rawmidi snd_hda_intel snd_hda_codec snd_hwdep pcmcia arc4 snd_seq_midi_event snd_seq btusb iwl3945 iwl_legacy yenta_socket pcmcia_rsrc r852 sm_common nand nand_ids nand_bch mac80211 snd_pcm psmouse bluetooth bch nand_ecc pcmcia_core mtd i915 snd_seq_device serio_raw drm_kms_helper cfg80211 drm snd_timer snd_page_alloc snd i2c_algo_bit soundcore nvram wmi video tpm_tis firewire_sbp2 lp parport sdhci_pci sdhci firewire_ohci firewire_core crc_itu_t ahci libahci e1000e
[14585.860571] Pid: 7980, comm: kworker/u:31 Tainted: G        W   3.0.0-11-generic #17-Ubuntu
[14585.860574] Call Trace:
[14585.860583]  [<ffffffff8105e82f>] warn_slowpath_common+0x7f/0xc0
[14585.860587]  [<ffffffff8105e926>] warn_slowpath_fmt+0x46/0x50
[14585.860600]  [<ffffffffa01b27aa>] intel_enable_pipe+0x14a/0x150 [i915]
[14585.860613]  [<ffffffffa01b4a41>] i9xx_crtc_mode_set+0x6f1/0xd70 [i915]
[14585.860622]  [<ffffffffa018a893>] ? i915_enable_vblank+0x33/0x100 [i915]
[14585.860634]  [<ffffffffa01a8d2f>] intel_crtc_mode_set+0x6f/0xa0 [i915]
[14585.860642]  [<ffffffffa0171ff9>] drm_crtc_helper_set_mode+0x2a9/0x420 [drm_kms_helper]
[14585.860649]  [<ffffffffa01721e3>] drm_helper_resume_force_mode+0x73/0x160 [drm_kms_helper]
[14585.860665]  [<ffffffffa00babb3>] ? drm_irq_install+0x143/0x210 [drm]
[14585.860674]  [<ffffffffa0181146>] i915_reset+0x296/0x440 [i915]
[14585.860683]  [<ffffffffa0185ae0>] ? notify_ring+0xf0/0xf0 [i915]
[14585.860692]  [<ffffffffa0185ba8>] i915_error_work_func+0xc8/0x110 [i915]
[14585.860699]  [<ffffffff8107c05a>] process_one_work+0x11a/0x480
[14585.860702]  [<ffffffff8107cd25>] worker_thread+0x165/0x370
[14585.860705]  [<ffffffff8107cbc0>] ? manage_workers.isra.30+0x130/0x130
[14585.860709]  [<ffffffff810811cc>] kthread+0x8c/0xa0
[14585.860714]  [<ffffffff815f32e4>] kernel_thread_helper+0x4/0x10
[14585.860717]  [<ffffffff81081140>] ? flush_kthread_worker+0xa0/0xa0
[14585.860720]  [<ffffffff815f32e0>] ? gs_change+0x13/0x13
[14585.860722] ---[ end trace eaf1667dd518c105 ]---
<More backtraces in dmesg>

Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Chipset: i965gm
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Sep 13 14:12:51 2011
DistUpgraded: Log time: 2011-06-05 21:41:42.955296
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
MachineType: LENOVO 6465CTO
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=eda8e981-7ccb-44f8-bb03-01dbd64009e4 ro quiet splash vt.handoff=7
UpgradeStatus: Upgraded to oneiric on 2011-06-06 (101 days ago)
dmi.bios.date: 04/25/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETB7WW (2.17 )
dmi.board.name: 6465CTO
dmi.chassis.type: 10
dmi.modalias: dmi:bvnLENOVO:bvr7LETB7WW(2.17):bd04/25/2008:svnLENOVO:pn6465CTO:pvrThinkPadT61:rvnLENOVO:rn6465CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6465CTO
dmi.product.version: ThinkPad T61
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu3
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
Comment 1 Bryce Harrington 2011-09-21 13:13:41 UTC
Created attachment 51466 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-09-21 13:13:52 UTC
Created attachment 51467 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-09-21 13:14:06 UTC
Created attachment 51468 [details]
i915_error_state.txt
Comment 4 Bryce Harrington 2011-09-21 13:14:27 UTC
Created attachment 51469 [details]
XorgConf.txt
Comment 5 Bryce Harrington 2011-09-21 13:16:31 UTC
Created attachment 51470 [details]
XorgLog.txt
Comment 6 Daniel Gnoutcheff 2012-02-18 21:34:24 UTC
This bug seems to be the crash that I sometimes get when I resume my laptop from suspend.  Whenever I resume, the display will always turn on initially, usually with a still image from some framebuffer console.  Usually, the X server will then come to life after a short delay (e.g. with the unlock dialog from gnome-screensaver).  Other times, however, there is a longer delay, after which the display shuts off (blacklight and all).  The rest of the system remains functioning, and when I log in via ssh, I'll find the reported error messages in the kernel log.  The display remains inoperable even if I do an Xserver restart, a VT switch, another suspend/resume, or a hibernate/thaw.  A soft reboot, however, does reset the display.

distro: Ubuntu 11.10 amd64
kernel 3.0.0-16-generic
libdrm 2.4.26-1ubuntu1
mesa 7.11-0ubuntu3
xorg-server 2:1.10.4-1ubuntu4.2
xf86-video-intel 2:2.15.901-1ubuntu2.1
machine: Lenovo Thinkpad R61 7733A82

I've had about fourteen of these crashes in the past month and a half, and I've managed to collect debugging logs on most of them.  However, this bug has defeated all my attempts to deliberately reproduce it.  Sometimes I go for almost three weeks with no hangs, other times I get several hangs in one day. This may be related to changes in my usage patterns (how frequently I use suspend, how much time I waste on Youtube videos, etc.), but I haven't found any correlation yet, nor do I have any real idea of what to look for.

Some observations I have made so far:
-) Doing many suspend/resume cycles in a row (e.g. running pm-suspend 50 times in a script) is *not* sufficient to reproduce this bug.
-) I once attempted to reproduce this bug by opening a large number of windows/applications at once, with the hope that this would stress the graphics system.  However, it had no apparent effect on suspend/resume performance.
-) This bug does not seem to depend on the kernel version.  I've encountered these hangs with the 3.0.0 kernel shipped with 11.10, and I've also seen it with vanilla 2.6.38, 2.6.39, and 3.2.0 kernels.  However, I never encountered this bug when running Ubuntu 11.04 and its 2.6.38 kernel.  It would seem that userspace changes are key.
-) This bug does not seem to be affected by the use of OpenGL compositing managers: the crashes continued even when I switched from Unity to Unity2D.

I'll attach some logs from one of my most recent hangs.  I've added drm.debug=0x06 to my default kernel command line, which wastes syslog space but ensures that verbose logging is on when a hang hits. The kernel messages are from my syslog (from which I've pulled out irrelevant non-kernel messages). All of these logs were saved shortly after the hang (while I was logged in via ssh).

I've also set up some small scripts to collect logs and statistics with every suspend/resume, with the hope that this would help find what makes the difference between successful and unsuccessful suspends.  Right now I only save dumps from xwininfo and xrestop, for lack of a better idea.
Comment 7 Daniel Gnoutcheff 2012-02-18 21:36:06 UTC
Created attachment 57259 [details]
gnoutchd-KernelLog.txt
Comment 8 Daniel Gnoutcheff 2012-02-18 21:36:49 UTC
Created attachment 57260 [details]
gnoutchd-i915_error_state.txt
Comment 9 Daniel Gnoutcheff 2012-02-18 21:37:33 UTC
Created attachment 57261 [details]
gnoutchd-intel_reg_dumper.txt
Comment 10 Daniel Gnoutcheff 2012-02-18 21:38:20 UTC
Created attachment 57262 [details]
gnoutchd-XorgLog.txt
Comment 11 Daniel Gnoutcheff 2012-02-18 21:39:07 UTC
Created attachment 57263 [details]
gnoutchd-vbios.dump
Comment 12 Daniel Gnoutcheff 2012-03-02 18:59:39 UTC
FWIW, I disabled DRI with
  Option "DRI" "false"
in xorg.conf, but I still got a hang just now.  That would seem to confirm that this regression is not related to the mesa driver.

This is still with the xserver-xorg-video-intel package shipped with Ubuntu oneric (2:2.15.901-1ubuntu2.1).  I'll see about re-testing with updated versions of everything.
Comment 13 Daniel Gnoutcheff 2012-03-12 14:23:48 UTC
This bug is still present on Ubuntu precise (12.04) beta.  The relevant package versions are:

kernel: 3.2.0-18.29
libdrm2: 2.4.30-1ubuntu1
libgl1-mesa-glx: 8.0.1-0ubuntu2
xserver-xorg: 1:7.6+10ubuntu1
xserver-xorg-video-intel: 2:2.17.0-1ubuntu4
Comment 14 Chris Wilson 2012-03-26 01:44:50 UTC
I believe these are all related to the underlying bug:

commit c501ae7f332cdaf42e31af30b72b4b66cbbb1604
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Wed Dec 14 13:57:23 2011 +0100

    drm/i915: Only clear the GPU domains upon a successful finish
    
    By clearing the GPU read domains before waiting upon the buffer, we run
    the risk of the wait being interrupted and the domains prematurely
    cleared. The next time we attempt to wait upon the buffer (after
    userspace handles the signal), we believe that the buffer is idle and so
    skip the wait.
    
    There are a number of bugs across all generations which show signs of an
    overly haste reuse of active buffers.
    
    Such as:
    
      https://bugs.freedesktop.org/show_bug.cgi?id=29046
      https://bugs.freedesktop.org/show_bug.cgi?id=35863
      https://bugs.freedesktop.org/show_bug.cgi?id=38952
      https://bugs.freedesktop.org/show_bug.cgi?id=40282
      https://bugs.freedesktop.org/show_bug.cgi?id=41098
      https://bugs.freedesktop.org/show_bug.cgi?id=41102
      https://bugs.freedesktop.org/show_bug.cgi?id=41284
      https://bugs.freedesktop.org/show_bug.cgi?id=42141
    
    A couple of those pre-date i915_gem_object_finish_gpu(), so may be
    unrelated (such as a wild write from a userspace command buffer), but
    this does look like a convincing cause for most of those bugs.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: stable@kernel.org
    Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    Reviewed-by: Eugeni Dodonov <eugeni.dodonov@intel.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Comment 15 Gordon Jin 2012-04-01 01:57:39 UTC
to mark dup to show relationship
Comment 16 Gordon Jin 2012-04-01 01:58:00 UTC

*** This bug has been marked as a duplicate of bug 29046 ***
Comment 17 Daniel Gnoutcheff 2012-04-12 17:07:59 UTC
NAK, it appears that the referenced commit does *not* fix this bug.  I just had another one of these crashes with v3.4-rc1 despite the fact that it contains this commit.
Comment 18 Chris Wilson 2012-04-14 06:35:46 UTC
Without the recent error-state I can't confirm that you experienced the same crash.
Comment 19 Daniel Gnoutcheff 2012-04-14 08:27:31 UTC
Created attachment 59973 [details]
gnoutchd-v3.4-rc1+-i915_error_state
Comment 20 Daniel Gnoutcheff 2012-04-14 08:28:13 UTC
Created attachment 59974 [details]
gnoutchd-v3.4-rc1+-KernelLog.txt
Comment 21 Daniel Gnoutcheff 2012-04-14 08:28:53 UTC
Created attachment 59975 [details]
gnoutchd-v3.4-rc1+-intel_reg_dumper.txt
Comment 22 Daniel Gnoutcheff 2012-04-14 08:32:41 UTC
error-state and logs attached as requested.  The running kernel was compiled from commit v3.4-rc1-271-g5d32c88
Comment 23 Chris Wilson 2012-04-14 08:39:56 UTC
Created attachment 59976 [details] [review]
Catch writes to address 0

Ok, somebody overwrite the ring-buffer. Just check you don't have the gallium-965 driver installed and try this patch which will hopefully catch the culprit.
Comment 24 Chris Wilson 2012-04-14 08:46:59 UTC
Wait a sec... Does this hang almost immediately upon boot? I'd been assuming the values were reset due to a failure during the hang, but on the other hand, we might be not flushing the ringbuffer correctly.
Comment 25 Chris Wilson 2012-04-14 08:50:26 UTC
Can you try:

diff --git a/drivers/gpu/drm/i915/intel_ringbuffer.c b/drivers/gpu/drm/i915/inte
index 041f144..8e632a5 100644
--- a/drivers/gpu/drm/i915/intel_ringbuffer.c
+++ b/drivers/gpu/drm/i915/intel_ringbuffer.c
@@ -928,6 +928,10 @@ int intel_init_ring_buffer(struct drm_device *dev,
        if (ret)
                goto err_unref;
 
+       ret = i915_gem_object_set_to_gtt_domain(obj, true);
+       if (ret)
+               goto err_unpin;
+
        ring->map.size = ring->size;
        ring->map.offset = dev->agp->base + obj->gtt_offset;
        ring->map.type = 0;
Comment 26 Daniel Gnoutcheff 2012-04-14 13:24:05 UTC
--- Comment #24 from Chris Wilson<chris@chris-wilson.co.uk>  2012-04-14 
08:46:59 PDT ---
> Wait a sec... Does this hang almost immediately upon boot?

As I described in comment 6, this is a hang that occasionally happens 
immediately after resume from suspend.

I've applied the patch in comment 25 on top of v3.4-rc2-333-g668ce0a and 
I am trying it now.  It doesn't seem to have broken anything, but since 
this hang is rare, unpredictable, and (at present) not reliably 
reproducible, I can't say with confidence that the bug is fixed until 
I've run it for at least a month.

All of my remarks in comment 6 still hold true.  I'm still hoping to 
find a way to quickly reproduce this, but at present, I know nothing at 
all about computer graphics, so I'm stuck behind a huge learning curve.
Comment 27 Daniel Gnoutcheff 2012-06-01 19:33:49 UTC
OK, I am reasonably confident that the patch from comment 25 fixes this bug.

 From April 14th to May 22ed, I made sure to use a kernel that contained 
that patch, and I never had any post-resume hangs during that period. 
As an experiment, I then reverted the patch, and it didn't take long to 
get another post-resume hang.  So the application of that patch strongly 
correlates with the absence of these hangs.

Looks good to me. :D
Comment 28 Marcos Dione 2012-06-02 08:30:32 UTC
I manage to constantly hit a similar bug with following setup:

(mostly current Debian Sid versions)

kernels: 2.6.39-1/2/3, 3.0.0-2, 3.1.8-2, 3.2.18, 3.2.19
xserver-xorg-video-intel: 2.18.0-2+b1
libdrm2/libdrm-intel1: 2.4.33-1
ufoai: 2.3.1-1~getdeb1 [from getdeb.net]

how to reproduce: launch ufo, select single player game, skirmish, start game. the 3d terrain shows up, but after a few seconds (I woulds say 2-5) it hangs, creen goes black and one or two seconds after music stops. the machine is still reachable by ssh.

dmesg says:

[  151.976045] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[  151.976052] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[  151.977046] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 4402 at 4395, next 4419)
[  151.977213] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 00000000 head 00000000 tail 00000000 start 00000000
[  151.977542] [drm] Changing LVDS panel from (+hsync, +vsync) to (-hsync, -vsync)
[  151.977695] ------------[ cut here ]------------
[  151.977717] WARNING: at /build/buildd-linux-2.6_2.6.39-1-i386-RRBuT6/linux-2.6-2.6.39/debian/build/source_i386_none/drivers/gpu/drm/i915/intel_display.c:1079 intel_enable_pipe+0x59/0xfa [i915]()
[  151.977720] Hardware name: Inspiron 1420                   
[  151.977722] PLL state assertion failure (expected on, current off)
[  151.977724] Modules linked in: cryptd aes_i586 aes_generic ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi fuse coretemp firewire_sbp2 loop sr_mod cdrom usbhid hid ata_generic snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm option usb_wwan snd_page_alloc r852 sm_common usbserial snd_seq_midi nand snd_seq_midi_event ata_piix nand_ecc i915 uhci_hcd ehci_hcd usbcore snd_rawmidi nand_ids snd_seq arc4 ecb mtd iwl3945 tg3 drm_kms_helper snd_seq_device snd_timer firewire_ohci snd battery ac dell_wmi sparse_keymap joydev pcspkr drm i2c_i801 iwl_legacy i2c_algo_bit dell_laptop mac80211 firewire_core i2c_core crc_itu_t cfg80211 power_supply soundcore wmi rfkill psmouse processor video button sdhci_pci iTCO_wdt libphy sdhci serio_raw mmc_core dcdbas iTCO_vendor_support evdev ext3 mbcache jbd raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor xor async_tx raid6_pq raid1 raid0 multipath linear md_mod sd_mod crc_t10dif ahci libahci libata scsi_mod thermal thermal_sys
[  151.977811] Pid: 153, comm: kworker/u:1 Not tainted 2.6.39-1-686-pae #1
[  151.977813] Call Trace:
[  151.977819]  [<c1036b3d>] ? warn_slowpath_common+0x6a/0x7b
[  151.977830]  [<f85e6292>] ? intel_enable_pipe+0x59/0xfa [i915]
[  151.977833]  [<c1036bb4>] ? warn_slowpath_fmt+0x28/0x2c
[  151.977844]  [<f85e6292>] ? intel_enable_pipe+0x59/0xfa [i915]
[  151.977857]  [<f85ea4a7>] ? intel_crtc_mode_set+0x14bb/0x157e [i915]
[  151.977866]  [<f85d229f>] ? i915_read32+0x18/0x21 [i915]
[  151.977877]  [<f85e31e1>] ? i915_write32+0x1b/0x27 [i915]
[  151.977886]  [<f875757c>] ? drm_crtc_helper_set_mode+0x1e3/0x31a [drm_kms_helper]
[  151.977894]  [<f8757701>] ? drm_helper_resume_force_mode+0x4e/0x1cf [drm_kms_helper]
[  151.977904]  [<f85d41e5>] ? i915_hangcheck_elapsed+0x1ab/0x1ab [i915]
[  151.977913]  [<f85cf6cb>] ? i915_reset+0x3c6/0x3d8 [i915]
[  151.977922]  [<f85d2c89>] ? i915_error_work_func+0x9d/0xd5 [i915]
[  151.977931]  [<c104838c>] ? process_one_work+0x181/0x25e
[  151.977940]  [<f85d2bec>] ? i915_get_vblank_counter+0x95/0x95 [i915]
[  151.977943]  [<c1049d18>] ? worker_thread+0xf3/0x1f4
[  151.977946]  [<c1049c25>] ? manage_workers+0x15a/0x15a
[  151.977949]  [<c104c4e8>] ? kthread+0x63/0x68
[  151.977952]  [<c104c485>] ? kthread_worker_fn+0x114/0x114
[  151.977956]  [<c12b757e>] ? kernel_thread_helper+0x6/0x10
[  151.977959] ---[ end trace 1f85d66eea7ec4fb ]---

then the block between [cut-here] and [end-trace] repeats untill I reboot in kernels form 2.6.39-3 and newer, or just a few times and then:


[  153.556552] [drm:i915_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling

in older kernels. I hadn't tried the patch yet.
Comment 29 Daniel Gnoutcheff 2012-06-02 13:24:28 UTC
--- Comment #28 from Marcos Dione<mdione@grulic.org.ar>  2012-06-02 
08:30:32 PDT ---
> how to reproduce: launch ufo, select single player game, skirmish, start game.
> the 3d terrain shows up, but after a few seconds (I woulds say 2-5) it hangs,
> creen goes black and one or two seconds after music stops. the machine is still
> reachable by ssh.

Thanks for the report, Marcos.  Does it hang happen every time you run 
the game?  I was not able to reproduce the hang that way, even without 
the patch from comment 25.  Of course, I have different userspace 
(Ubuntu 12.04 amd64 with playdeb's ufoai) and different hardware (Lenovo 
ThinkPad R61 7733A82).
Comment 30 Chris Wilson 2012-06-02 14:07:11 UTC
(In reply to comment #28)
> I manage to constantly hit a similar bug with following setup:
> 
> (mostly current Debian Sid versions)
> 
> kernels: 2.6.39-1/2/3, 3.0.0-2, 3.1.8-2, 3.2.18, 3.2.19
> xserver-xorg-video-intel: 2.18.0-2+b1
> libdrm2/libdrm-intel1: 2.4.33-1
> ufoai: 2.3.1-1~getdeb1 [from getdeb.net]
> 
> how to reproduce: launch ufo, select single player game, skirmish, start game.
> the 3d terrain shows up, but after a few seconds (I woulds say 2-5) it hangs,
> creen goes black and one or two seconds after music stops. the machine is still
> reachable by ssh.

Marcus, I expect that you have a distinct bug caused a defect in mesa trigged by the game. Can you please open a new bug and attach your dmesg, Xorg.0.log and critically the /sys/kernel/debug/dri/0/i915_error_state following the hang.
Comment 31 Daniel Vetter 2012-06-05 01:57:18 UTC
Patch merged to -fixes as:

commit 3eef8918ff440837f6af791942d8dd07e1a268ee
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Jun 4 17:05:40 2012 +0100

    drm/i915: Mark the ringbuffers as being in the GTT domain

Thanks a lot for reporting this bug.
Comment 32 Björn Ruberg 2013-06-22 13:35:10 UTC
I'm seeing this bug on a compaq 6720s laptop after having upgraded the CPU from celeron-550 to core2duo t7100 half a year ago. It nearly always makes the laptop unuseable after logging in to a desktop environment (no matter which one).

Im running Fedora 18, specifically with kernel 3.9.6 and xorg-x11-drv-intel 2.21.8. libdrm 2.4.45, xorg-x11-server-Xorg 1.13.3 .

Find i915_error_state attached, dmesg follows.

[   37.587352] cgroup: libvirtd (791) created nested cgroup for controller "memory" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[   37.587357] cgroup: "memory" requires setting use_hierarchy to 1 on the root.
[   37.587428] cgroup: libvirtd (791) created nested cgroup for controller "devices" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[   37.587496] cgroup: libvirtd (791) created nested cgroup for controller "blkio" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[   45.093808] fuse init (API version 7.21)
[   64.704072] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[   64.704107] [drm] capturing error event; look for more information in/sys/kernel/debug/dri/0/i915_error_state
[   64.710181] ------------[ cut here ]------------
[   64.710263] WARNING: at drivers/gpu/drm/i915/intel_display.c:1051 intel_enable_pipe+0xe7/0x190 [i915]()
[   64.710270] Hardware name: HP Compaq 6720s
[   64.710274] PLL state assertion failure (expected on, current off)
[   64.710278] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   64.710401] Pid: 1372, comm: upowerd Tainted: PF          O 3.9.6-200.fc18.x86_64 #1
[   64.710406] Call Trace:
[   64.710423]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   64.710432]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   64.710481]  [<ffffffffa00b2e97>] intel_enable_pipe+0xe7/0x190 [i915]
[   64.710523]  [<ffffffffa00b7157>] i9xx_crtc_mode_set+0xb37/0x13a0 [i915]
[   64.710565]  [<ffffffffa00b588e>] __intel_set_mode+0x5be/0x970 [i915]
[   64.710610]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   64.710653]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   64.710702]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   64.710744]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   64.710757]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   64.710767]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   64.710778]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   64.710786]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   64.710797]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   64.710803] ---[ end trace 1b0e79d86bdac02b ]---
[   65.207098] [drm:i915_reset] *ERROR* Failed to reset chip.
[   65.217578] ------------[ cut here ]------------
[   65.217621] WARNING: at drivers/gpu/drm/i915/intel_display.c:1051 intel_enable_pipe+0xe7/0x190 [i915]()
[   65.217624] Hardware name: HP Compaq 6720s
[   65.217626] PLL state assertion failure (expected on, current off)
[   65.217628] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   65.217683] Pid: 1372, comm: upowerd Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   65.217685] Call Trace:
[   65.217694]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   65.217699]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   65.217720]  [<ffffffffa00b2e97>] intel_enable_pipe+0xe7/0x190 [i915]
[   65.217738]  [<ffffffffa00b47bd>] i9xx_crtc_enable+0x19d/0x310 [i915]
[   65.217757]  [<ffffffffa00b5a38>] __intel_set_mode+0x768/0x970 [i915]
[   65.217777]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   65.217796]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   65.217818]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   65.217837]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   65.217844]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   65.217848]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   65.217853]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   65.217857]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   65.217862]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   65.217865] ---[ end trace 1b0e79d86bdac02c ]---
[   65.268045] ------------[ cut here ]------------
[   65.268086] WARNING: at drivers/gpu/drm/i915/intel_display.c:1228 assert_pipe+0x102/0x110 [i915]()
[   65.268089] Hardware name: HP Compaq 6720s
[   65.268092] pipe B assertion failure (expected on, current off)
[   65.268093] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   65.268149] Pid: 1372, comm: upowerd Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   65.268151] Call Trace:
[   65.268160]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   65.268164]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   65.268185]  [<ffffffffa00b3442>] assert_pipe+0x102/0x110 [i915]
[   65.268204]  [<ffffffffa00b45b3>] intel_enable_plane+0x33/0xa0 [i915]
[   65.268222]  [<ffffffffa00b47cb>] i9xx_crtc_enable+0x1ab/0x310 [i915]
[   65.268240]  [<ffffffffa00b5a38>] __intel_set_mode+0x768/0x970 [i915]
[   65.268260]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   65.268280]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   65.268302]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   65.268320]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   65.268326]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   65.268331]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   65.268336]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   65.268340]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   65.268344]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   65.268347] ---[ end trace 1b0e79d86bdac02d ]---
[   65.528825] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
[   65.536956] ------------[ cut here ]------------
[   65.536997] WARNING: at drivers/gpu/drm/i915/intel_display.c:1051 intel_enable_pipe+0xe7/0x190 [i915]()
[   65.536999] Hardware name: HP Compaq 6720s
[   65.537038] PLL state assertion failure (expected on, current off)
[   65.537040] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   65.537098] Pid: 1372, comm: upowerd Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   65.537101] Call Trace:
[   65.537111]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   65.537115]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   65.537137]  [<ffffffffa00b2e97>] intel_enable_pipe+0xe7/0x190 [i915]
[   65.537156]  [<ffffffffa00b7157>] i9xx_crtc_mode_set+0xb37/0x13a0 [i915]
[   65.537175]  [<ffffffffa00b588e>] __intel_set_mode+0x5be/0x970 [i915]
[   65.537195]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   65.537214]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   65.537236]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   65.537255]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   65.537261]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   65.537266]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   65.537271]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   65.537274]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   65.537279]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   65.537282] ---[ end trace 1b0e79d86bdac02e ]---
[   65.646489] ------------[ cut here ]------------
[   65.646527] WARNING: at drivers/gpu/drm/i915/intel_display.c:1051 intel_enable_pipe+0xe7/0x190 [i915]()
[   65.646530] Hardware name: HP Compaq 6720s
[   65.646532] PLL state assertion failure (expected on, current off)
[   65.646534] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   65.646590] Pid: 1372, comm: upowerd Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   65.646592] Call Trace:
[   65.646601]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   65.646605]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   65.646626]  [<ffffffffa00b2e97>] intel_enable_pipe+0xe7/0x190 [i915]
[   65.646645]  [<ffffffffa00b47bd>] i9xx_crtc_enable+0x19d/0x310 [i915]
[   65.646664]  [<ffffffffa00b5a38>] __intel_set_mode+0x768/0x970 [i915]
[   65.646683]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   65.646703]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   65.646725]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   65.646743]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   65.646749]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   65.646754]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   65.646759]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   65.646762]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   65.646767]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   65.646770] ---[ end trace 1b0e79d86bdac02f ]---
[   65.698084] ------------[ cut here ]------------
[   65.698155] WARNING: at drivers/gpu/drm/i915/intel_display.c:1228 assert_pipe+0x102/0x110 [i915]()
[   65.698161] Hardware name: HP Compaq 6720s
[   65.698166] pipe B assertion failure (expected on, current off)
[   65.698169] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   65.698290] Pid: 1372, comm: upowerd Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   65.698295] Call Trace:
[   65.698310]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   65.698320]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   65.698367]  [<ffffffffa00b3442>] assert_pipe+0x102/0x110 [i915]
[   65.698409]  [<ffffffffa00b45b3>] intel_enable_plane+0x33/0xa0 [i915]
[   65.698450]  [<ffffffffa00b47cb>] i9xx_crtc_enable+0x1ab/0x310 [i915]
[   65.698491]  [<ffffffffa00b5a38>] __intel_set_mode+0x768/0x970 [i915]
[   65.698535]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   65.698578]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   65.698627]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   65.698663]  [<ffffffffa0032b06>] status_show+0x46/0x90 [drm]
[   65.698676]  [<ffffffff813f5eb0>] dev_attr_show+0x20/0x60
[   65.698687]  [<ffffffff81214be5>] sysfs_read_file+0xa5/0x1c0
[   65.698697]  [<ffffffff811a01f9>] vfs_read+0xa9/0x180
[   65.698705]  [<ffffffff811a0472>] sys_read+0x52/0xa0
[   65.698715]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   65.698721] ---[ end trace 1b0e79d86bdac030 ]---
[   77.943509] ------------[ cut here ]------------
[   77.943558] WARNING: at drivers/gpu/drm/i915/intel_display.c:1051 intel_enable_pipe+0xe7/0x190 [i915]()
[   77.943561] Hardware name: HP Compaq 6720s
[   77.943563] PLL state assertion failure (expected on, current off)
[   77.943565] Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables dm_crypt snd_hda_codec_analog snd_hda_intel vhost_net acpi_cpufreq mperf coretemp iTCO_wdt iTCO_vendor_support snd_hda_codec e1000e snd_hwdep lib80211_crypt_tkip snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd tun macvtap macvlan hp_wmi sparse_keymap soundcore wl(POF) nfsd auth_rpcgss nfs_acl kvm_intel lockd kvm cfg80211 rfkill lib80211 microcode serio_raw lpc_ich mfd_core ptp sunrpc pps_core uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
[   77.943622] Pid: 572, comm: X Tainted: PF       W  O 3.9.6-200.fc18.x86_64 #1
[   77.943624] Call Trace:
[   77.943633]  [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
[   77.943637]  [<ffffffff8105f066>] warn_slowpath_fmt+0x46/0x50
[   77.943659]  [<ffffffffa00b2e97>] intel_enable_pipe+0xe7/0x190 [i915]
[   77.943677]  [<ffffffffa00b7157>] i9xx_crtc_mode_set+0xb37/0x13a0 [i915]
[   77.943696]  [<ffffffffa00b588e>] __intel_set_mode+0x5be/0x970 [i915]
[   77.943716]  [<ffffffffa00bca56>] intel_set_mode+0x16/0x30 [i915]
[   77.943736]  [<ffffffffa00bdc79>] intel_get_load_detect_pipe+0x269/0x420 [i915]
[   77.943760]  [<ffffffffa00db574>] intel_tv_detect+0x124/0x4e0 [i915]
[   77.943782]  [<ffffffffa003f037>] ? drm_get_edid+0x27/0x2f0 [drm]
[   77.943792]  [<ffffffffa00807c2>] drm_helper_probe_single_connector_modes+0x1d2/0x360 [drm_kms_helper]
[   77.943808]  [<ffffffffa00386af>] drm_mode_getconnector+0x41f/0x470 [drm]
[   77.943821]  [<ffffffffa0029483>] drm_ioctl+0x4d3/0x580 [drm]
[   77.943826]  [<ffffffff811df802>] ? send_to_group+0x182/0x250
[   77.943841]  [<ffffffffa0038290>] ? drm_mode_getcrtc+0xe0/0xe0 [drm]
[   77.943845]  [<ffffffff811dfb2f>] ? fsnotify+0x25f/0x340
[   77.943850]  [<ffffffff811b1827>] do_vfs_ioctl+0x97/0x580
[   77.943854]  [<ffffffff811b1da1>] sys_ioctl+0x91/0xb0
[   77.943859]  [<ffffffff811a0512>] ? sys_write+0x52/0xa0
[   77.943864]  [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
[   77.943867] ---[ end trace 1b0e79d86bdac031 ]---
[   78.054480] ------------[ cut here ]------------
Comment 33 Björn Ruberg 2013-06-22 13:37:24 UTC
Created attachment 81216 [details]
i915_error_state on compaq 6720s
Comment 34 Chris Wilson 2013-06-22 13:45:42 UTC
Bjorn, that is a completely different bug and looks just like a common mesa bug.
Comment 35 Jari Tahvanainen 2016-11-03 12:09:42 UTC
Closing resolved+duplicate as duplicate of closed+fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.