Bug 41340 - vga_switcheroo doesn't work with AMD Radeon HD 6770M
Summary: vga_switcheroo doesn't work with AMD Radeon HD 6770M
Status: RESOLVED DUPLICATE of bug 37528
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-29 09:12 UTC by mlambda
Modified: 2011-10-05 06:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Kernel config (77.98 KB, text/plain)
2011-09-29 09:12 UTC, mlambda
no flags Details
output of 'dmesg' before switch (63.08 KB, text/plain)
2011-09-29 09:13 UTC, mlambda
no flags Details
Output of 'lspci -vvnn' (11.92 KB, text/plain)
2011-09-29 09:14 UTC, mlambda
no flags Details
/var/log/syslog (222.11 KB, text/plain)
2011-09-29 09:15 UTC, mlambda
no flags Details
/var/log/Xorg.0.log (32.56 KB, text/plain)
2011-09-29 09:15 UTC, mlambda
no flags Details
/var/log/Xorg.1.log (38.99 KB, text/plain)
2011-09-29 09:16 UTC, mlambda
no flags Details
/proc/cpuinfo (6.79 KB, text/plain)
2011-09-29 11:09 UTC, mlambda
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mlambda 2011-09-29 09:12:25 UTC
Created attachment 51758 [details]
Kernel config

How to reproduce:
cd /sys/kernel/debug/vgaswitcheroo/; echo ON >switch; echo DDIS >switch
Hit Ctrl+Alt+Backspace to restart X-Server

Expected Result:
Switch to discrete GPU

Actual Result:
System freezes, but can be restarted with Ctrl+Alt+Esc

Notebook: HP Pavilion dv7 6104eg
Kernel: latest git kernel (commit d5767c53535ac79758084773418e0ad186aba4a2), Linux hp 3.1.0-rc8-custom #1 SMP Wed Sep 28 21:23:06 CEST 2011 x86_64 x86_64 x86_64 GNU/Linux
Distribution: Ubuntu 11.04 64bit

lsmod:
Module                  Size  Used by
vboxnetadp             13340  0 
vboxnetflt             28297  0 
vboxdrv               252684  2 vboxnetadp,vboxnetflt
radeon               1016473  0 
iwlagn                311183  0 
ttm                    72079  1 radeon
r8169                  55918  0

If you need any additional information, please tell me!
Comment 1 mlambda 2011-09-29 09:13:33 UTC
Created attachment 51759 [details]
output of 'dmesg' before switch
Comment 2 mlambda 2011-09-29 09:14:10 UTC
Created attachment 51760 [details]
Output of 'lspci -vvnn'
Comment 3 mlambda 2011-09-29 09:15:02 UTC
Created attachment 51761 [details]
/var/log/syslog
Comment 4 mlambda 2011-09-29 09:15:44 UTC
Created attachment 51762 [details]
/var/log/Xorg.0.log
Comment 5 mlambda 2011-09-29 09:16:18 UTC
Created attachment 51763 [details]
/var/log/Xorg.1.log
Comment 6 mlambda 2011-09-29 11:09:03 UTC
Created attachment 51776 [details]
/proc/cpuinfo
Comment 7 Alex Deucher 2011-09-29 11:52:30 UTC
You have a mux-less system which means the radeon card is not actually connected to any physical displays as such there is no way for you to switch to the radeon card with vgaswitcheroo.  In order to support mux-less systems the xserver needs support for decoupling display and rendering and the drm needs support for sharing buffers between drivers.  This is a large amount of work and probably won't happen in the short term.
Comment 8 mlambda 2011-09-29 13:05:42 UTC
(In reply to comment #7)
> You have a mux-less system which means the radeon card is not actually
> connected to any physical displays as such there is no way for you to switch to
> the radeon card with vgaswitcheroo.  In order to support mux-less systems the
> xserver needs support for decoupling display and rendering and the drm needs
> support for sharing buffers between drivers.  This is a large amount of work
> and probably won't happen in the short term.

I have a BIOS Option "Switchable Graphics Mode":

Fixed Mode - Graphics adapter switch is based on AC/DC transition or user selectable options under OS
Dynamic Mode - Seamlessy switch to internal or external graphics adapter based on application needs

If I select "Fixed Mode" the BIOS still enables the Intel graphics even on AC power and vga_switcheroo doesn't work. Does this setting make any difference in principle?
Comment 9 mlambda 2011-09-29 13:41:47 UTC
According to http://linux-hybrid-graphics.blogspot.com/2011/08/bios-update-has-been-released-for-amd.html vgaswitcheroo should work when using the "Fixed Mode" BIOS setting, but I still get the same error.
Comment 10 Alex Deucher 2011-10-05 06:32:57 UTC

*** This bug has been marked as a duplicate of bug 37528 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.